How to hibernate Linux Mint LMDE XFCE & GNOME

Archived topics about LMDE 1
Forum rules
User avatar
on4aa
Level 2
Level 2
Posts: 55
Joined: Wed Nov 18, 2009 5:30 am
Location: Hasselt, Belgium

How to hibernate Linux Mint LMDE XFCE & GNOME

Postby on4aa » Tue Mar 20, 2012 2:42 pm

I got this great info from http://experiencinglinux.blogspot.com/2011/09/lmde-update.html and
tested it successfully on a Lenovo SL510 notebook running LMDE 64-bit XFCE.

Please, note that you will need a functional swap partition for hibernate to work.
First, make sure that the following packages are installed:

Code: Select all

sudo apt-get install acpi acpi-support acpi-support-base acpi-fakekey acpid acpitool pm-utils powermgmt-base hibernate

For XFCE, you will also need:

Code: Select all

sudo apt-get install xfce4-power-manager xfce4-power-manager-data xfce4-power-manager-plugins

whereas for GNOME, you will need:

Code: Select all

sudo apt-get install gnome-power-manager

Next, take note of the device name /dev/sdx and the UUID of your swap partition:

Code: Select all

cat /etc/fstab

Make sure that RESUME=UUID= is filled out correctly in the following configuration file:

Code: Select all

gksu gedit /etc/initramfs-tools/conf.d/resume

Open GRUB's configuration file and write the swap device name
between the quotes following the variable GRUB_CMDLINE_LINUX="resume=/dev/sdax" where x is the swap partition number

Code: Select all

gksu gedit /etc/default/grub

Finally,

Code: Select all

sudo update-initramfs -u && update-grub
and reboot.
Hibernate should work now. Keep your computing green :mrgreen:
Last edited by on4aa on Sun Dec 23, 2012 11:25 am, edited 2 times in total.

zShell
Level 1
Level 1
Posts: 1
Joined: Sun Apr 01, 2012 8:57 am

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby zShell » Sun Apr 01, 2012 9:13 am

Hey man I ran into some problems

First I couldn't get the

Code: Select all

sudo apt-get install acpi acpi-support acpi-support-base acpi-fakekey acpid acpitool pm-utils powermgmt-base hibernate
part, it wouldnt find the repo and when I went and DL it manually it wouldnt install, said there was an error during process

There was nothing in /etc/initramfs-tools/conf.d/

And after running

Code: Select all

sudo update-initramfs -u && update-grub
I rebooted and got a kernel panic just after selecting Mint in grub (hard freeze with blinking caps lock and scroll lock leds blinking)

It did restart fine the second time, but I'm still unable to hibernate :(

I got a Dell Vostro with Mint 12 LXDE, what could be the problem

vincezd
Level 1
Level 1
Posts: 15
Joined: Wed May 23, 2012 5:16 pm

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby vincezd » Mon Jun 18, 2012 1:25 pm

Thanks a lot !!

donv
Level 1
Level 1
Posts: 11
Joined: Mon Oct 04, 2010 5:38 pm

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby donv » Tue Jul 17, 2012 1:00 pm

Just worked great for me on LMDE/Mate 201204, thanks! Only issue was that the combined command line:

Code: Select all

sudo update-initramfs -u && update-grub
did not execute update-grub as root/sudo (error returned), so I had to enter a separate

Code: Select all

sudo update-grub
to complete the action as root. Also, note gedit is now replaced by pluma as the text editor, apparently (at least on my default install).

bfrancom
Level 1
Level 1
Posts: 5
Joined: Tue Aug 21, 2012 12:53 pm

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby bfrancom » Tue Aug 21, 2012 12:58 pm

Thanks! This worked nicely for me on LMDE XFCE.
I had to change the UUID to what LVM showed in lvdisplay, and also had to change the GRUB_CMDLINE_LINUX to my logical volume path.

User avatar
luis.nando
Level 1
Level 1
Posts: 47
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby luis.nando » Tue Aug 28, 2012 11:40 am

Hello guys, I have a question related to this thread. How to hibernate and suspend in the command line, so I can assign keystrokes in xfce??
thanks
ASUS UL30a2 LMDE 64bit

TarasMK
Level 1
Level 1
Posts: 19
Joined: Fri Nov 12, 2010 3:40 pm

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby TarasMK » Fri Oct 19, 2012 8:36 am

Hi all,

I had another configuration without swap partition and with swap file. Some steps would differ in this case and it's described here: http://ubuntuforums.org/showthread.php?t=1042946
May be someone else will gain from it too ;)

jjaythomas
Level 5
Level 5
Posts: 603
Joined: Sun Mar 07, 2010 12:52 pm

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby jjaythomas » Fri Oct 19, 2012 3:42 pm

I believe also...

your swap partition need to be => then installed memory (I usually use 1.25 installed memory for swap) I.E. 5MB if 4MB sticks installed

J.Jay

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby bigbenaugust » Fri Oct 19, 2012 8:43 pm

luis.nando wrote:Hello guys, I have a question related to this thread. How to hibernate and suspend in the command line, so I can assign keystrokes in xfce??
thanks


I do it with: pm-suspend or pm-hibernate.

I set this up on my netbook at home yesterday, but didn't install any other packages other than what came with the LMDE XFCE install... but it seems that I should have ACPI installed.

EDIT: I checked, acpi was part of the default LMDE install on my machines.

Also, pm-suspend and pm-hibernate (symlinks to /usr/lib/pm-utils/bin/pm-action) are world-executable. I'd been running them via sudo all this time. Oops.
--Ben

User avatar
luis.nando
Level 1
Level 1
Posts: 47
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby luis.nando » Wed Dec 19, 2012 7:11 am

Hello all,

Is there any way of doing this using mate? I made a new install in my system using btrfs and mate. I followed the tutorial http://forums.linuxmint.com/viewtopic.php?f=197&t=100659&p=635755&hilit=btrfs+lmde+snapshots#p635755, but after the system was ready I couldn't set the hibernation changing the parameters as suggested in this forum entry. Does someone have any idea of how to solve this case?

My fstab:

Code: Select all

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc /proc proc defaults 0 0
/dev/sda1 / btrfs defaults,subvol=@ 0 0
/dev/sda1 /home btrfs defaults,subvol=home 0 0
/dev/sda5   none   swap   sw   0   0


My /etc/initramfs-tools/conf.d/resume

Code: Select all

RESUME=/dev/sda5


Best regards,

Luís Fernando
ASUS UL30a2 LMDE 64bit

talora
Level 1
Level 1
Posts: 6
Joined: Mon Jan 30, 2012 12:38 am

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby talora » Mon Feb 25, 2013 8:28 am

It worked perfectly on Linux Mint Debian Edition. Thanks a lot!

grokenberger
Level 1
Level 1
Posts: 3
Joined: Mon Oct 29, 2012 4:43 am

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby grokenberger » Fri May 03, 2013 8:20 am

Now my machine hibernates again. Thanks a lot! This has been bugging me since way too long.

tunist
Level 2
Level 2
Posts: 50
Joined: Thu Feb 28, 2013 8:45 pm

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby tunist » Sun Nov 03, 2013 3:12 pm

hmm.. maybe i missed something here.. but i used this process to activate hibernation on lmde here and was unable to reboot..
the hibernate and suspend buttons have always been visible and generally the suspend has been ok and i 'thought' hibernate worked at least once.
recently though they both stopped being triggered when i pressed their buttons and instead the screen was locked.
i thought maybe this process would resolve the issue, though my challenge appears to be located elsewhere..

if anyone has any other ideas i would appreciate hearing them.

screenshot
Level 1
Level 1
Posts: 17
Joined: Sat Feb 01, 2014 8:54 am

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby screenshot » Sat Feb 01, 2014 12:47 pm

does it work for lmde mate also? i tried it once and it did make some snapshots of the system and worked once, but most of the time it just hangs during the loading animation :roll:

kurotsugi
Level 6
Level 6
Posts: 1055
Joined: Fri Jan 25, 2013 3:54 am

Re: How to hibernate Linux Mint LMDE XFCE & GNOME

Postby kurotsugi » Sat Feb 01, 2014 3:01 pm

if you could disable plymouth and grab the log file it will be easier for us to identify your problem.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 3 guests