Keyboard vol. control bound to wrong output device

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 13
Joined: Sat Nov 12, 2011 9:32 am

Keyboard vol. control bound to wrong output device

Postby christian.convey » Tue Jun 19, 2012 8:12 am

I'm using Linux Mint 13 (Ubuntu-based) on a Dell M6500 laptop. The following issue occurs on all of the desktop environments I've tried: Cinnamon, Mate, Gnome Classic

My laptop has two audio output devices:
#1 = RV710/730 HDMI Audio [Radeon HD 4000 Series] Digital Stereo (HDMI)
#2 = Built-in Audio Analog Stereo
In System Settings -> Sound, on the Output tab, they're listed in that order.

When I play movies, music, etc. the audio goes to the Built-in Audio Analog Stereo. Which is good - that's what I want.

However, my external keyboard has a volume control wheel. Whenever I boot into Mint, the wheel appears bound to the volume of the #1 audio device mentioned above.

The only way I can get it to be bound to the #2 audio device is to go into System Settings --> Sound, and on the "Output" tab, select the "Built-in Audio Analog Stereo" setting. When I do this, the volume wheel becomes bound to that output device, as I want.

The problem is, this binding is forgotten whenever I shut the laptop down (or log out, I'm not sure which).

Any idea how I can fix this? It hasn't been a problem on previous versions of Mint or Ubuntu.

Level 2
Level 2
Posts: 81
Joined: Sat Aug 11, 2012 11:49 pm

Re: Keyboard vol. control bound to wrong output device

Postby xclusive585 » Wed Nov 21, 2012 1:44 am

Bump. I am having the same exact issue...

“The only way to fix Linux is to take one distro, one set of components as a baseline, abandon everything else and everyone should just contribute to this single Linux..."

Return to “Sound, Multimedia, & Codecs”