Need to patch kernel source, proper way?

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 4
Joined: Tue Feb 28, 2012 3:18 pm

Need to patch kernel source, proper way?

Postby ckirk » Mon Jul 16, 2012 2:19 pm

I'm running LMDE 3.2.0-2-amd64 and need to incorporate some patches to my kernel to fix suspend issues. I know the fix made it into kernel 3.4 but isn't in 3.2 as the problem is reproducible on my system. I have read a few HOWTO guides and after experimenting with building custom kernels from, liquorix, etc.. I would much rather stick with the standard kernel to mitigate any potential side effects - some of which I've seen including troubles with compiling nvidia DKMS, virtualbox modules, and other random system issues surrounding my procfs instances.

It seems that when I try to compile the "standard" kernel as above that is booted, it instead downloads the 3.2.9 sources and builds from that. I have tried that but in the end I wasn't able to get the system to recognize those headers. Am I missing something in trying to merely patch the existing kernel version shipping with LMDE?

Thanks in advance for the help.

Level 2
Level 2
Posts: 77
Joined: Mon Jun 18, 2012 4:26 pm

Re: Need to patch kernel source, proper way?

Postby titetanium » Fri Jul 20, 2012 6:36 pm

In Debian testing, the 3.2.0-2 kernels have been replaced with the 3.2.0-3 version....I'd suggest you upgrade your kernel to that version as well as download the headers and/or source for that version. If all you are doing is patching to get a module, the headers should do the trick. If you need more than replacing a module, then u need the kernel, headers, and sources (all need to be the same version) installed, if you want to patch against the distribution kernel.

The sources once installed are in a compressed package that you need to unpack. It is highly recommended that you copy the source package to your home directory, create a src directory, uncompress the kernel source and compile from there.

Good luck.

P.S. What patch is this that you need to patch into the kernel source?

Return to “Archive”

Who is online

Users browsing this forum: Bing [Bot] and 0 guests