How to get the date to show in MATE (SOLVED)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
lou002
Level 1
Level 1
Posts: 22
Joined: Sun Jan 23, 2011 4:28 pm
Location: Greensburg, Pennslyvania
Contact:

How to get the date to show in MATE (SOLVED)

Post by lou002 » Thu Aug 09, 2012 1:59 am

Hello,

I'm back after a year and 7 months (!?) wow..first let me say hello again, I can't believe I'm back with Linux Mint!

Anyway, here I am using Linux Mint 13 MATE edition and I have a question. The date only reads "Thu August 9," and then that's it. why is there a comma there if there's no year showing? And how do I get the year to show?

Thanks in advance. I know it's a little quirk but the English major/perfectionist in me won't let that go :)

caribriz, everything you just described did not come up for me. I found out Linux Mint 13 had an XFCE version, so I switched to that. Maybe I'll go back and give MATE or Cinnamon a try again.
Last edited by lou002 on Sat Aug 11, 2012 11:59 pm, edited 1 time in total.

den68
Level 1
Level 1
Posts: 45
Joined: Sun Jun 17, 2012 12:32 pm

Re: How to get the date to show in MATE

Post by den68 » Thu Aug 09, 2012 3:06 am

is it because you left for almost 2 years that you are wondering now what year it is ? :wink:
sorry, I don't have an answer to your question, but couldn't resist to say :D
it got me wondering as well, I guess the comma is just to separate with the hour. Showing the year would be a waste of space in my opinion, but I agree it should at least be an option.

sorry for not helping :D

remoulder
Level 17
Level 17
Posts: 7636
Joined: Fri May 09, 2008 1:14 pm
Contact:

Re: How to get the date to show in MATE

Post by remoulder » Thu Aug 09, 2012 1:06 pm

lou002 wrote:how do I get the year to show
Not running MATE so may be wrong, but have you tried right clicking on the date? Is there a preferences/options there?
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

User avatar
lou002
Level 1
Level 1
Posts: 22
Joined: Sun Jan 23, 2011 4:28 pm
Location: Greensburg, Pennslyvania
Contact:

Re: How to get the date to show in MATE

Post by lou002 » Fri Aug 10, 2012 5:20 pm

den68 wrote:is it because you left for almost 2 years that you are wondering now what year it is ? :wink:
LOL! that made me chuckle
sorry, I don't have an answer to your question, but couldn't resist to say :D
it got me wondering as well, I guess the comma is just to separate with the hour. Showing the year would be a waste of space in my opinion, but I agree it should at least be an option.

sorry for not helping :D
No worries, you gave a laugh and some levity to a thread that could have gone wrong ;)

And yes! I first used Mint in January of 2011, used it till about June of 2011 then moved back to windows for a short while, then started using linux again in about April of 2012. :D I've gone form distro to distro, but as long as mint keeps MATE, I'll be fine. I don't like GNOME3

User avatar
lou002
Level 1
Level 1
Posts: 22
Joined: Sun Jan 23, 2011 4:28 pm
Location: Greensburg, Pennslyvania
Contact:

Re: How to get the date to show in MATE

Post by lou002 » Fri Aug 10, 2012 5:21 pm

remoulder wrote:
lou002 wrote:how do I get the year to show
Not running MATE so may be wrong, but have you tried right clicking on the date? Is there a preferences/options there?
I hope that attachment works, but nope no setting.
Attachments
blah
blah
Screenshot.png (120.23 KiB) Viewed 852 times

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: How to get the date to show in MATE

Post by caribriz » Sat Aug 11, 2012 6:53 am

Try:
Menu > System tools > Configuration Editor
apps > panel > applets > applet_clock > prefs

Double-click format line - in Value box, type custom, click ok

Double-click custom_format line - type in your desired date format
eg. Saturday 11 August 2012 03:52pm
would be

Code: Select all

 %A %e %B %Y %I:%M%P
click ok
Configuration Editor - prefs.png
Configuration Editor - prefs.png (112.17 KiB) Viewed 838 times
caribriz
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

User avatar
lou002
Level 1
Level 1
Posts: 22
Joined: Sun Jan 23, 2011 4:28 pm
Location: Greensburg, Pennslyvania
Contact:

Re: How to get the date to show in MATE

Post by lou002 » Sat Aug 11, 2012 6:58 pm

caribriz wrote:Try:
Menu > System tools > Configuration Editor
apps > panel > applets > applet_clock > prefs

Double-click format line - in Value box, type custom, click ok

Double-click custom_format line - type in your desired date format
eg. Saturday 11 August 2012 03:52pm
would be

Code: Select all

 %A %e %B %Y %I:%M%P
click ok
Configuration Editor - prefs.png
caribriz
That didn't help at all. :( there's no 'ok' to click, I did exactly as you said, even following your photo as a guide and nothing.

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: How to get the date to show in MATE

Post by caribriz » Sat Aug 11, 2012 8:39 pm

Place your cursor exactly on the word format and double-click - you get a pop up box where you can type in custom then click ok
Screenshot-2.png
Screenshot-2.png (81.4 KiB) Viewed 804 times
Then double-click exactly on the words custom_format - you get another pop up box where you type your desired layout, then click ok
Screenshot-3.png
Screenshot-3.png (103.29 KiB) Viewed 804 times
Then you should have something like this
Screenshot-1.png
Screenshot-1.png (62.42 KiB) Viewed 804 times
caribriz
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: How to get the date to show in MATE (SOLVED)

Post by caribriz » Sun Aug 12, 2012 6:34 pm

caribriz, everything you just described did not come up for me. I found out Linux Mint 13 had an XFCE version, so I switched to that. Maybe I'll go back and give MATE or Cinnamon a try again.
Well, the problem isn't really solved then, is it?

I'd be interested to see if anyone else using LM13 Mate can follow the above instructions to get the year to show in the date (in the panel).

It worked for me not only on LM13 Mate, but in LM9 Gnome which has a similar default date format.
In LM9 Gnome I used similar steps with gconf-editor.

caribriz
Last edited by caribriz on Sun Aug 12, 2012 11:21 pm, edited 1 time in total.
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

squeezy
Level 5
Level 5
Posts: 565
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: How to get the date to show in MATE (SOLVED)

Post by squeezy » Sun Aug 12, 2012 7:49 pm

caribriz wrote:I'd be interested to see if anyone else using LM13 Mate can follow the above instructions to get the year to show in the date (in the panel).
Yep, works perfectly well here. I've got MATE 1.4 installed on a custom Ubu 12.04 setup, but that's pretty much LM 13 anyway :lol:

One thing, my mconf key is called clock_screen0 instead of applet_clock. Do you have MATE 1.2 by chance?

PS - You can click in the field and edit the info there directly as well.
Attachments
mate_1.4.png
mate_1.4.png (102.23 KiB) Viewed 757 times

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: How to get the date to show in MATE (SOLVED)

Post by caribriz » Sun Aug 12, 2012 8:51 pm

Thanks for checking, squeezy.
squeezy wrote:One thing, my mconf key is called clock_screen0 instead of applet_clock. Do you have MATE 1.2 by chance?
Yes, I have Mate 1.2 - the Configuration Editor is 1.2.0.

Maybe that was why the OP couldn't follow the instructions - they may have Mate 1.4 and the layout is not quite the same as what I saw with Mate 1.2 :?:

At least, we now know if they have Mate 1.4, they can follow your picture instead - editing clock_screen0> prefs.
If they have Mate 1.2 - follow my picture and edit applet_clock> prefs.
It works in both versions.

Thanks ...
caribriz
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

Post Reply

Return to “Newbie Questions”