Compiz CCSM not working for me on Mint 10?

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 29
Joined: Mon Nov 29, 2010 9:22 am

Compiz CCSM not working for me on Mint 10?

Postby bullpen7979 » Tue Sep 11, 2012 1:39 pm

Greetings list,

Another compiz question. Have Mint 10 installed. I have the intel 82845G/GL/GE
graphics card installed. (64mb) I know, not a bunch..but still...I have read enough to know ( I think) that the drivers installed during the OS install routine should be good enough for the hardware. Please correct me on this if I'm wrong. And, if I am, how would I go about installing the proper drivers? I am not familiar with command line....

I have not had a problem using compiz on other machines, but for some reason none of the effects are working for me.

I have the following items ticked in CCSM:

Gnome compatibility

Nothing checked

Desktop cube
Rotate cube
Viewport switcher

Window decoration (read enough to know this is kind of a must)
Minimize effect
Wobbly windows

There were some other boxes checked in the Utility, Image loading, and window management sections, but I didn't figure those were all that important...Again, I have always gotten it to work before, so not sure why not now.

Any suggestions as to what I might check or do?

Thanks for your input, listers...


Level 17
Level 17
Posts: 7645
Joined: Fri May 09, 2008 1:14 pm

Re: Compiz CCSM not working for me on Mint 10?

Postby remoulder » Tue Sep 11, 2012 2:04 pm

This version of mint is now obsolete and no longer supported. You should consider upgrading.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

Level 1
Level 1
Posts: 29
Joined: Mon Nov 29, 2010 9:22 am

Re: Compiz CCSM not working for me on Mint 10?

Postby bullpen7979 » Tue Sep 11, 2012 9:51 pm

I had mint mate 13 installed, and read that CCSM is not an available window manager with the default installation. I tried changing the window manager per some instructions on the posts that I saw, somehow missed a step or got it wrong. My box booted up to a desktop that flashed every 5 seconds. I did not know how to fix that. I installed Mint 10, because A) I figured that would be a faster way to solve the problem, and B) I had good experiences with that before, as I have it installed on my netbook with no issues.

Is there anyone who might know how to solve the problem? Recommending that someone upgrade to a new version that doesn't (by default) contain the functionality I was asking about in the first place would kind of be the long way around the barn. (or so it seems).

Perhaps there are some in the know who might be able to recommend some troubleshooting measures with my current version?

EDIT - if it helps, inxi -G output:
ejl@ejl-Dimension-2400 ~ $ inxi -G
Graphics: Card Intel 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device X.Org 1.9.0 Res: 1280x1024@0.0hz
GLX Renderer Software Rasterizer GLX Version 2.1 Mesa 7.9-devel
ejl@ejl-Dimension-2400 ~ $

Further, ran compiz check and got the following output:

Distribution: Linux Mint
Desktop environment: GNOME
Graphics chip: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
Driver in use: vesa
Rendering method: AIGLX

Checking if it's possible to run Compiz on your system... [SKIP]

Checking for hardware/setup problems... [SKIP]

At least one check had to be skipped:
Error: vesa driver in use

Would you like to know more? (Y/n) y

The vesa driver is not capable of running Compiz, you need to install
the proper driver for your graphics card.

Now, begging the question, how is it that I install the proper driver? I had read somewhere where the driver installed by mint is as good as any....


Return to “Compiz, Conky, Docks, & Widgets”