What is going on with my system ? { SOLVED }

Archived topics about LMDE 1
Forum rules
scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

What is going on with my system ? { SOLVED }

Postby scottjge » Sat Sep 29, 2012 7:10 pm

I think that I may have a unresolvable problem. I changed my sources.lst and then update the system to UP5. Everything went as smooth as silk with no problems that I new of. I then tried to intall mint-meta-debian-mate, but it would not install and game me the error that I had unmet dependencies which was
mint-meta-debian-core. So I tried to install mint-meta-debian-core but I got the error that I had unmet dependencies which was mint-debian-artwork. So I tried to install
mint-debian-artwork which game me another unmet dependency and so on............untill I got to defoma. You kinda get the idea.....It seems like there are a lot of file that are not installed on my system. WHY ?

Everything seems to work alright, I have been using the system in this condition for about a week with no ill effects. I am running LMDE 201204 with Mate. Has anyone else had any of these problems if so, how did you resolve them. I just can't seem to find the answers on my own so I need some help with this one.

Would it be better if I just start from scratch and re-install LMDE from the DVD ?

Any help or suggestions would be greatly appreciated.

Many thanks in advance,
scottjge
Last edited by scottjge on Sun Sep 30, 2012 1:49 pm, edited 1 time in total.

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 7:17 pm

scotthge wrote: I changed my sources.lst and then update the system to UP5.

changed from what to what?
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 8:42 pm

Hi Zerozero,

My apt sources were changed to

Code: Select all

 Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free

I can not remember what they were when I first put LMDE on my computer.

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 9:05 pm

this is a system fully updated to UP5 and the pkgs you mention are here at v.

Code: Select all

zerozero@wine ~ $ apt policy mint-meta-debian-mate mint-meta-debian-core mint-artwork-debian
mint-meta-debian-mate:
  Installed: 2012.09.14
  Candidate: 2012.09.14
  Version table:
 *** 2012.09.14 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status
mint-meta-debian-core:
  Installed: 2012.09.14
  Candidate: 2012.09.14
  Version table:
 *** 2012.09.14 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status
mint-artwork-debian:
  Installed: 2012.09.11
  Candidate: 2012.09.11
  Version table:
 *** 2012.09.11 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status

so please give us the output of

Code: Select all

apt policy mint-meta-debian-mate mint-meta-debian-core mint-artwork-debian
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 9:12 pm

Here is my output:

Code: Select all

glenn@laptop:~$ apt policy mint-meta-debian-mate mint-meta-debian-core mint-artwork-debian
No command 'apt' found, did you mean:
 Command 'aptd' from package 'aptdaemon' (main)
 Command 'opt' from package 'llvm' (main)
 Command 'atp' from package 'atp' (main)
 Command 'apm' from package 'apmd' (main)
 Command 'apf' from package 'apf-firewall' (main)
 Command 'apg' from package 'apg' (main)
 Command 'gpt' from package 'gpt' (main)
 Command 'ant' from package 'ant' (main)
 Command 'at' from package 'at' (main)
 Command 'pat' from package 'dist' (main)
 Command 'aft' from package 'aft' (main)
apt: command not found

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 9:21 pm

well, on purpose or not we discovered another pkg that is missing in your install >> mintsystem
so that command as to be

Code: Select all

apt-cache policy  mint-meta-debian-mate mint-meta-debian-core mint-artwork-debian
(this way has to work :wink: )
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 9:34 pm

Hey hey it worked or atleast I got some output.

Code: Select all

glenn@laptop:~$ apt-cache policy  mint-meta-debian-mate mint-meta-debian-core mint-artwork-debian
mint-meta-debian-mate:
  Installed: (none)
  Candidate: 2012.09.14
  Version table:
     2012.09.14 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
mint-meta-debian-core:
  Installed: (none)
  Candidate: 2012.09.14
  Version table:
     2012.09.14 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
mint-artwork-debian:
  Installed: (none)
  Candidate: 2012.09.11
  Version table:
     2012.09.11 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages


which is what we already new but it worked.

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 9:38 pm

what is exactly the output when you try

Code: Select all

sudo apt-get install mint-artwork-debian
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 9:46 pm

Output:

Code: Select all

sudo apt-get install mint-artwork-debian
[sudo] password for glenn:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mint-artwork-debian : Depends: ttf-ubuntu-font-family but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 9:50 pm

ok lets keep the chase

Code: Select all

sudo apt-get install ttf-ubuntu-font-family
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 9:53 pm

This is where I stopped chasing the problem, when I got this message.

Code: Select all

glenn@laptop:~$ sudo apt-get install ttf-ubuntu-font-family
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ttf-ubuntu-font-family : Depends: defoma but it is not installable
E: Unable to correct problems, you have held broken packages.

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 9:59 pm

one step back: how did you updated to UP5? mintupdate? sudo apt-get upgrade? sudo apt-get dist-upgrade?

what is the output of

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 10:13 pm

Yes, this is the way that I updated using the terminal: sudo apt-get update && sudo apt-get dist-upgrade


Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
[sudo] password for glenn:
Ign http://packages.linuxmint.com debian InRelease
Get:1 http://packages.linuxmint.com debian Release.gpg [197 B]
Hit http://debian.linuxmint.com testing InRelease         
Get:2 http://packages.linuxmint.com debian Release [15.6 kB]           
Hit http://debian.linuxmint.com testing/updates InRelease                     
Ign http://debian.linuxmint.com testing InRelease                             
Hit http://debian.linuxmint.com testing/main amd64 Packages/DiffIndex
Get:3 http://packages.linuxmint.com debian/main amd64 Packages [16.8 kB]
Hit http://debian.linuxmint.com testing/contrib amd64 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/non-free amd64 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/contrib Translation-en/DiffIndex
Hit http://debian.linuxmint.com testing/main Translation-en/DiffIndex
Hit http://debian.linuxmint.com testing/non-free Translation-en/DiffIndex
Hit http://debian.linuxmint.com testing/updates/main amd64 Packages
Hit http://debian.linuxmint.com testing/updates/contrib amd64 Packages
Hit http://debian.linuxmint.com testing/updates/non-free amd64 Packages
Get:4 http://packages.linuxmint.com debian/upstream amd64 Packages [5,387 B]
Get:5 http://packages.linuxmint.com debian/import amd64 Packages [63.3 kB]
Hit http://debian.linuxmint.com testing Release.gpg     
Hit http://debian.linuxmint.com testing Release                       
Hit http://debian.linuxmint.com testing/main amd64 Packages/DiffIndex 
Hit http://debian.linuxmint.com testing/non-free amd64 Packages/DiffIndex
Ign http://packages.linuxmint.com debian/import Translation-en_US
Ign http://packages.linuxmint.com debian/import Translation-en
Ign http://packages.linuxmint.com debian/main Translation-en_US
Ign http://packages.linuxmint.com debian/main Translation-en
Ign http://packages.linuxmint.com debian/upstream Translation-en_US
Ign http://packages.linuxmint.com debian/upstream Translation-en
Ign http://debian.linuxmint.com testing/updates/contrib Translation-en_US
Ign http://debian.linuxmint.com testing/updates/contrib Translation-en
Ign http://debian.linuxmint.com testing/updates/main Translation-en_US
Ign http://debian.linuxmint.com testing/updates/main Translation-en
Ign http://debian.linuxmint.com testing/updates/non-free Translation-en_US
Ign http://debian.linuxmint.com testing/updates/non-free Translation-en
Ign http://debian.linuxmint.com testing/main Translation-en_US
Ign http://debian.linuxmint.com testing/main Translation-en
Ign http://debian.linuxmint.com testing/non-free Translation-en_US
Ign http://debian.linuxmint.com testing/non-free Translation-en
Fetched 101 kB in 6s (16.7 kB/s)                                               
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 10:26 pm

have you tried

Code: Select all

sudo apt-get install defoma
(the strange thing is that all those packages are peaceful installed in the systems i checked: one tracking UP5 and another tracking testing)
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 10:31 pm

Yes I have tried and then quit trying and come to the conclusion that it may not be resolvable. Here is my output.

Code: Select all

sudo apt-get install defoma
[sudo] password for glenn:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package defoma is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'defoma' has no installation candidate

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sat Sep 29, 2012 11:11 pm

ok, i see the problem:
1- ttf-ubuntu-font-family depends on defoma;
2- mint-artwork-debian depends on ttf-ubuntu-font-family;
3- mint-meta-debian-core depends on mint-artwork-debian;
4- mint-meta-debian-mate depends on mint-meta-debian-core

Code: Select all

zerozero@deb-kde ~ $ apt-cache depends ttf-ubuntu-font-family | grep defoma
  Depends: defoma
zerozero@deb-kde ~ $ apt-cache depends mint-meta-debian-core | grep mint-artwork-debian
  Depends: mint-artwork-debian
zerozero@deb-kde ~ $ apt-cache depends mint-meta-debian-mate | grep mint-meta-debian-core
  Depends: mint-meta-debian-core
zerozero@deb-kde ~ $ apt-cache depends mint-artwork-debian | grep ttf-ubuntu-font-family
  Depends: ttf-ubuntu-font-family
zerozero@deb-kde ~ $

in short all this packages are dependent on defoma but it was removed from testing and unstable considered obsolete by fontconfig

there's no way around this unless Clem updates the packages dependencies.
if you are asking why some have this issue (you) and others not (me) the package was removed in may and the last lmde respins done in april, so unless this pkg was uninstalled (as it seems it was in your system) there should be no problem.
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sat Sep 29, 2012 11:38 pm

Thank you zerozero. So if I understand you correctly. There is no fix at this time so the problem is unresolvable. So will there fix in the future or should I do a clean install when the new Iso with UP5 comes out?

Again I want to thank you so much for taking the time to help me sort this problem out. I really appreciate your expertise. It takes a special person to surf the forum and help everyone out my friend, and you are certainly one of those people.Thank you so much!

scottjge

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sun Sep 30, 2012 12:39 am

very kind words :oops:

there's (almost always) a way:
debian has this useful snapshot of old archives at http://snapshot.debian.org/ and we can find the missing defoma pkg at http://snapshot.debian.org/package/defo ... ma_0.11.12 (you want always the first option, not the one that says debian-ports)
probably you have to d/l the 3 pkgs (check if you have the other 2 or they are also missing); after that is just right-click and install with gdebi :D
Image

[ bliss of ignorance ]

scottjge
Level 4
Level 4
Posts: 242
Joined: Sun Sep 13, 2009 8:17 pm

Re: What is going on with my system ?

Postby scottjge » Sun Sep 30, 2012 12:20 pm

Well I run into a little of a snaf-foo. I need to find libwbclient0 (= 2:3.6.6-2) in order to install samba. I check the archives that you pointed me too but it is not present and I also google'd and still can not find the correct file. If I could bother once more for some of your knowledge, I would certainly appreciate it. Would you know of anywhere that I might be able to find this download?

scottjge

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: What is going on with my system ?

Postby zerozero » Sun Sep 30, 2012 12:28 pm

that lib should be available in the repos

Code: Select all

zerozero@wine ~ $ apt policy libwbclient0
libwbclient0:
  Installed: 2:3.6.6-2
  Candidate: 2:3.6.6-2
  Version table:
 *** 2:3.6.6-2 0
        500 http://mirror.rts-informatique.fr/linuxmint/debian/incoming/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
Image

[ bliss of ignorance ]


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 5 guests