Can't Get Network Proxy To Work

Archived topics about LMDE 1
Forum rules
TheAndyBob
Level 1
Level 1
Posts: 19
Joined: Sat Oct 10, 2009 10:23 pm

Can't Get Network Proxy To Work

Postby TheAndyBob » Sun Oct 21, 2012 11:42 pm

Hello,
So I'm trying to connect to a proxy server on Linux Mint Debian. Off the bat, I can type in the proxy information in Firefox and it works fine, I google "what's my ip", and it shows the correct IP for my proxy server. However, when I try to type it into Mint's Network Proxy setting, it does not show me correct proxy ip when I look it up in google. The command I'm typing in terminal to setup the proxy is:

Code: Select all

ssh -D 8080 -Nf andrew@XX.XXX.XX.XX

Where the X's represent the IP address I'm trying to connect to.
In firefox, I tell it to use a SOCKS proxy with the server being local host and port 8080. And that seems to work within firefox just fine. But when I type the same information within the system settings for proxy information, it doesn't seem to use the proxy server...
Is there something I'm missing here? How can I get the system to use the proxy settings system wide? Thanks for the help.

User avatar
remoulder
Level 17
Level 17
Posts: 7653
Joined: Fri May 09, 2008 1:14 pm
Contact:

Re: Can't Get Network Proxy To Work

Postby remoulder » Mon Oct 22, 2012 7:44 am

What version of mint, what desktop?
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

TheAndyBob
Level 1
Level 1
Posts: 19
Joined: Sat Oct 10, 2009 10:23 pm

Re: Can't Get Network Proxy To Work

Postby TheAndyBob » Mon Oct 22, 2012 8:34 am

Debian, with I believe cinnamon.

trueknight
Level 1
Level 1
Posts: 2
Joined: Wed Oct 31, 2012 3:59 am

Re: Can't Get Network Proxy To Work

Postby trueknight » Wed Oct 31, 2012 4:03 am

I have just the same issue. Proxy configuration in firefox and in skype works perfect but not in system configuration.
Version of my mint is 13, desktop is maya.

User avatar
Garvan
Level 4
Level 4
Posts: 296
Joined: Sun May 29, 2011 3:26 am
Location: Lao PDR
Contact:

Re: Can't Get Network Proxy To Work

Postby Garvan » Wed Oct 31, 2012 6:30 am

I cannot answer the question completely, but I think I can provide extra information which may help. I do not run the Debian version of mint.

I can set up a proxy in Firefox by editing the Manual proxy Configuration settings. These work only in Firefox.

To use a proxy from a terminal I need to use this style command.

Code: Select all

export http_proxy='http://81.27.79.181:8080/'


I sometimes use this to pretend I am in the UK so I can download BBC TV shows using get-iplayer. This also supports the user-name and password syntax you are using.

This will show your IP address in the terminal. It is important to note that the terminal ignores the network manager settings.
ip addr show


Finally I have set up proxies using the GUI interface Network Settings in Cinnamon. I do not know if you have this utility in your version of mint.

Garvan
Notebook: HP 14 Notebook PC 14-r003TX, i5-4210U @ 1.7 GHz, 8GB RAM, Linux Mint 17.2 (Dual boot with Win 10)
Notebook: DELL latitude E5520, i5-2520M @ 2.50 GHz, 4GB RAM, Linux Mint 17.2


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 3 guests