Application Launcher "shutdown" option gone

Forum rules
Before you post please read how to get help
Claudius
Level 1
Level 1
Posts: 5
Joined: Sun Nov 04, 2012 7:33 pm

Application Launcher "shutdown" option gone

Postby Claudius » Sun Nov 04, 2012 7:51 pm

Hi,
I'm experiencing a strange problem: the option "shutdown" has disappered from the "Leave" submenu as well as from the main menu of the application launcher (I had activated its visibility using the KMenuEdit). The option to show the "shutdwon" function is shown in KMenuEdit but un-checking and re-checking it does not change the situation.

Any suggestion greatly appreciated.
Attachments
Menu.png
Menu.png (30.37 KiB) Viewed 1978 times

007
Level 1
Level 1
Posts: 38
Joined: Fri Mar 05, 2010 10:01 am

Re: Application Launcher "shutdown" option gone

Postby 007 » Tue Nov 06, 2012 6:16 am

Don't know much..... but you can add widgets -> lock/leave widget

Claudius
Level 1
Level 1
Posts: 5
Joined: Sun Nov 04, 2012 7:33 pm

Re: Application Launcher "shutdown" option gone

Postby Claudius » Tue Nov 06, 2012 4:59 pm

Thanks for the reply but the widget you suggested does not offer the option to shutdown the system. I can always run

Code: Select all

sudo /sbin/shutdown -h -P now

of course but that is not the point.

User avatar
Flemur
Level 9
Level 9
Posts: 2951
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Application Launcher "shutdown" option gone

Postby Flemur » Tue Nov 06, 2012 7:10 pm

I had that happen with starting without a display manager:

My .xinitrc:
exec /usr/bin/startxfce4 ---> NO shutdown menu (missing or greyed out).
exec ck-launch-session /usr/bin/startxfce4 --> shutdown menu.

If you're using a display manager (MDM, etc), you might reinstall it.
Mint 18 Mate/fluxbox/pulse-less - Xubuntu 16.04/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

Claudius
Level 1
Level 1
Posts: 5
Joined: Sun Nov 04, 2012 7:33 pm

Re: Application Launcher "shutdown" option gone

Postby Claudius » Sat Nov 10, 2012 2:00 am

Not sure how to do that, any suggestion would be very helpful. KDM is used in my system and it has always displayed the shutdown option until it stopped working a few days ago.

Claudius
Level 1
Level 1
Posts: 5
Joined: Sun Nov 04, 2012 7:33 pm

Re: Application Launcher "shutdown" option gone

Postby Claudius » Sat Nov 10, 2012 2:29 am

Actually the problem might be a different one. I realized that none of the following applications works properly:
1) mintupdate: starts and then nothing happens (tried both from the menu and from terminal)
2) synaptic: starts only from terminal with
sudo synaptic

3) user management from system settings; it works only from terminal with
sudo kcmshell4 userconfig
but then lots of error messages relating to
/tmp/kde-user is owned by uid 1000 instead of uid 0
; using the command
kdesudo kcmshell4 userconfig
results instead in the following error:
kdesudo kcmshell4 userconfig

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/claudius/.config/ibus/bus
No protocol specified
kcmshell4: cannot connect to X server localhost:0.0


Totally confused!

User avatar
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Application Launcher "shutdown" option gone

Postby Schoelje » Tue Nov 13, 2012 11:38 am

It looks very much like the bug I reported a while ago:
viewtopic.php?f=47&t=113559

For me it was an update of xinit:
In my case it was the upgrade of xinit to version 1.3.2-1
When I downgraded that package to 1.3.1-1, all functioned as expected.

Claudius
Level 1
Level 1
Posts: 5
Joined: Sun Nov 04, 2012 7:33 pm

Re: Application Launcher "shutdown" option gone

Postby Claudius » Wed Nov 14, 2012 4:25 pm

Schoelje, thanks for the reply. I had a look at the version of xinit I am using at it is the 1.3.1-1. I also had a look at the bug you indicated in your post but I failed to see how that is relevant but thanks none the less. Still haven't found a solution.


Return to “KDE”

Who is online

Users browsing this forum: No registered users and 1 guest