[SOLVED] VIA VT1718S - no sound from the front panel.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
Level 3
Level 3
Posts: 127
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife

[SOLVED] VIA VT1718S - no sound from the front panel.

Postby ElStellino » Sun Nov 25, 2012 11:59 am

Yes, I know, it has been asked countless times in multiple flavours. I have been spending the last period looking for a solution everywhere, but I had no luck. So please bear with me..
I did search prior to post. Please pardon me if the solution was in front of my nose.

On my system, Mint 13 Cinnamon 64 bit, I have sound from the onboard soundcard at th eback, but no sound from the front panel, as the title of this thread says. Funny thing is that if I insert the headphones in the front panel the speakers go mute as they should, but also the headphones remain mute. In Windows 7 and 8 everything works, so the hardware failure is to be excluded.

I paste here some details, I guess that they may be useful...

Code: Select all

maya@Maya ~ $ inxi -c 0 -Ax
Audio:     Card-1: Intel 5 Series/3400 Series Chipset High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2: Microsoft LifeCam HD-5000 driver: USB Audio usb-ID: 045e:076d
           Card-3: Microsoft LifeCam VX-3000 driver: USB Audio usb-ID: 045e:00f5
           Sound: Advanced Linux Sound Architecture ver: 1.0.24


Code: Select all

maya@Maya ~ $ cat /proc/asound/card0/codec* | grep Codec
Codec: VIA VT1718S
Codec: Intel IbexPeak HDMI


Code: Select all

maya@Maya ~ $ lsmod | grep -e hda -e snd
snd_hda_codec_hdmi     32474  1
snd_hda_codec_via      51398  1
snd_usb_audio         122982  3
snd_usbmidi_lib        25395  1 snd_usb_audio
snd_hda_intel          33773  5
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel
snd_hwdep              13668  2 snd_usb_audio,snd_hda_codec
snd_pcm                97188  6 snd_hda_codec_hdmi,snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_seq_midi           13324  0
snd_rawmidi            30748  2 snd_usbmidi_lib,snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    78855  26 snd_hda_codec_hdmi,snd_hda_codec_via,snd_usb_audio,snd_usbmidi_lib,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm

the settings in Sound are:
hardware tab, profile from the dropdown menu Analog stereo duplex (I tried all of the right sunding ones anyway, either don't work at all, or give the same result)
output tab, connector from the dropdown menu is Analog output

I tried to install ALSA a while back because Skype audio wouldn't work at all, but now it comes out that the sound in Skype is still managed by PulseAudio volume control.
Although I tampered the system, the front panel really never worked, so I don't consider myself guilty...

Would some kind soul please try to explain what's wrong? It would be highly appreciated.

Thanks, thanks thanks!
Last edited by ElStellino on Tue Dec 04, 2012 5:07 pm, edited 3 times in total.
Linux Mint 18.1 Sirena – Cinnamon-64

Hardware: Core i3 530 2.93Ghz – 4Gb Ram Dual Channel.

Level 17
Level 17
Posts: 7648
Joined: Fri May 09, 2008 1:14 pm

Re: Another one on sound.. Front panel doesn't have output.

Postby remoulder » Sun Nov 25, 2012 2:28 pm

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

User avatar
Level 3
Level 3
Posts: 127
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife

Re: Another one on sound.. Front panel doesn't have output.

Postby ElStellino » Sat Dec 01, 2012 9:38 am

Thanks for replying.

Unfortunately I got stuck at one passage, now I opened via the panel the alsa-base.conf file and found this in front of me:

What am I supposed to do here, please?

As I couldn't see much of the file, I opened it in its location with a double click and it listed me this:

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Do I just paste at the end of it

Code: Select all

VIA VT17xx/VT18xx/VT20xx
auto          BIOS setup (default)

without messing up stuff?
I honestly find it so confusing.
EDIT: I copied and pasted it at the end of the file sure that it couldn't work, and....
It does not work.

I then started to google around and found this other bug which is clearly the one I am experiencing.
https://bugs.launchpad.net/ubuntu/+sour ... bug/772638

However, if I change The HP value nothing changes other than having the speaker working with the headphones plugged in.

I admit it is not a thing I cannot live with, I have other 2 jacks to use with my headphones but they are in a "impossible to reach" position.

Any help would be really appreciated!
Please consider that I am really a n00b and I just have a month's experience with linux: many things to me are still too "cryptic".
Linux Mint 18.1 Sirena – Cinnamon-64

Hardware: Core i3 530 2.93Ghz – 4Gb Ram Dual Channel.

User avatar
Level 3
Level 3
Posts: 127
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife

Re: Another one on sound.. Front panel doesn't have output.

Postby ElStellino » Tue Dec 04, 2012 4:59 pm

So, it now works.

As I am sure somebody else soon or later will probably experience my same issue, and given that not everybody is a linux expert, I am posting my solution here.
Nothing is more frustrating than seeing no useful replies, and not being able to find a solution online.

Many thanks to my Italian friend Loris, who suggested me to upgrade to the new 3.6.7 kernel and ditching the 3.2.0-23, then he gave me a link to an Italian page explaining exactly what to do.
For the process read below.

Code: Select all

cd /tmp
wget http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.6.7 -O linux-kernel-3.6.7
chmod +x linux-kernel-3.6.7
sudo sh linux-kernel-3.6.7
sudo reboot

Although I was getting an error at the last stage just before reebooting...

Code: Select all

Error! Bad return status for module build on kernel: 3.6.7-030607-generic (x86_64)
Consult /var/lib/dkms/virtualbox-guest/4.1.12/build/make.log for more information.

...I decided to go forward anyway, and the thing now works.

here where the code comes from: http://blog.mrwebmaster.it/2012/11/20/aggiornare-ubuntu-al-linux-kernel-3-6-7.html
Linux Mint 18.1 Sirena – Cinnamon-64

Hardware: Core i3 530 2.93Ghz – 4Gb Ram Dual Channel.

Return to “Newbie Questions”

Who is online

Users browsing this forum: Bing [Bot], frankt, GS3, TomComKnowsHow, wcpython and 13 guests