Can't choose Dropbox location

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Fri Nov 23, 2012 6:44 pm

Can't choose Dropbox location

Postby Chypsylon » Fri Nov 23, 2012 7:04 pm

Is it just me, or is the ability to choose the location of the Dropbox folder, apart from the standard "/home/[USER]/Dropbox", now broken in the new nemo-dropbox package?
This has been working flawless with the "old" nautilus-dropbox package under mint 13. But now the field for choosing the location just remains grayed out and the same. Sometimes you also get the error-message "Target folder is already your dropbox".
Please note that others are facing the same problem - see

Any help would be appreciated :)

Level 1
Level 1
Posts: 12
Joined: Wed May 16, 2012 10:48 am
Location: Washington, DC USA

Re: Can't choose Dropbox location

Postby rdegennaro » Thu Dec 20, 2012 11:24 am

Yes, I had same problem and solved it this way.

1) Set up Dropbox in the only place it would let me: /home/username/Dropbox
I did this with Advanced setup, and unselected almost all files, so it didn't try to put a lot of files there yet.
There seems to be no alternative to this step.

2) Edited Dropbox preferences to MOVE the folder to where I wanted it. Some have said you must type in the name, but I think I just navigated to the directory. Anyway, one of those worked. I moved it to: /home/username/documents/Dropbox

I'm running Linux Mint 14.

Level 1
Level 1
Posts: 3
Joined: Fri Feb 22, 2013 1:00 am

Re: Can't choose Dropbox location

Postby Drakonas » Wed Feb 27, 2013 4:04 pm

The only issue with this is that I think it won't recognize the Dropbox folder in the old location, and will re-download and overwrite all files instead of checking and syncing the directory that's there. I'll give it a try, and report back my find.

Edit: Upon attempting to move the Dropbox folder to a previous location (where my old Dropbox folder still is), this error is shown:

Code: Select all

Target folder is your current Dropbox!

It still thinks that's my current directory, even when Dropbox states in its preferences that the current directory is still in my home root.

On top of that, I had deleted both the .dropbox and .dropboxd folder from my home folder before doing this! Is there some hidden configuration directory somewhere? I think that might by the culprit. (I already checked dconf, gconf, and mateconf because I had previous installs with them)

Edit 2: I just thought of something. I created a symbolic link ~/Dropbox pointing to my dropbox folder on a separate drive. I thought I installed dropbox with the actual location in its settings (not ~/Dropbox), because I know it's a bad idea for Dropbox to operate in a symbolic link (they claimed so on their wiki or forums).
However, I may have had it set up in the symbolic link. I can't remember. I wasn't having issues, and for me, if it isn't broken I don't need to fix it. lol.

Edit 3: Well, apparently that "current Dropbox" error shows up regardless of where I try to move, whether the old one is there or not.

I'm filing a bug.

Bug report here.

Return to “Software & Applications”