Problema Update

Italian Forum
deeniel
Level 1
Level 1
Posts: 21
Joined: Sat Nov 24, 2012 8:38 am

Problema Update

Postby deeniel » Sun Nov 25, 2012 5:09 pm

Dunque dopo 1000 problemi(tra cui aver perso per sempre windows non so come, e aver dovuto installare ben 2 linuxmint sul mio pc) sono riuscito a farlo partire.
Ho subito avuto diciamo un colpo di sfiga che mi è andata via la luce durante gli aggiornamenti e una volta riacceso il computer, se provo da terminale a fare:
-sudo apt-get update:
W: Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/ ... slation-en Impossibile connettersi a archive.getdeb.net:http:
(una lunghissima lista)
-Mentre se provo degli install:
E: Impossibile impostare il blocco /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). Un altro processo potrebbe tenerla occupata

Ciò l'ho fatot da pc appena acceso quindi non ho altri installer o che aperti in conflitto.

Inoltre la barra delle applicazioni mi da le icone delle finestre aperte ma senza il nome(di solito vedo terminale, google chrome(e nome pagina aperta) e a destra le icone di orario, rete, suono ecc sono enormi e non le vedo bene.

Qualcuno ha un'idea senza farmi reinstallare tutto che impazzirei?

deeniel
Level 1
Level 1
Posts: 21
Joined: Sat Nov 24, 2012 8:38 am

Re: Problema Update

Postby deeniel » Mon Nov 26, 2012 12:02 pm

A sto punto mi è toccato risolvere formattando tutte le partizioni ed installare solo mint. Spero non sorgano altri problemi. Potete chiudere grazie

oleh_
Level 1
Level 1
Posts: 3
Joined: Tue Dec 11, 2012 8:47 am

Re: Problema Update

Postby oleh_ » Tue Dec 11, 2012 8:54 am

Anche io ho lo stesso problema:
dopo una nuova installazione, aggiungo i repo getdeb apps & games e provando a fare l'aggiornamento ottengo gli stessi errori:

Code: Select all

Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/Release.gpg  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/apps/binary-amd64/Packages  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/games/binary-amd64/Packages  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/apps/binary-i386/Packages  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/games/binary-i386/Packages  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/apps/i18n/Translation-it_IT  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/apps/i18n/Translation-it  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/apps/i18n/Translation-en  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/games/i18n/Translation-it_IT  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/games/i18n/Translation-it  Impossibile connettersi a archive.getdeb.net:http:
Impossibile recuperare http://archive.getdeb.net/ubuntu/dists/quantal-getdeb/games/i18n/Translation-en  Impossibile connettersi a archive.getdeb.net:http:
Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.


provando a installare un qualunque pacchetto:

Code: Select all

E: Impossibile impostare il blocco /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). Un altro processo potrebbe tenerla occupata.

Ma è strano che sia occupata in quanto il sistema è stato appena avviato...
Qualche soluzione? :(

akd
Level 1
Level 1
Posts: 18
Joined: Fri Dec 02, 2011 10:46 am

Re: Problema Update

Postby akd » Wed Dec 19, 2012 6:02 am

So che hanno problemi con i server di download, può essere quello?
Anch'io sono bloccato, non si aggiorna nulla... Mint 13.

twolf
Level 1
Level 1
Posts: 41
Joined: Wed Nov 21, 2012 6:34 pm

Re: Problema Update

Postby twolf » Thu Jan 03, 2013 9:39 pm

Da quel che sono riuscito a capire i repository getdeb non raggiungibili sono stati dismessi.
Togliendoli (da Modifica -> Sorgenti Software -> Altro software del gestore aggiornamenti) io ho risolto (uso Mint 13 xfce).
Quando riscontravo il problema il gestore aggiornamenti rimaneva bloccato per parecchio tempo: è molto probabile che sia lui a tenere il blocco su /var/lib/dpkg/lock, soprattutto se un errore del genere lo si ha a sistema appena avviato.

oleh_
Level 1
Level 1
Posts: 3
Joined: Tue Dec 11, 2012 8:47 am

Re: Problema Update

Postby oleh_ » Fri Jan 04, 2013 5:05 am

Esatto, hanno dei problemi (così ho capito) con server dal 9 dicembre :(

twolf
Level 1
Level 1
Posts: 41
Joined: Wed Nov 21, 2012 6:34 pm

Re: Problema Update

Postby twolf » Fri Jan 04, 2013 7:20 am

Da quel che leggo qui sembra anche che si possa risolvere utilizzando dei mirrors sostitutivi, ma personalmente non ho ancora provato:

viewtopic.php?f=47&t=118809&p=657077

ff0rt
Level 1
Level 1
Posts: 17
Joined: Tue Jul 31, 2012 5:01 pm

Re: Problema Update

Postby ff0rt » Fri Jan 04, 2013 9:36 am

Io ho seguito le indicazioni del blog (in inglese) e non ho avuto problemi:

http://blog.linuxmint.com/?p=2254

In particolare ho fatto così:
- Ho verificato che fosse installato il pacchetto: "mint-debian-mirrors"
- Ho digitato su terminale il comando "mint-choose-debian-mirror"

Poi ho lasciato fare il resto a Gestore aggiornamenti.

Se ho frainteso la natura del problema, vi chiedo scusa.
Il mio altro hobby:
http://www.fremmauno.com/

twolf
Level 1
Level 1
Posts: 41
Joined: Wed Nov 21, 2012 6:34 pm

Re: Problema Update

Postby twolf » Fri Jan 04, 2013 12:33 pm

ff0rt, mi sembra che il tuo link parli di un altro argomento, ossia l'aggiornamento dell'edizione Debian di Linux Mint.

Qui il problema è che alcuni repositories getdeb, non essenziali alle distribuzioni ma utili, non sembrano più essere raggiungibili da molto tempo.
Io li ho tolti ma dall'ultimo link da me postato sembrerebbe che ci siano dei repositories alternativi, però non ho ancora trovato il tempo di testare la cosa personalmente.

Grazie comunque

queenfan
Level 1
Level 1
Posts: 1
Joined: Thu May 09, 2013 6:18 am

Re: Problema Update

Postby queenfan » Thu May 09, 2013 6:30 am

Buongiorno a tutti,
il problema a me è nato perchè ho aggiornato il file source.list da terminale mentre avevo il gestore dei pacchetti aperto.
Per risolvere il problema ho rinominato il file sources.list e ho fatto l'upgrade.
Dopo questa operazione ho ridato il nome corretto al sources.list e rifatto l'upgrade che non ha più dato problemi:

cd /etc/apt
sudo mv sources.list sources.list.bk
sudo apt-get update
sudo mv sources.list.bk sources.list
sudo apt-get update

Fatemi sapere se anche a voi ha risolto il problema

twolf
Level 1
Level 1
Posts: 41
Joined: Wed Nov 21, 2012 6:34 pm

[Risolto] Problema Update

Postby twolf » Tue May 14, 2013 5:41 pm

Dopo un po' di tempo sono tornato a controllare il link che avevo trovato e che per comodità riporto ancora:

viewtopic.php?f=47&t=118809&p=657077

L'ultimo intervento (by eMcE on Fri Jan 18, 2013 11:09 pm) comunica che i repositories in questione sono stati dismessi. Ecco la ragione della non raggiungibilità. La soluzione è toglierli.
Il link riporta anche le alternative per accedere al materiale GetDeb and PlayDeb.
Dire che il mistero è svelato, quindi mi azzardo a mettere [Risolto].
Ciao

twolf
Level 1
Level 1
Posts: 41
Joined: Wed Nov 21, 2012 6:34 pm

<SOLVED> Problema Update

Postby twolf » Thu Jun 06, 2013 3:39 am

Risolto


Return to “Italiano (Italian)”

Who is online

Users browsing this forum: No registered users and 3 guests