Sleep and Hibernate working for you?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
User avatar
ma66nus
Level 1
Level 1
Posts: 8
Joined: Sun Oct 07, 2012 4:03 am

Sleep and Hibernate working for you?

Postby ma66nus » Tue Oct 09, 2012 2:10 am

Hi,

I use Mint 13 64-bits and an Asus 1225b machine.

When I choose Sleep or Hibernate it always hangs (I have to force the turn off with the on and off button), If I remember right it has very often been a problem with Linux and my machines to turn off, sleep and hibernate. With e.g. Puppy if I do shutdown it restarts and sleep never seems to work no matter which hardware.

I love Linux and the possibility to be able to write posts and get answers and fixes like this, but is there anyone else that has experienced this and/or have a solution to it?

Cheers!
'To ride, shoot straight and speak the truth'

wayne128
Level 10
Level 10
Posts: 3418
Joined: Tue Jul 13, 2010 12:15 am

Re: Sleep and Hibernate working for you?

Postby wayne128 » Tue Oct 09, 2012 2:54 am

I think you should read this post and would find out from the release annoucement

viewtopic.php?f=90&t=109338

User avatar
ma66nus
Level 1
Level 1
Posts: 8
Joined: Sun Oct 07, 2012 4:03 am

Re: Sleep and Hibernate working for you?

Postby ma66nus » Wed Oct 10, 2012 2:12 am

Thanks!

I'll read it :-)
'To ride, shoot straight and speak the truth'

jaderiver
Level 2
Level 2
Posts: 83
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Re: Sleep and Hibernate working for you?

Postby jaderiver » Wed Oct 10, 2012 12:13 pm

Hi ma66mus:

The following links provided information which enabled me to hibernate and suspend my ASUS U56E and wake from either mode, successfully...

http://thecodecentral.com/2011/01/18/fix-ubuntu-10-10-suspendhibernate-not-working-bug
https://help.ubuntu.com/12.04/ubuntu-help/power-hibernate.html
http://askubuntu.com/questions/94754/how-to-enable-hibernation

The first link also discusses how not having enough swap space will prevent hibernation from working properly.

Hopefully these links help you, too.

jaderiver
ASUS U56E 64-bit Mint 17.1 MATE Rebecca dualboot WIN 7
Zoom #3095 dialup USB modem

User avatar
ma66nus
Level 1
Level 1
Posts: 8
Joined: Sun Oct 07, 2012 4:03 am

Re: Sleep and Hibernate working for you?

Postby ma66nus » Fri Oct 12, 2012 2:07 am

Thanks :D

I'll read them and try to get it working, else I really like the Maya Mint.
'To ride, shoot straight and speak the truth'

User avatar
pelleoss
Level 1
Level 1
Posts: 22
Joined: Sat Nov 17, 2012 9:39 am

Re: Sleep and Hibernate working for you?

Postby pelleoss » Fri Nov 23, 2012 9:34 am

ma66nus wrote:Thanks :D

I'll read them and try to get it working, else I really like the Maya Mint.


Hi.
I have the same problem on my sony vaio (LM 13 KDE). Waking up from "sleep" mode becomes a new fresh boot.
Did you make sleep mode work? If yes, may you share your solution?
Thanks,
Claudio:)
---------------------------------------------------------------------
Sony Vaio VGN-NW11S running LM 15 KDE 64 bit (dual boot Win7)

bwat47
Level 2
Level 2
Posts: 62
Joined: Sun May 01, 2011 1:31 am

Re: Sleep and Hibernate working for you?

Postby bwat47 » Sun Nov 25, 2012 1:52 am

I run linux on two laptops.

Asus U52F: Suspend and hibernate do not work out of the box. I need to use the following script to fix suspend: http://thecodecentral.com/2011/01/18/fi ... orking-bug. To get hibernate working I need to add resume=UUID=UUIDOFSWAP to my /etc/default/grub (without doing this it hibernates fine, but boots into a fresh session instead of resuming the saved one). And to get ubuntu/mint to even show the hibernate option it needs to be enabled via policykit: http://www.faqforge.com/linux/how-to-en ... x-mint-13/. Since you also have an asus machine hopefully the codecentral fix will work for you too,

System76 Lemur Ultra: Suspend works out of the box. Hibernate works after the above grub tweak and enabling the hibernate option via policykit.

User avatar
pelleoss
Level 1
Level 1
Posts: 22
Joined: Sat Nov 17, 2012 9:39 am

Re: Sleep and Hibernate working for you?

Postby pelleoss » Tue Nov 27, 2012 8:16 am

I used the script suggested and now the sleep mode works. I had to choose the "step 2 old" since the first one is not working for me.
So now my laptop can go in sleep mode and can wake up perfectly and very fast!

Unfortunately I still have problem with networks: in fact after resuming ALL the networks (LAN-WIFI-MOBILE) are disabled & in grey. I cannot switch them on. I have to reboot.
In the sleep log file I have some errors with network manager...
Any hint about that?

/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01PulseAudio suspend suspend:
Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>>
/usr/lib/pm-utils/sleep.d/01PulseAudio suspend suspend: success.
Running hook /etc/pm/sleep.d/10_grub-common suspend suspend:

/etc/pm/sleep.d/10_grub-common suspend suspend: success.
Running hook /etc/pm/sleep.d/10_unattended-upgrades-hibernate suspend suspend:

/etc/pm/sleep.d/10_unattended-upgrades-hibernate suspend suspend: success.
Running hook /etc/pm/sleep.d/20_custom-ehci_hcd suspend suspend:
0000:00:1a.70000:00:1d.7
/etc/pm/sleep.d/20_custom-ehci_hcd suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend:
Having NetworkManager put all interaces to sleep...Failed.

/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory

/usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:

/usr/lib/pm-utils/sleep.d/90clock suspend suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95anacron suspend suspend:

/usr/lib/pm-utils/sleep.d/95anacron suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend:

/usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:

/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
ATI Catalyst driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0

/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Running hook /etc/pm/sleep.d/novatel_3g_suspend suspend suspend:

/etc/pm/sleep.d/novatel_3g_suspend suspend suspend: success.
Tue Nov 27 00:02:57 CET 2012: performing suspend


Thanks in advance.
---------------------------------------------------------------------
Sony Vaio VGN-NW11S running LM 15 KDE 64 bit (dual boot Win7)

bwat47
Level 2
Level 2
Posts: 62
Joined: Sun May 01, 2011 1:31 am

Re: Sleep and Hibernate working for you?

Postby bwat47 » Wed Nov 28, 2012 11:58 am

The networkmanager error is this bug: https://bugs.launchpad.net/ubuntu/+sour ... ug/1007924. I get the same networkmanager error in my logs, and my suspend/resume works fine though, including reconnecting to my networks automatically on resume.

User avatar
pelleoss
Level 1
Level 1
Posts: 22
Joined: Sat Nov 17, 2012 9:39 am

Re: Sleep and Hibernate working for you?

Postby pelleoss » Thu Nov 29, 2012 8:33 am

At the end I did the following things:

1) disable ATI/AMD drivers
2) add script @ http://thecodecentral.com/2011/01/18/fi ... orking-bug , using "step 2" (not step 2 old)
3) in the previous script, modify line DRIVERS="ehci xhci" using ehci_hcd & xhci_hcd as commented in the script itself (since I had no ehci folder but ehci_hcd) --> not sure this is really needed.
4a) edit (as root) /etc/default/grub and put
GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"
(by default was empty ie. "")
4b) run in a root-console 'sudo update-grub'.
see http://askubuntu.com/questions/24048/

Still same error in sleep.log but everything works perfectly.

Hoping this can help.
---------------------------------------------------------------------
Sony Vaio VGN-NW11S running LM 15 KDE 64 bit (dual boot Win7)


Return to “Hardware Support”

Who is online

Users browsing this forum: JeremyB and 4 guests