<Solved> theme GTK+ engine 'name' is not installed

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Thu Nov 22, 2012 7:42 am

<Solved> theme GTK+ engine 'name' is not installed

Postby nerderello » Thu Nov 29, 2012 5:15 am

I say <Solved> this feels more like a work around.

The story so far. A fresh Mint v14 install using the 64bit version. I wanted the nimbus theme, so downloaded the deb dor it and for the GTK engine from Mint look website. Both installed okay. But when I selected the nimbus theme (Start > System > Prefrences > Appearance) I got the warning that the GTK+ Engine 'nimbus' was not installed.

Checking (using caja) I found the engine (libnimbus.so) where it had been installed, in /usr/lib/gtk-2.0/2.10.0/engines/libnimbus.so

The way that I got it to work was by copying this file (as root, so I did a quick sudo caja and used the file manager as a superuser) from /usr/lib/gtk-2.0/2.10.0/engines/libnimbus.so to /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libnimbus.so (this has a different name on 32bit versions - /usr/lib/i386-linux-gnu/gtk-2.0/2.10.0/engines/libnimbus.so ).

The theme now works, but, as I've said, this feels like a work around, as all othe themes taken from debs that also have a GTK engine, have to have their libname.so GTK engines moved.

Return to “Themes, Icons, & Wallpaper”