Radeon Xpress 200 - No 3D?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 19
Joined: Wed Nov 21, 2012 4:41 pm

Radeon Xpress 200 - No 3D?

Postby ummagumma » Thu Nov 29, 2012 8:25 am

Just recently discovered a little issue on my old Dell laptop with Radeon Xpress 200 graphics card (I think it's an onboard type). I tried to play a couple of games to see if it was capable but seemed unable to get any 3D acceleration at all. I've searched around a bit and I see that the older ATi cards are not well supported in Linux. Am I just going to have to accept this limitation? The display otherwise (2D stuff) is great, no problems at all.

The games I tried were 'planeshift' and 'openarena'. I was able to play, for example, Quake III perfectly well on this hardware believe it or not which I why I think it's just not 3D accelerating (for want of a better phrase). The frame rate I get is about 1 every 8-9 seconds (software only rendering?)


LinuxMint 13 MATE - 32bit
Results of inxi -Fc 0...
System: Host: Vostro Kernel: 3.2.0-23-generic i686 (32 bit) Desktop: N/A Distro: Linux Mint 13 Maya
Machine: System: Dell (portable) product: Vostro 1000
Mobo: Dell model: 0WY383 Bios: Dell version: 2.6.3 date: 12/07/2007
CPU: Single core Mobile AMD Sempron 3600+ (-UP-) cache: 256 KB flags: (lm nx sse sse2 sse3) clocked at 800.00 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI RS482 [Radeon Xpress 200]
X.Org: 1.11.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x800@60.0hz
GLX Renderer: Gallium 0.4 on ATI RS480 GLX Version: 2.1 Mesa 8.0.4
Audio: Card: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel Sound: ALSA ver: 1.0.24
Network: Card-1: Broadcom BCM4401-B0 100Base-TX driver: b44
IF: eth0 state: down mac: 00:1d:09:df:3f:2b
Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: wl
IF: eth2 state: up mac: 00:22:5f:1f:16:21
Drives: HDD Total Size: 80.0GB (22.2% used) 1: /dev/sda FUJITSU_MHZ2080B 80.0GB
Partition: ID: / size: 19G used: 17G (93%) fs: ext4 ID: swap-1 size: 0.94GB used: 0.02GB (3%) fs: swap
Sensors: System Temperatures: cpu: 53.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 135 Uptime: 3:01 Memory: 316.4/873.6MB Client: Shell inxi: 1.7.33

I don't get any error messages, the games install fine and the initial 2D config screens are ok...any thoughts?

User avatar
Level 6
Level 6
Posts: 1042
Joined: Sun Sep 04, 2011 12:39 pm

Re: Radeon Xpress 200 - No 3D?

Postby sagirfahmid3 » Thu Nov 29, 2012 1:23 pm

Yes, you will have to accept the limitation. (I have the same igfx on my Toshiba Satellite A100, 6 years old).

Level 1
Level 1
Posts: 19
Joined: Wed Nov 21, 2012 4:41 pm

Re: Radeon Xpress 200 - No 3D?

Postby ummagumma » Thu Nov 29, 2012 6:08 pm

Thanks for the reply, I had a feeling that would be the case, just exercising blind optimism hoping that a bit terminal-based geek magic would sort it :D

Onwards and upwards

Return to “Hardware Support”