zoneminder 1.25 on linux mint 13

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Sat Dec 01, 2012 9:37 am

zoneminder 1.25 on linux mint 13

Postby alcatail » Sat Dec 01, 2012 9:44 am

After 3 painstaking weeks of scouring through forums, how to's and guides I have taken code from all including my own code from years gone by to come up with this guide. I have rebuilt linux mint several times whilst trying out the patches, mods or updates and am currently running a stable version of zoneminder on linux mint 13.

I am posting here to save some other poor sod from going through the same ordeal ;)

Install 13 Maya Precise Pangolin Long term support release (LTS), supported until April 2017

Log in then become root:

sudo su

apt-get update && apt-get upgrade

go into your network settings and setup your default adapter and staic addresses.


dns server

Reboot server

open terminal again

Install Zoneminder

Log in then become root

sudo su

apt-get install zoneminder

Note: You will be prompted to configure Nullmailer during the Zoneminder install. You can leave the program un-configured if you do not plan to have the server email alerts. Or search for instructions to configure Nullmailer.

Add delay to allow MySQL to start before Zoneminder

nano /etc/init.d/zoneminder

Add above "zmfix -a" sleep 15

Ctrl+o Enter to save

CTRL+x to exit

Link Apache to Zoneminder

ln -s /etc/zm/apache.conf /etc/apache2/conf.d/zoneminder.conf

/etc/init.d/apache2 force-reload

adduser www-data video

Optional Install Cambozola

cd /usr/src && wget ... est.tar.gz

tar -xzvf cambozola-latest.tar.gz

replace "92" with cambozola version downloaded

cp cambozola-0.92/dist/cambozola.jar /usr/share/zoneminder

Optional Add SSL to Apache2

Create a self-signed certificate:

make-ssl-cert generate-default-snakeoil --force-overwrite

Activate Apache SSL module:

a2enmod ssl

Activate Apache default ssl virtual host:

a2ensite default-ssl

Restart Apache:

service apache2 restart

You should now be able to access the web server using https://serverip

NTP Daily Sync

nano /etc/cron.daily/ntpdate

Copy the following two lines into nano


Note: replace with the time server(s) of your choice. I use

Ctrl+o Enter to save

CTRL+x to exit

chmod 755 /etc/cron.daily/ntpdate

Open Zoneminder in web browser


Click Options

Uncheck: Check with for updated versions (?) click Save.

Click Images tab

Optional: check "Is the (optional) cambozola java streaming client installed (?)"

Path to (optional) ffmpeg mpeg encoder (?) enter /usr/bin/ffmpeg click Save

Reboot server to insure Zoneminder starts on boot.

add password to root

sudo passwd root
>>> enter ure password twice :)

service zoneminder stop

Setup apache2 to show Zoneminder user interface

Edit the file /etc/apache2/sites-enabled/000-default
nano /etc/apache2/sites-enabled/000-default

Change 'DocumentRoot /var/www', to 'DocumentRoot /usr/share/zoneminder'
Change '<Directory /var/www/>', to '<Directory /usr/share/zoneminder/>'
service apache2 restart
Fixing Apache2 error:"Could not reliably determine the server's fully qualified domain name, using for ServerName"
nano /etc/apache2/httpd.conf
Add the line:
ServerName localhost
save and exit
Restart apache2 service
service apache2 restart

Fixing php errors complaining about time zone, edit file php.ini and set your timezone, according to
nano /etc/php5/apache2/php.ini

Add the line with your time zone, in my case:
date.timezone ="Australia/Brisbane"

save and exit

memory patch / fix for monitors
nano /etc/sysctl.conf

# Memory modifications for ZoneMinder (kernel.shmall = 16 MB, kernel.shmmax = 256 MB)
kernel.shmall = 16777216
kernel.shmmax = 268435456

save and close

lastly for anyone using an 8 channel 7134 capture card

nano /etc/modprobe.d/modprobe.conf
alias char-major-81 saa7134
options saa7134 card=33,33,33,33,33,33,33,33

save and close

sudo reboot

Anyway inside options tabs under hashed key's you have to select plain hash option otherwise you won't get any picture on your monitors. There are workarounds in the forums but they involve making and installing patches and I found using the plain option to work for my situation.

Am currently looking at the mythzoneminder plugin to work with zoneminder. If anyone has done this can they pls email me at

kind regards

Last edited by alcatail on Wed Dec 12, 2012 8:20 pm, edited 1 time in total.

User avatar
Level 3
Level 3
Posts: 166
Joined: Tue Dec 15, 2009 11:30 pm
Location: Minnesota, USA

Re: zoneminder 1.25 on linux mint 13

Postby SunWorks » Sun Dec 09, 2012 3:51 pm

Thank you alcatail for posting your work... it's making me consider using your method step by step. Maybe I missed these details, if so please excuse my asking.

  • What version of Mint 13?
  • What hardware box (cpu/ram/etc.) ?
  • What cameras are you using?
  • How many cameras?
  • Any other details on how this is working either by alcatel or anybody who has tried it?
Would be great to get some operational and experience driven details.

Thank you again for what you've posted so far!

Level 1
Level 1
Posts: 2
Joined: Sat Dec 01, 2012 9:37 am

Re: zoneminder 1.25 on linux mint 13

Postby alcatail » Wed Dec 12, 2012 7:43 pm

Hi the version I am using is 13 Maya Precise Pangolin Long term support release (LTS), supported until April 2017 (64Bit)
I am currently running it on 3 systems and can confirm that it works on the following hardware;

rig 1.
core 2 duo 3 gig cpu with 6 mb cache.
gigabyte MB
4 gig ram
onboard video.

Rig2. I7
I7 cpu with 8MB cache and 16gig of memory. 2TB raid setup 1 I installed a cheap video card

Rig3. latest gigabyte motherboard with I5 CPU. 2 TB raid and 16 gig of ram I installed a cheap video card

The cameras are the cheaper PAL standard 480 tvlines found from places like ebay, etc.
Quality is reasonable.
The capture cards I used on the older gigabyte M'b's are 'BTTV' cards
I am having a lot of trouble with a 'Connexiant capture card' and am also building a virtual machine of zoneminder to work in virtual box on my rig's to talk to ipcameras as a back up recorder.
Rig 3 uses the latest gigabyte motherboard which uses the atheros ethernet onboard lan. I have had trouble getting this to work but have a workaround that I have not yet tried.

Also I had a lot of trouble with the raid so now I only have 1 partitiion - 2gb that is raided and mounted as a storage directory and I have a standard hard disk with the operating system - broken up into different partitions. I.e I use 20gig for swap (don't know if 20 is the do all end all but it works), 50 gig for the /tmp, 20 gig for the home partition and 80 for the /. 5 gig for the boot.

One thing to consider with the zoneminder is that if it fills up the /var the system becomes unstable. Inside zoneminder you can set filters up that would stop this but I usually have a seperate partition mounted under /zoneminder and I put symlinks in to redirect the events and images to the zoneminder.

I have just finished getting virtual box to run as a service - automatically starts up and shuts down at boot thanks to someone elses fantastic guide. I will post that up in the next few weeks with references to the guide itself and things I had to do make it work with linux mint.

Level 1
Level 1
Posts: 4
Joined: Wed Oct 28, 2009 1:45 am

Re: zoneminder 1.25 on linux mint 13

Postby khentiamentiu » Fri Mar 01, 2013 6:12 pm

Wow! This is a wonderful and detailed post, but it causes me to ask this: I have a fit-PC2 that I was planning to turn into a security camera server. The basic setup I'm looking at is 2-4 Agasio Wireless IP nightvision cameras, Linksys wireless router, one fit-PC2 plugged into the router. I want the ability to simultaneously record all channels while viewing on the LAN, and perhaps from the WAN. Think this is too much for a fit-pc2 to handle? (It may be too much for the router, but that's another problem). Here are the basic specs on the Fit-PC2. It's running Mint 9, but I'm upgrading to Mint 13, the latest Mint release supported by Compulabs.

CPU Intel Atom Z530 1.6GHz / Z510 1.1GHz
Chipset Intel US15W SCH
Memory 1GB DDR2-533 on-board
Storage 250 GB SSD HDD
miniSD socket
Display & Graphics Intel GMA500 graphics acceleration
Full hardware video acceleration of H.264, MPEG2, VC1, and WMV9
DVI Digital output up to 1920 x 1200 through HDMI connector
Audio Line-out, line-in, mic
5.1 Channels S/PDIF
Networking 1000 BaseT Ethernet
802.11n WLAN (based on RaLink RT3090, single antenna)
USB 6 USB 2.0 High Speed ports
IR Programmable consumer IR receiver
Operating System Linux Mint

Thanks for any help you can provide.

Level 1
Level 1
Posts: 2
Joined: Mon Mar 11, 2013 12:10 pm

Re: zoneminder 1.25 on linux mint 13

Postby zudzaks » Mon Mar 11, 2013 12:14 pm

i have installed 14 And want zoneminder but the system shows umet dependecies & try -f install but still it doesnt work ,,,what shud i do ?

Level 1
Level 1
Posts: 2
Joined: Mon Mar 11, 2013 12:10 pm

Re: zoneminder 1.25 on linux mint 13

Postby zudzaks » Mon Mar 11, 2013 12:30 pm

sudhir@sudhir-G31M-ES2L ~/Documents $ dpkg -l | grep -v ^ii
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
iU bleachbit 0.9.3-1 all delete unnecessary files from the system
rc libexttextcat-1.0-0 3.3.1-2 i386 Language detection library
iU openjdk-7-jre:i386 7u15-2.3.7-0ubuntu1~12.10.1 i386 OpenJDK Java runtime, using Hotspot JIT

Return to “Software & Applications”