CPU frequency scaling stuck at minimum clock on Dell M4300

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Sun Dec 02, 2012 10:54 am

CPU frequency scaling stuck at minimum clock on Dell M4300

Postby fgago » Sun Dec 02, 2012 12:14 pm

It took a lot of time to solve this problem, but finally it's gone and cpufreq is working fine. Here's the story:
First with Ubuntu 11.04 and later with Mint 13, I observed the same behaviour. After booting, with the laptop cool, cpufreq started working fine, the clock changed from 800MHz to 2.4GHz normally, based on cpu demand. After less than an hour, the laptop got hotter and clock stuck at 800MHz. cpufreq-info showed:

Code: Select all

current policy: frequency should be within 800 MHz and 800 MHz

Cooler fan seemed to be working fine, I checked lm-sensors, tried to tweak cpufreqd, sysfs, ondemand init script, among many other things, following advice from people on many linux forums. Nothing worked. Actually, everything worked, all the alternatives of cpu frequency scaling worked quite the same, but after half an hour or so, cpu stuck at 800MHz making it impossible to use the computer.
Finally I found this post http://ubuntuforums.org/showthread.php?t=1438377 where somebody solved the problem just cleaning the dust from the fan. At first I found it absurd, but later I decided to open the laptop and was shocked by the amount of dust that was clogging the air output of the fan. After cleaning it up, the problem was gone. Now cpu is scaling well even after several hours of work.

If you are facing this problem, check all possible solutions before attempting to open up your laptop and do not attempt to do that unless you're used to deal with computer hardware. Many people on the forums reported that cleaning the fan did not solve the problem.If your computer is brand new, this is certainly not your problem

Now that cpu scaling is working fine, I disabled the ondemand init script:

Code: Select all

sudo update-rc.d -f ondemand remove

Configured cpufrequtilsd (/etc/init.d/cpufrequtilsd) to set governor policy to conservative at boot time:

Code: Select all


And enabled cpufrequtilsd init script:

Code: Select all

sudo update-rc.d cpufrequtils defaults

Now that air is flowing and cooling the system, everything is working fine.

Level 1
Level 1
Posts: 12
Joined: Fri Nov 16, 2012 3:44 pm

Re: CPU frequency scaling stuck at minimum clock on Dell M43

Postby cj123 » Mon Dec 31, 2012 1:16 am

I have been searching for a while for how to make conservative the default governor. Thanks.

Return to “Hardware Support”

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests