setting a MANPATH environment variable?

Archived topics about LMDE 1
Forum rules
User avatar
Level 2
Level 2
Posts: 70
Joined: Sun Nov 25, 2012 1:51 am

setting a MANPATH environment variable?

Postby peyrol » Thu Dec 06, 2012 9:03 am

I use LMDE 64 bit with Mate and bash. I'm trying to install TkMan. Here is what happens when I try to run it:

Code: Select all

david@achernar:~$ tkman
You must set a MANPATH environment variable,
which is a colon-separated list of directories in which
to find man pages, for example /usr/man:/usr/share/man.
(See the help page for an explanation of why
alternatives to the MANPATH are a bad thing.)

How do I set environment variables?
What directories should be on the list for man pages?
Should this be added to a login script somewhere?

Multiple thanks in advance.

Level 4
Level 4
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: setting a MANPATH environment variable?

Postby stratus_ss » Thu Dec 06, 2012 9:59 am

environment variables are set like this

Code: Select all

export MANPATH

If you want these changes to stick, and to be sure they always persist I usually put a line in /etc/profile. For example the last two lines in my profile contain a custom path variable

Code: Select all

export PATH

This makes sure that every time the system is booted, I have a very custom path for my needs

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 2 guests