.

Archived topics about LMDE 1
Forum rules
maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

.

Postby maxibuntu » Sun Dec 09, 2012 10:27 am

Removed
Last edited by maxibuntu on Thu Apr 23, 2015 2:14 pm, edited 4 times in total.

User avatar
caf4926
Level 7
Level 7
Posts: 1848
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby caf4926 » Sun Dec 09, 2012 10:43 am

Image
Mint 18

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

.

Postby maxibuntu » Sun Dec 09, 2012 11:02 am

Removed
Last edited by maxibuntu on Thu Apr 23, 2015 2:15 pm, edited 4 times in total.

User avatar
caf4926
Level 7
Level 7
Posts: 1848
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby caf4926 » Sun Dec 09, 2012 11:15 am

In Gnome 3.4, by default, the screen blanks every 10 minutes
But you should be able to change this to at least 1hr?
Image
Mint 18

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

.

Postby maxibuntu » Sun Dec 09, 2012 11:52 am

Removed
Last edited by maxibuntu on Thu Apr 23, 2015 2:15 pm, edited 2 times in total.

User avatar
rop75
Level 2
Level 2
Posts: 97
Joined: Sat May 05, 2012 6:08 pm

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby rop75 » Sun Dec 09, 2012 12:53 pm

Well I don't know, but in my case (I am using Gnome shell 3.4) Ijust changed the settings in system settings / screen brightness and block, and I have my monitor on for an hour when I am using my laptop to watch a movie. Anyway, thanks for your how-to

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

.

Postby maxibuntu » Sun Dec 09, 2012 4:52 pm

Removed
Last edited by maxibuntu on Thu Apr 23, 2015 2:16 pm, edited 1 time in total.

Ghis1964
Level 1
Level 1
Posts: 2
Joined: Sun Oct 30, 2011 2:39 pm

[SOLVED]Re:How to stop Linux or any xorg DPMS screen blankin

Postby Ghis1964 » Tue Jan 08, 2013 9:41 pm

maxibuntu wrote:In Gnome 3.4, by default, the screen blanks every 10 minutes or so. Maybe the Gnome developers think this is funny when you are watching a movie, but I sure don't.

I do not have the issue in XFCE.

All the following commands can be run from a Terminal, like for instance gnome-terminal. You can easily select and copy a command from this page, then paste it in a terminal, and hit enter.

I have a sudo setup on LMDE, if you have an su setup like on standard Debian, use:

Code: Select all

su -


...and enter the root password, and commands.

But we will continue with the sudo version:

To stop the screen from blanking you have to pass some configuration parameters to the X server.

In a terminal, run:

Code: Select all

sudo mkdir -pv /etc/X11/xorg.conf.d


Then create a new config file:

Code: Select all

sudo gedit /etc/X11/xorg.conf.d/01-disable-screen-blanking.conf


Copy/paste the following code and save the file:

Code: Select all

Section "ServerFlags"

    Option   "BlankTime"   "0"
    Option   "StandbyTime"   "0"
    Option   "SuspendTime"   "0"

EndSection


Close your applications and restart the X server with Ctrl+Alt+Backspace, or simply log out nad log back in again.



Yes, SOLVED :)

Thanks! I should keep notes about where my notes are.
So far, this works in any xorg whither Debian, Arch, Linux, Slacks, BSDs etc (sorry, not Mi¢ro$o£t Wind%w¢)
Seeing this, I remembered doing this same FIX in Debian and ArchBang once. As now the screen is still on after 30mins so far and going (instead of 10). This old box is on AntiX. It's the only thing that can access "random hdd" that I add as slave drives in. I'm installing/reinstalling hoping OSs as a hooby on old machines just to see how far it goes. I don't even network them into each other. I care even less for gaming. And I like having something that runs when I'm stuck in the mud with the next one ahahah;) (and at 25$ a piece these oldies, it's a lot cheaper than any twin or quad-display video card)

This time I have been looking for a fix through tty's :; --> I don't see why I should have at some level up, something or codes that works to put wherever, when I have to at the user level to put a code that will counter-act that un-needed output.

User avatar
tbplayer
Level 1
Level 1
Posts: 11
Joined: Mon Apr 29, 2013 3:35 pm

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby tbplayer » Sun May 19, 2013 1:05 pm

maxibuntu wrote:Copy/paste the following code and save the file:

Code: Select all

Section "ServerFlags"

    Option   "BlankTime"   "0"
    Option   "StandbyTime"   "0"
    Option   "SuspendTime"   "0"

EndSection


Yup. That worked for me. Thanks.

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

.

Postby maxibuntu » Fri Jun 07, 2013 4:34 pm

Removed
Last edited by maxibuntu on Thu Apr 23, 2015 2:16 pm, edited 1 time in total.

Transitman
Level 2
Level 2
Posts: 95
Joined: Sun Dec 02, 2007 1:48 am

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby Transitman » Fri Jun 07, 2013 11:37 pm

maxibuntu wrote:Ugh, this crap is back in XFCE 4.10. Constant screen blanking makes watching movies a nuisance.



In the startup application settings, put these 2 items in and your DPMS screen blanking will go away.
Click ADD and then the following;

Code: Select all

Xset -dpms
1. Name: Xset -dpms
2. Command: xset -dpms
3. Comment: (Leave Blank)
 
Click save. If prompted, enter your password.

Xset s off
1. Name: Xset s off
2. Command: xset s off
3. Comment: (Leave Blank)

Click save.


Works under GNome, Cinnamon, XFCE, KDE, LXDE, etc.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 6 guests