workspace switcher applet no longer show numbers

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
obidamnkenobi
Level 1
Level 1
Posts: 6
Joined: Fri Nov 09, 2012 1:16 pm

workspace switcher applet no longer show numbers

Postby obidamnkenobi » Thu Dec 13, 2012 9:58 pm

As the title says; the workspace applet no longer show numbers for each workspace, instead it's just a green box. See below. This happened all of a sudden. I've rebooted, restarted Cinnamon, removed and readded the applet but to no avail. Did this change for some reason? What am I missing?

edit: I'm an idiot. I changed to another theme which changed it!
Thanks to bimsebasse
Attachments
workspace_switcher.png
workspace_switcher.png (20.77 KiB) Viewed 796 times
Last edited by obidamnkenobi on Mon Dec 17, 2012 9:45 am, edited 2 times in total.

obidamnkenobi
Level 1
Level 1
Posts: 6
Joined: Fri Nov 09, 2012 1:16 pm

Re: workspace switcher applet no longer show numbers

Postby obidamnkenobi » Mon Dec 17, 2012 8:46 am

Really? Nobody?
I tried to reinstall Cinnamon previously and stuff got real weird so I did a clean install for LM 14, so I really don't want to do that again for something this small..

User avatar
bimsebasse
Level 7
Level 7
Posts: 1702
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: workspace switcher applet no longer show numbers

Postby bimsebasse » Mon Dec 17, 2012 8:55 am

That's down to the theme you're using, and it's mine (Ambiance Mint) :D

I made it like that as that was how it worked in Gnome 2 - and in your screenshot it's very easy to see, without numbers, that there are three workspaces and the first of the three is active.

To return to a numbers scheme change to pretty much any other theme in Cinnamon Settings.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!

obidamnkenobi
Level 1
Level 1
Posts: 6
Joined: Fri Nov 09, 2012 1:16 pm

Re: workspace switcher applet no longer show numbers

Postby obidamnkenobi » Mon Dec 17, 2012 9:02 am

bimsebasse wrote:That's down the theme you're using, and it's mine (Ambiance Mint) :D

I made it like that as that was how it worked in Gnome 2 - and in your screenshot it's very easy to see, without numbers, that there are three workspaces and the first of the three is active.

To return to a numbers scheme change to pretty much any other theme in Cinnamon Settings.


ahh! I see! I thought I messed with the themes trying to change it, but maybe not. doh!

I like the theme though, and think I'll stick with it. Was just wondering what was going on. I've been going back and forth whether or not I like it, and I certainly see your logic for how it works.
Thanks!

User avatar
bimsebasse
Level 7
Level 7
Posts: 1702
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: workspace switcher applet no longer show numbers

Postby bimsebasse » Mon Dec 17, 2012 9:18 am

If you want numbers in them anyway, you can edit this bit in cinnamon.css:

Code: Select all

.workspace-button {
text-shadow: 0px 1px 1px rgba(0,0,0,0.0);
width: 24px;
color: #292826;
background-color: #292826;
border: 2px solid #444;
}

.workspace-button:outlined {
    background-color: #accd8a;
    color: #accd8a;
}


Inactive workspaces have dark grey #292826 color text on #292826 color backgrounds (invisible) and outlined/active workspaces have green #accd8a color text on #accd8a color backgrounds. To get visible text, simple change the two "color:" values.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 2 guests