solved: german keyboard layout with ALT GR

Forum rules
Before you post please read how to get help
RogerWilco77
Level 1
Level 1
Posts: 2
Joined: Mon Dec 17, 2012 6:01 am

solved: german keyboard layout with ALT GR

Postby RogerWilco77 » Wed Dec 19, 2012 5:26 pm

Hello,

I have installed Mint 14 KDE rc.
Normally I use a German keyboard layout with "no dead keys".
I guess I selected this during installation, but now my layout is wrong.
For example all keys I normally access with Alt Gr are in the wrong location. The @ is on the letter "L" istead of "Q".

I tried (slight translation discrepancies back to English are possible):
Applications -> settings -> system settings -> keyboard

I can select a lot of keyboard types here, but nothing like "german without dead key".
What am I missing? Just things like "generic keyboard with 102 keys", etc...

Thanks for your help.

PS:
I guess it is related to "XKBVARIANT="mac_nodeadkeys""

Code: Select all

axel@mambo ~ $ cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="mac_nodeadkeys"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Last edited by RogerWilco77 on Wed Dec 19, 2012 5:46 pm, edited 1 time in total.

RogerWilco77
Level 1
Level 1
Posts: 2
Joined: Mon Dec 17, 2012 6:01 am

solved: Re: german keyboard layout with ALT GR

Postby RogerWilco77 » Wed Dec 19, 2012 5:45 pm

ok, quite simple solution:

wrong: XKBVARIANT="mac_nodeadkeys"
right: ........................="nodeadkeys"

valhalla_dweller
Level 1
Level 1
Posts: 28
Joined: Wed Mar 25, 2015 5:06 am
Location: Berlin, Germany

Re: solved: german keyboard layout with ALT GR

Postby valhalla_dweller » Mon Nov 09, 2015 9:52 am

I am happy to have solved this, but a different way. Had selected German keyboard layout on Linux Mint 17.2 Rafaela. Most of it seemed to be working, including the acute and grave accent to the left of the backspace key which might be handy sometimes.. BUT, ALT-GR + q = @ and ALT-GR + e = € were not, neither were {[]} on the 7,8,9,0 keys or ²³ on the 2 and 3. They are now : Go to
Keyboard ->Layout->Options->Position of Compose Key and unselect anything which has automatically selected itself, that will turn that key to the right of the space bar back into an ALT-GR.


Return to “KDE”

Who is online

Users browsing this forum: No registered users and 0 guests