[Solved] Login fails to show

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 29
Joined: Wed Aug 01, 2012 5:46 pm

[Solved] Login fails to show

Postby Zyzz » Thu Dec 20, 2012 3:55 pm


(Short story at the end.)

The download appeared to be stopped as it said something about 4 days until its complete. (It was mint-icon or so doanloading at that moment) so I thought "Hey lets stop and go again." Stupid me didn't read the next dialog correctly and just clicked "Yes", realizing moments later that that question was if it should install without the none downloaded stuff. But I didn't dare to abort that now.
So everything went fine until it came again to download the "mint icon" (10mb big?) or something like that. And again it said it takes 4+ days to finish so I stopped it again. This time telling it to not continue the installation.
Restarting the update manager it couldn't load the "updates" because they were locked from the previous update. But it was showing the 4 missing "files", so I hit start.
Now a window popped up telling me it want to remove like 1 file and updating (or installing) 4000 files. (Could that be because of "activating" the 32-bit stuff before upgrading?) That looked like a lot to me so I scrolled down and saw that that appeared to be an error as it was naming lots of empty commands or so.
Hitting start anyway and everything went fine.
After it was done I tried to check via update manager if everything was installed but it was still locked and the icon was a shield with a "wheel" no a blue "!" or a green mark.
Restarting got me to the loginscreen just for a second then the screen got gray. (Recovery the same.)
Using the previous kernel version works so I think something went wrong. :(
In the news it said it will ask for the grub position. Didn't ask me.
The update manager now tells me everything is up to date.

In short:
- probably made a few mistakes upgrading
- added the 32-bit command before upgrading too (running 64-bit)
- no grub prompt
- after reboot, loginscreen pops up and immediately screen gets gray without any chance of interaction
- previous kernel version works fine

Any chance to clean up the mess? Like reinstalling the UP6 completely?

EDIT: These are the packaged failed to download the first time:

mint-x-icons (1.0.8) to 1.1.1
mintinstall (7.3.9) to 7.4.4
mintinstall-icons (1.0.5) to 1.0.6
mintmenu (5.3.7) to 5.3.8

This is what was installed by the "weird" prompt:

Code: Select all


ia32-libs (20120102) to 1:0.4
ia32-libs-gtk (20120102) to 1:0.1

freeglut3:i386 (2.6.0-4)
gcc-4.7-base:i386 (4.7.2-4)
gtk2-engines-pixbuf:i386 (2.24.10-2)
gtk2-engines:i386 (1:2.20.2-2)
ia32-libs-gtk-i386:i386 (1:0.1)
ia32-libs-i386:i386 (1:0.4)
krb5-locales (1.10.1+dfsg-3)
lesstif2:i386 (1:0.95.2-1.1)
libacl1:i386 (2.2.51-8)
libaio1:i386 (0.3.109-3)
libart-2.0-2:i386 (2.3.21-2)
libasound2:i386 (1.0.25-4)
libasyncns0:i386 (0.8-4)
libatk1.0-0:i386 (2.4.0-2)
libattr1:i386 (1:2.4.46-8)
libaudio2:i386 (1.9.3-5)
libaudiofile1:i386 (0.3.4-2)
libavahi-client3:i386 (0.6.31-1)
libavahi-common-data:i386 (0.6.31-1)
libavahi-common3:i386 (0.6.31-1)
libbsd0:i386 (0.4.2-1)
libc6-i686:i386 (2.13-37)
libc6:i386 (2.13-37)
libcaca0:i386 (0.99.beta18-1)
libcairo2:i386 (1.12.2-2)
libcanberra-gtk-module:i386 (0.28-5)
libcanberra-gtk0:i386 (0.28-5)
libcanberra0:i386 (0.28-5)
libcap2:i386 (1:2.22-1.2)
libcomerr2:i386 (1.42.5-1)
libcups2:i386 (1.5.3-2.4)
libcurl3:i386 (7.26.0-1)
libdatrie1:i386 (0.2.5-3)
libdb5.1:i386 (5.1.29-5)
libdbus-1-3:i386 (1.6.8-1)
libdbus-glib-1-2:i386 (0.100-1)
libdirectfb-1.2-9:i386 (
libdrm-intel1:i386 (2.4.33-3)
libdrm-nouveau1a:i386 (2.4.33-3)
libdrm-radeon1:i386 (2.4.33-3)
libdrm2:i386 (2.4.33-3)
libedit2:i386 (2.11-20080614-5)
libesd0:i386 (0.2.41-10+b1)
libexif12:i386 (0.6.20-3)
libexpat1:i386 (2.1.0-1)
libffi5:i386 (3.0.10-3)
libflac8:i386 (1.2.1-6)
libfltk1.1:i386 (1.1.10-14)
libfontconfig1:i386 (2.9.0-7)
libfreetype6:i386 (2.4.9-1)
libgail-common:i386 (2.24.10-2)
libgail18:i386 (2.24.10-2)
libgcc1:i386 (1:4.7.2-4)
libgconf-2-4:i386 (3.2.5-1+build1)
libgconf2-4:i386 (3.2.5-1+build1)
libgcrypt11:i386 (1.5.0-3)
libgd2-xpm:i386 (2.0.36~rc1~dfsg-6.1)
libgdbm3:i386 (1.8.3-11)
libgdk-pixbuf2.0-0:i386 (2.26.1-1)
libgl1-mesa-dri:i386 (8.0.4-2)
libgl1-mesa-glx:i386 (8.0.4-2)
libglapi-mesa:i386 (8.0.4-2)
libglib2.0-0:i386 (2.33.12+really2.32.4-3)
libglu1-mesa:i386 (8.0.4-2)
libgmp10:i386 (2:5.0.5+dfsg-2)
libgnutls26:i386 (2.12.20-2)
libgpg-error0:i386 (1.10-3.1)
libgphoto2-2:i386 (2.4.14-2)
libgphoto2-l10n (2.4.14-2)
libgphoto2-port0:i386 (2.4.14-2)
libgpm2:i386 (1.20.4-6)
libgssapi-krb5-2:i386 (1.10.1+dfsg-3)
libgtk2.0-0:i386 (2.24.10-2)
libice6:i386 (2:1.0.8-2)
libidn11:i386 (1.25-2)
libieee1284-3:i386 (0.2.11-10)
libjack-jackd2-0 (1.9.8~dfsg.4+20120529git007cdc37-4.1)
libjack-jackd2-0:i386 (1.9.8~dfsg.4+20120529git007cdc37-4.1)
libjasper1:i386 (1.900.1-13)
libjbig0:i386 (2.0-2)
libjpeg62:i386 (6b1-3)
libjpeg8:i386 (8d-1)
libjson0:i386 (0.9-1.1)
libk5crypto3:i386 (1.10.1+dfsg-3)
libkeyutils1:i386 (1.5.5-3)
libkrb5-3:i386 (1.10.1+dfsg-3)
libkrb5support0:i386 (1.10.1+dfsg-3)
liblcms1:i386 (1.19.dfsg-1.2)
libldap-2.4-2:i386 (2.4.31-1)
libltdl7:i386 (2.4.2-1.1)
liblua5.1-0:i386 (5.1.5-4)
liblzma5:i386 (5.1.1alpha+20120614-2)
liblzo2-2:i386 (2.06-1)
libmng1:i386 (1.0.10-3)
libmpc2:i386 (0.9-4)
libmpfr4:i386 (3.1.0-5)
libmpg123-0:i386 (1.14.4-1)
libncursesw5:i386 (5.9-10)
libnspr4-0d:i386 (2:4.9.2-1)
libnspr4:i386 (2:4.9.2-1)
libnss3-1d:i386 (2:3.13.6-1)
libnss3:i386 (2:3.13.6-1)
libodbc1:i386 (2.2.14p2-5)
libogg0:i386 (1.3.0-4)
libopenal1:i386 (1:1.14-4)
libp11-kit0:i386 (0.12-3)
libpam0g:i386 (1.1.3-7.1)
libpango1.0-0:i386 (1.30.0-1)
libpciaccess0:i386 (0.13.1-2)
libpcre3:i386 (1:8.30-5)
libpixman-1-0:i386 (0.26.0-3)
libpng12-0:i386 (1.2.49-1)
libpopt0:i386 (1.16-7)
libpulse0:i386 (2.0-6)
libqt4-dbus:i386 (4:4.8.2+dfsg-2)
libqt4-network:i386 (4:4.8.2+dfsg-2)
libqt4-script:i386 (4:4.8.2+dfsg-2)
libqt4-test:i386 (4:4.8.2+dfsg-2)
libqt4-xml:i386 (4:4.8.2+dfsg-2)
libqtcore4:i386 (4:4.8.2+dfsg-2)
libqtgui4:i386 (4:4.8.2+dfsg-2)
librtmp0:i386 (2.4+20111222.git4e06e21-1)
libsamplerate0:i386 (0.1.8-5)
libsane-extras:i386 (
libsane:i386 (1.0.22-7.4)
libsasl2-2:i386 (2.1.25.dfsg1-6)
libsasl2-modules:i386 (2.1.25.dfsg1-6)
libsdl1.2debian:i386 (1.2.15-5)
libselinux1:i386 (2.1.9-5)
libsigc++-2.0-0c2a:i386 (2.2.10-0.2)
libslang2:i386 (2.2.4-15)
libsm6:i386 (2:1.2.1-2)
libsndfile1:i386 (1.0.25-5)
libsqlite3-0:i386 (3.7.13-1)
libssh2-1:i386 (1.4.2-1.1)
libssl1.0.0:i386 (1.0.1c-4)
libstdc++5:i386 (1:3.3.6-25)
libstdc++6:i386 (4.7.2-4)
libsvga1:i386 (1:1.4.3-33)
libsysfs2:i386 (2.1.0+repack-1.2)
libtasn1-3:i386 (2.13-2)
libtdb1:i386 (1.2.10-2)
libthai0:i386 (0.1.18-2)
libtiff4:i386 (3.9.6-9)
libtinfo5:i386 (5.9-10)
libts-0.0-0:i386 (1.0-11)
libusb-0.1-4:i386 (2:0.1.12-20+nmu1)
libuuid1:i386 (2.20.1-5.2)
libv4l-0:i386 (0.8.8-3)
libv4lconvert0:i386 (0.8.8-3)
libvorbis0a:i386 (1.3.2-1.3)
libvorbisenc2:i386 (1.3.2-1.3)
libvorbisfile3:i386 (1.3.2-1.3)
libwrap0:i386 (7.6.q-24)
libx11-6:i386 (2:1.5.0-1)
libx11-xcb1:i386 (2:1.5.0-1)
libx86-1:i386 (1.1+ds1-10)
libxau6:i386 (1:1.0.7-1)
libxaw7:i386 (2:1.0.10-2)
libxcb-glx0:i386 (1.8.1-2)
libxcb-render-util0:i386 (0.3.8-1.1)
libxcb-render0:i386 (1.8.1-2)
libxcb-shm0:i386 (1.8.1-2)
libxcb1:i386 (1.8.1-2)
libxcomposite1:i386 (1:0.4.3-2)
libxcursor1:i386 (1:1.1.13-1)
libxdamage1:i386 (1:1.1.3-2)
libxdmcp6:i386 (1:1.1.1-1)
libxext6:i386 (2:1.3.1-2)
libxfixes3:i386 (1:5.0-4)
libxft2:i386 (2.3.1-1)
libxi6:i386 (2:1.6.1-1)
libxinerama1:i386 (2:1.1.2-1)
libxml2:i386 (2.8.0+dfsg1-6)
libxmu6:i386 (2:1.1.1-1)
libxmuu1:i386 (2:1.1.1-1)
libxp6:i386 (1:1.0.1-2)
libxpm4:i386 (1:3.5.10-1)
libxrandr2:i386 (2:1.3.2-2)
libxrender1:i386 (1:0.9.7-1)
libxslt1.1:i386 (1.1.26-14)
libxss1:i386 (1:1.2.2-1)
libxt6:i386 (1:1.1.3-1)
libxtst6:i386 (2:1.2.1-1)
libxv1:i386 (2:1.0.7-1)
libxxf86vm1:i386 (1:1.1.2-1)
odbcinst1debian2:i386 (2.2.14p2-5)
xaw3dg:i386 (1.5+E-18.2)
zlib1g:i386 (1:1.2.7.dfsg-13)

Thanks for your time reading this. :)
Last edited by Zyzz on Fri Dec 21, 2012 10:51 am, edited 1 time in total.

Level 1
Level 1
Posts: 29
Joined: Wed Aug 01, 2012 5:46 pm

Re: Login fails to show

Postby Zyzz » Fri Dec 21, 2012 10:17 am

Ok now I tried to reinstall the header and image kernel files.
Maybe it's a normal error msg but that's what I got:

Code: Select all

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
does not represent a valid dkms.conf file.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
Found linux image: /boot/vmlinuz-3.2.0-3-amd64
Found initrd image: /boot/initrd.img-3.2.0-3-amd64
Found linux image: /boot/vmlinuz-3.2.0-2-amd64
Found initrd image: /boot/initrd.img-3.2.0-2-amd64
Found Windows 7 (loader) on /dev/sda1
linux-headers-3.2.0-4-common (3.2.32-1) wird eingerichtet ...
linux-headers-3.2.0-4-amd64 (3.2.32-1) wird eingerichtet ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-4-amd64
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
does not represent a valid dkms.conf file.
linux-headers-amd64 (3.2+46) wird eingerichtet ...
linux-image-amd64 (3.2+46) wird eingerichtet ...

Level 1
Level 1
Posts: 29
Joined: Wed Aug 01, 2012 5:46 pm

Re: Login fails to show

Postby Zyzz » Fri Dec 21, 2012 10:50 am

Alright I found a pretty easy solution. For anyone else having that problem:
Run 'sudo dpkg-reconfigure nvidia-kernel-dkms' (if you use nvidia drivers) or 'sudo dpkg-reconfigure fglrx-modules-dkms' (if you use AMD drivers).

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests