mintConstructor /dev/null: Permission denied [Solved]

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
dritzominous
Level 3
Level 3
Posts: 159
Joined: Sat Nov 14, 2009 12:49 am

mintConstructor /dev/null: Permission denied [Solved]

Postby dritzominous » Thu Dec 20, 2012 4:48 am

--Working with LMDE Xfce (latest respin)--

When mintconstructor opens an xterm with chroot, I get a ton of these errors:

Code: Select all

bash: /dev/null: Permission denied


From what I've read online, it's supposed to have to have something to do with how the disk is mounted. I don't really know. I've never had this problem when I was remastering LM13 Xfce. Weird.

In the meantime, I can't do squat with apt in the chrooted shell.

Any help is always appreciated. :)
Last edited by dritzominous on Sat Dec 22, 2012 1:24 pm, edited 2 times in total.

User avatar
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: mintConstructor /dev/null: Permission denied

Postby Schoelje » Fri Dec 21, 2012 4:04 am

When I started with the unofficial LMDE KDE, I had several problems with mintconstructor.
I had to change some files and posted that to Github, but as far as I know these changes were not merged into mintconstructor.

I'll attach them here:
mintConstructor.glade.tar.gz
(10.46 KiB) Downloaded 147 times


Copy both .py and .glade file to /usr/lib/linuxmint/mintConstructor

Hope this helps.

User avatar
dritzominous
Level 3
Level 3
Posts: 159
Joined: Sat Nov 14, 2009 12:49 am

Re: mintConstructor /dev/null: Permission denied

Postby dritzominous » Fri Dec 21, 2012 2:03 pm

Thanks, I'll try it out this afternoon!

User avatar
dritzominous
Level 3
Level 3
Posts: 159
Joined: Sat Nov 14, 2009 12:49 am

Re: mintConstructor /dev/null: Permission denied

Postby dritzominous » Sat Dec 22, 2012 1:23 pm

Fixed!

It was probably the code that you added starting @ ln 364 that made it work.

Working on a LMDE Xfce remaster now... :mrgreen:

User avatar
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: mintConstructor /dev/null: Permission denied

Postby Schoelje » Sat Dec 22, 2012 1:46 pm

dritzominous wrote:Fixed!

It was probably the code that you added starting @ ln 364 that made it work.

Working on a LMDE Xfce remaster now... :mrgreen:


Glad I could help.


Return to “Software & Applications”

Who is online

Users browsing this forum: NADAV1479 and 1 guest