Reboot and select proper boot device after installing

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sat Dec 29, 2012 11:29 pm

Reboot and select proper boot device after installing

Postby DesperateandTired » Sat Dec 29, 2012 11:49 pm

Please, I know this is a common error, but I`ve been working on it for 20 hours, I`m desperate! I have an exam in 3 days and I need my computer! I`ve searched for everysolution I could find but none seems to work. Just please bear with me!
I have an Asus ATTVM, 64-bit Intel i7 processor. I had installed windows 8, had it for almost 2 weeks, than it just stopped booting and giving me the BSOD. Intel Rapid Storage technology could have something to do with it. tried recovering with windows 8 windows 7 and windows xp disk but they just tell me that the disks, partitions are blocked. Or that they`re GPT and not MBR.
I installed Linux Mint, and everything went fine but when I restart it gives me that error. In bios I can-t see and add my hardrive as an option, just dvd and usb.
I tried repairing the boot with boot-repair, and everything seemed to go right
but it still doesn-t work In bios it sais Windows boot manager (driver not present).
I tried assigning the boot flag wit gparted but it doesn`t work.
I`m not interested to going back to windows, Linux Mint seems perfect for me, but I can`t get it to boot and I haven`t slept in a long time

User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Re: Reboot and select proper boot device after installing

Postby viking777 » Sun Dec 30, 2012 8:05 am

I just wrote a detailed reply to this, when I pressed 'Submit' the forum timed out and lost the post so this is the abbreviated version.

1)Look in your bios and see if it is possible to switch off Uefi and boot and install the mint live cd in non-efi mode (not all bioses have this setting).
2)Try and install grub-efi-amd64 into the Mint installation (it may have installed grub-pc by mistake - it happened to me). You will have to know about chroot in order to do this.
3)Given the urgency, install Ubuntu 12.10 instead for now, its Uefi implementation definitely works, it was the only distro I could install to begin with. You can switch to Mint when you have more time.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

Return to “Newbie Questions”