[SOLVED] /usr/bin/X using too much CPU after Update Pack 5

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 8
Joined: Mon Oct 10, 2011 4:07 pm

[SOLVED] /usr/bin/X using too much CPU after Update Pack 5

Postby lvxferre » Thu Sep 27, 2012 7:35 pm

Short story: /usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.auth -nolisten tcp vt8 using too much CPU after upgrade. What to do?

Long story:
When dealing with heavier programs (Firefox with Flash and a bunch of tabs open, or OpenTTD, or Minecraft, or GIMP with larger images, or other applications), /usr/bin/X usage of CPU rises sharply, sometimes using 100% of one core. It starts randomly - sometimes as soon as I open the program, sometimes after one hour. When I close said application, X's CPU usage lowers a bit, but it's still in the range of 10-12%.

Checking htop, the "offending" process is always /usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.auth -nolisten tcp vt8. Things I've already tried:
  • Killing the offending process. When X restarts, the issue continues.
  • Googling it for days. I've seem more people with this problem, but no answer for this.
  • Swapping MDM with GDM3. The issue remains the same, only with /var/lib/gdm3 instead of /var/lib/mdm.
  • Logging from console. Same as above, but with /var/lib/x-auth hogging CPU instead.
  • Uninstalling the NVidia driver (302.17) provided by the distro and installing the one in NVidia's site (304.something). No change.
  • Deactivating Compiz for Xfwm4. No change.
  • Using 3.2.0-3-amd64 kernel instead of 3.2.0-3-rt-amd64 or the old kernel (3.2.0-2, I think). The issue remains.
Seriously, I got no idea of what else I can try. Could you guys help me? Before UP4, this wasn't happening, now it happens in an annoying rate, specially with Minecraft (renders the game unplayable at ~4fps) but, as I said, it affects some distribution's programs too.

Machine where this happens: CPU AMD Athlon II X2 dual core; 4GB RAM; GPU Geforce 9400GT. LMDE 64 bits with Xfce.

UPDATE: Since another program that got sluggish and slow was Vuze, I tried different JDK versions (sun, openjdk-6, openjdk-7). No success.
Last edited by lvxferre on Fri Sep 28, 2012 4:56 am, edited 1 time in total.

Level 1
Level 1
Posts: 8
Joined: Mon Oct 10, 2011 4:07 pm

Re: /usr/bin/X using too much CPU after Update Pack 5

Postby lvxferre » Fri Sep 28, 2012 4:56 am

Well, after hours and hours of head-scratching, I've identified myself the problem: the GPU was overheating with the newer drivers. X using too much CPU was a symptom (the GPU stopped/slowed and then the CPU needed to do its work), not the main cause.

Reverting the driver back to 295.20 from NVidia site (and letting the thing cool down a bit) solved the issue, I'll mark this as "solved" in order to help other people.

User avatar
Level 1
Level 1
Posts: 47
Joined: Thu Nov 08, 2012 4:48 am
Location: Australia

Re: [SOLVED] /usr/bin/X using too much CPU after Update Pack

Postby kiwi » Wed Jan 02, 2013 11:35 pm

With thanks and apologies for the additon to lvxferre.

Adding information about a similar problem in case someone googles this thread and gains value.

Linux Mint 13 then Linux Mint 14

Linux mint would freeze. Some mouse use but no or extremely limited (slow to stopped) access to open applications. Ended up having to Ctrl Shft F12 to kill the session and then restart the computer. I tried a lot of things suggested in various mint and ubuntu threads to resolve it and sometimes it seemed to have abated but with the new Mint 14 I could rely on it happening within 4-5 hours of resuming from sleep.

It seemed that using suspend either from the menu or using Hal and autokey would trigger the situation: some random time after restarting from suspend the computer would freeze. I proved this by never suspending it and never getting the issue - however I prefer to use suspend overnight so I was disappointed I couldn't solve it. Using HTOP showed no obvious high CPU usage apps although usr/bin/X etc was higher after resumption.

After reading this thread I got the idea of changing my NVIDIA drivers again. I had settled on the first NVIDIA driver in the list of Additional Drivers (to get my two screen NVIDIA 9600 setup running) so I experimented. Using the last on the list (Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library from nvidia-experimental-304) the problem seems to have gone. So it would appear that video drivers might have been the issue and might be resolved - but moving in the opposite direction to the OP.

I will post again if this proves premature.

I also followed the procedures recommended for Suspend/Hibernation problems at:

Linux Mint 18 x64 Zsh Python -- shutdown scripts using systemd

Level 1
Level 1
Posts: 1
Joined: Mon Jun 10, 2013 12:04 pm

Re: [SOLVED] /usr/bin/X using too much CPU after Update Pack

Postby michaelhughes » Mon Jun 10, 2013 12:14 pm

I had the same problem, nearly 70%cpu on X and the other 30% on cinnamon. Running 2 screens on a dell E6400, Intel Core2 Duo 2.4GHz. 8GB ram.

I don't know why, but when I set my screen background to "no picture" it immediately stopped.

I found this posting helpful because it made me think of trying things on the graphics card; and I thought I'd share what I learned.


Return to “Archive”