Cannot install ia32-libs

Archived topics about LMDE 1
Forum rules
dezo
Level 2
Level 2
Posts: 59
Joined: Sat Apr 07, 2012 3:16 pm

Cannot install ia32-libs

Postby dezo » Thu Jan 03, 2013 12:53 pm

Hello guys,
on UP6 I cannot install ia32-libs:

Code: Select all

$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-i386 but it is not installable
E: Unable to correct problems, you have held broken packages.


Why?

sources.list:

Code: Select all

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot install ia32-libs

Postby zerozero » Thu Jan 03, 2013 12:55 pm

please share the output of

Code: Select all

dpkg --print-foreign-architectures
Image

[ bliss of ignorance ]

dezo
Level 2
Level 2
Posts: 59
Joined: Sat Apr 07, 2012 3:16 pm

Re: Cannot install ia32-libs

Postby dezo » Thu Jan 03, 2013 12:59 pm

Code: Select all

$ dpkg --print-foreign-architectures
i386

dezo
Level 2
Level 2
Posts: 59
Joined: Sat Apr 07, 2012 3:16 pm

Re: Cannot install ia32-libs

Postby dezo » Thu Jan 03, 2013 1:13 pm

Ups, I've missed apt-get update, problem solved. :)

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot install ia32-libs

Postby zerozero » Thu Jan 03, 2013 1:22 pm

anyway you don't need ia32-libs (in a multiarch system)
see this
http://wiki.debian.org/Multiarch/Implem ... _multiarch
and this discussion
http://forums.debian.net/viewtopic.php? ... 8309fec9ef
(unless you see a problem with a specific pkg that you want to share)
Image

[ bliss of ignorance ]

dezo
Level 2
Level 2
Posts: 59
Joined: Sat Apr 07, 2012 3:16 pm

Re: Cannot install ia32-libs

Postby dezo » Thu Jan 03, 2013 4:58 pm

Great! I did this because of wine and apt-get install wine-bin:i386 works great as well!

shekeine
Level 1
Level 1
Posts: 1
Joined: Tue Apr 09, 2013 3:38 am

Re: Cannot install ia32-libs

Postby shekeine » Tue Apr 09, 2013 4:03 am

Hello all,
I have not been able to install any i386 application : Wine/Google earth/Skype etc [on my Linux Mint 13, 64 bit ] due to is ia32 libs issue. From what I have understood from this and other forums, ia32libs is not necessary anymore. Running "dpkg --print-foreign-architectures" as recommended on this thread returns i386 and I have run "apt-get update" countless times, but when I try to install from any i386 deb package such as google earth, I still get "Error: cannot install ia32-libs". Attempting to install other i386 apps reports unmet dependencies, for example, attempting a skype install from apt/deb package gives:

Error, Cannot install libqwebkit4:'i386'

I have no idea what could be wrong here, since multiarch is enabled on my system which is upto date as well! Any help will be much appreciated.


Best, Shekeine.


Return to “Archive”

Who is online

Users browsing this forum: linux22 and 0 guests