12 hour clock stuck in 24 hour mode SOLVED

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
trefall
Level 3
Level 3
Posts: 171
Joined: Tue Dec 22, 2009 3:13 pm
Location: Mexico

12 hour clock stuck in 24 hour mode SOLVED

Postby trefall » Wed Jan 25, 2012 11:09 pm

As always any help is appreciated. I switched to Cinnamon from Gnome (not exactly sure of the difference) using Mint 12. Now, even though my 'Date and Time Settings' show my clock is set in 12 hour (AM/PM) mode the clock display on the desktop only shows in 24 hour mode. Any ideas?
Last edited by trefall on Thu Jan 26, 2012 1:36 am, edited 1 time in total.
HP Pavilion DV6 17.2" 1366x768pix 6GB RAM
560GB DD Mint 17 (Cinnamon) Intel i5 quad 2.4mhz

User avatar
KoHoSo
Level 1
Level 1
Posts: 22
Joined: Tue Oct 19, 2010 10:38 pm
Location: Crestline, California USA
Contact:

Re: 12 hour clock stuck in 24 hour mode

Postby KoHoSo » Thu Jan 26, 2012 1:27 am

I am having the same problem with LM12. I've been using Cinnamon for a while now. The problem showed up a few days ago, perhaps after the most recent update for Cinnamon showed up in the Update Manager. I verified that the setting had not been switched. I clicked it over to 24 hour, closed, and then went back to 12 hour but still no change. It's only a minor thing but a fix would be nice.
I was a bland little boy until I discovered the joys of weirdness. - John Kricfalusi

trefall
Level 3
Level 3
Posts: 171
Joined: Tue Dec 22, 2009 3:13 pm
Location: Mexico

Re: 12 hour clock stuck in 24 hour mode

Postby trefall » Thu Jan 26, 2012 1:35 am

Found it in the Cinnamon notes page. http://forum.linuxmint.com/viewtopic.php?f=208&t=89411&start=380. Change the 'Cinnamon Settings' - H to l (Upper case H to lower case L)
HP Pavilion DV6 17.2" 1366x768pix 6GB RAM
560GB DD Mint 17 (Cinnamon) Intel i5 quad 2.4mhz

craig10x
Level 7
Level 7
Posts: 1576
Joined: Fri Jul 03, 2009 12:44 pm

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby craig10x » Thu Jan 26, 2012 2:43 am

crzen and kmb42vt provided the solution on that linked thread...
I started having the problem when i installed the latest version (1.2)...Clem is aware and it will be fixed in future version...meanwhile you (or anyone else with the problem) can fix it as they outlined below:

craig in cinnamon-settings -> calender. change the date format in panel.
the cap "H" means 24 hour. cap "I" means 12 hour:
%a %b %e, %I:%M or
%a %b %e, %I:%M %p


You'll also need to add "%p" after the line above if you want to see AM/PM after the time as well:

%A %b %e %l:%M %p = Monday Jan 23 2:50 PM (the "time" is just an example of course).

You'll notice a link in Cinnamon settings/Calendar labeled: "Generate your own date formats"? Clicking on that link open your browser to this page:

woodsmoke
Level 2
Level 2
Posts: 75
Joined: Tue Jul 07, 2009 4:46 am
Location: Midwest USA: "flyover country" for the elites of either coast USA

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby woodsmoke » Sat Jan 28, 2012 5:27 pm

Hi
I'm running kind of late, but was able to get into the site and found the same as outlined above by craig10x and and can confirm that it works on my superos/mint/cinnamon install.

woodsmoke

webguy64
Level 1
Level 1
Posts: 45
Joined: Sun Jan 01, 2012 5:14 pm

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby webguy64 » Sat Feb 18, 2012 6:37 pm

I'm having the same problem. Glad it's not just me.
I'll stick with Gnome for now until it's fixed

skunkjar
Level 1
Level 1
Posts: 3
Joined: Fri May 25, 2012 10:00 pm

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby skunkjar » Fri May 25, 2012 10:02 pm

Thanks, that worked perfectly. I love this community!

tbrownarcher2
Level 4
Level 4
Posts: 476
Joined: Mon Aug 06, 2012 12:56 pm

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby tbrownarcher2 » Sun Aug 19, 2012 5:58 pm

the same question the same success. I too am happy that this community exists. It worked

Thanks,
Nate
HP 2000 Notebook PC running windows 8.1 (lap top )

and

Acer Aspire running linux mint 17.1 on the linux side and windows 10

TheKOAD
Level 1
Level 1
Posts: 3
Joined: Thu Jan 03, 2013 10:49 pm

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby TheKOAD » Fri Jan 04, 2013 4:50 am

This shoul be fixed by now. make it an update "fixes confusing clock bug"

User avatar
beachgardener
Level 3
Level 3
Posts: 101
Joined: Sun Sep 19, 2010 10:22 pm
Location: Australia

Re: 12 hour clock stuck in 24 hour mode SOLVED

Postby beachgardener » Fri Jan 11, 2013 7:53 pm

Thanks for this :)
Linux Mint 17.3 Cinnamon - 64bit


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 1 guest