How To Disable Lock Screen In Gnome

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
User avatar
tdockery97
Level 14
Level 14
Posts: 5025
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

How To Disable Lock Screen In Gnome

Postby tdockery97 » Mon Aug 15, 2011 12:38 am

A common request on the forums is "How do I disable the screen lock following screensaver or resume from suspend?"

It's actually very simple and completely solves the problem. I've included a clickable thumbnail of a screenshot for each step, so here we go.

1. You need to open the gconfig editor by keying Alt-F2 and enter gconf-editor in the text box:
Image

2. Next double-click on desktop to open the tree further:

Image

3. Next double-click on gnome to open the tree further:
Image

4. Click once on lockdown and you'll see selections in the right-hand window. Tick the disable_ lock_screen box, close gconf2 and you are done. :D
Image
Image


Mint MATE 18

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: How To Disable Lock Screen In Gnome

Postby zombie » Mon Aug 15, 2011 2:12 am

Why not simply: Preferences > Screensaver > Uncheck 'Lock screen when screensaver is active' ?
Works for me.

User avatar
tdockery97
Level 14
Level 14
Posts: 5025
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: How To Disable Lock Screen In Gnome

Postby tdockery97 » Mon Aug 15, 2011 2:16 am

I've heard of several cases where that doesn't "stick". I've had installations where it happened to me as well. This way you cut it off at the source.
Image


Mint MATE 18

TenBirds
Level 1
Level 1
Posts: 1
Joined: Tue Jan 01, 2013 2:54 pm

Re: How To Disable Lock Screen In Gnome

Postby TenBirds » Tue Jan 01, 2013 3:06 pm

Thanks a lot!

That was extremely irritating.

rafi
Level 1
Level 1
Posts: 20
Joined: Wed Jan 02, 2013 11:46 pm

Re: How To Disable Lock Screen In Gnome

Postby rafi » Sat Jan 05, 2013 1:59 pm

Thanks tdockery97, but that actually doesn't work for me. I'm on a fresh install of Linux Mint 14. Upon boot, Mint logs on automatically, but not when coming back from suspend or hibernate, no matter what the tick setting that you suggest.

I also tried to edit gnome-power-manager setting as suggested elsewhere in this forum (http://forums.linuxmint.com/viewtopic.php?f=90&t=24051#p140671) but that key does not exist in my install. Also, preferences->screensaver does no longer exist.

Any ideas what could be the issue?

Thanks!

Cheers,
rafi

rafi
Level 1
Level 1
Posts: 20
Joined: Wed Jan 02, 2013 11:46 pm

Re: How To Disable Lock Screen In Gnome

Postby rafi » Sun Jan 20, 2013 10:37 pm

OK, no somebody explain me why I didn't see that earlier, but Preferences->Brightness and Lock-> Lock set to "off" works... doh :oops:

matthewkuhl
Level 1
Level 1
Posts: 2
Joined: Sun May 26, 2013 12:12 pm
Location: San Diego, CA

Re: How To Disable Lock Screen In Gnome

Postby matthewkuhl » Thu Jun 06, 2013 6:07 pm

Thanks!
Any idea how to simply change the background? This is better than having the default wallpaper as the lock screen image, but if i could change the image to my current wallpaper i would not mind the lock screen so much.

rompelstilchen
Level 1
Level 1
Posts: 11
Joined: Tue Oct 15, 2013 4:03 pm

Re: How To Disable Lock Screen In Gnome

Postby rompelstilchen » Tue Dec 16, 2014 3:47 pm

there is no gconf-edit in my mint 17 distro

Otheus
Level 1
Level 1
Posts: 1
Joined: Tue Apr 14, 2015 1:23 pm

Please update answer

Postby Otheus » Tue Apr 14, 2015 1:27 pm

As previous comment, Mint 17 does not have gconf-editor. There *is* a Preferences->"Screen Locker" widget, but this only disables locking screen after the computer goes to sleep or the "screen turns off" whatever that means. That doesn't sound like the right thing. I want to completely disable it as I'm running this within a VM on a desktop that already locks the screen.

-Mr Happy-
Level 1
Level 1
Posts: 1
Joined: Thu Dec 24, 2015 7:33 pm

Re: How To Disable Lock Screen In Gnome

Postby -Mr Happy- » Thu Dec 24, 2015 7:39 pm

Linux Mint 17.3 under System Settings > Screensaver > Settings options for Lock the computer when inactive work for me.


Return to “Tutorials”

Who is online

Users browsing this forum: No registered users and 2 guests