won't boot because of fstab changes [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
aldrigmer
Level 1
Level 1
Posts: 5
Joined: Sun Jan 06, 2013 6:12 pm

won't boot because of fstab changes [SOLVED]

Postby aldrigmer » Sun Jan 06, 2013 6:24 pm

Hi!

im new on linux mint and sofar everythings been fine - but i wanted my harddrives and partitions to automount and changed them with mountmanager and after that i couldnt boot anymore. i get to the linux mint logo and then it stops. through repair mode or what its called i could see it stops becouse it cant mount all devices. how can i change that? i have a live cd and would like an answer i can understand :) can i somehow reset fstab? without too much knowledge of linux?
Last edited by aldrigmer on Thu Jan 10, 2013 7:35 am, edited 1 time in total.

User avatar
nomko
Level 10
Level 10
Posts: 3030
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: won't boot because of fstab changes

Postby nomko » Mon Jan 07, 2013 7:09 am

aldrigmer wrote:Hi!

im new on linux mint and sofar everythings been fine - but i wanted my harddrives and partitions to automount and changed them with mountmanager and after that i couldnt boot anymore. i get to the linux mint logo and then it stops. through repair mode or what its called i could see it stops becouse it cant mount all devices. how can i change that? i have a live cd and would like an answer i can understand :) can i somehow reset fstab? without too much knowledge of linux?


If everything went okay, you should have a backup file of your original fstab file. Start the live-cd and mount your internal disc and open it with the filemanager. Go to this directory: /etc/ and delete the fstab file. Then rename your backed up fstab file.

Your original fstab file is simply called: fstab
The backed up file is called fstab.backup. Just by removing the extension .backup and you have your original fstab file back. Reboot and see what happens then.

If you can log into linux, open a terminal and type the following command:

Code: Select all

cat /etc/fstab
and place the output here. Also tell us then which drives you want to automount.

aldrigmer
Level 1
Level 1
Posts: 5
Joined: Sun Jan 06, 2013 6:12 pm

Re: won't boot because of fstab changes

Postby aldrigmer » Tue Jan 08, 2013 4:01 pm

Thank you for your answer!

i have no backup!
this is what fstab looks like:
UUID=8E2C05EC2C05D05F /media/user/Musik ntfs-3g users 0 0
UUID=001CE7BD1CE7AC3A /media/user/001CE7BD1CE7AC3A ntfs-3g defaults 0 0
UUID=6614a18c-b008-4daa-8fe1-006887d9df7e swap swap sw 0 0
UUID=8CB0AA73B0AA6404 /media/user/8CB0AA73B0AA6404 ntfs-3g users 0 0
UUID=bdee0c71-50bf-4d72-9c86-1e678c175dc7 / ext4 users 0 1

cat /etc/fstab gives me:
overlayfs / overlayfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sdb6 swap swap defaults 0 0

aldrigmer
Level 1
Level 1
Posts: 5
Joined: Sun Jan 06, 2013 6:12 pm

Re: won't boot because of fstab changes

Postby aldrigmer » Tue Jan 08, 2013 4:49 pm

all i get after trying recovery mode is:
mountall : mount/ permission denied

and then it stops

altair4
Level 17
Level 17
Posts: 7842
Joined: Tue Feb 03, 2009 10:27 am

Re: won't boot because of fstab changes

Postby altair4 » Wed Jan 09, 2013 8:36 am

UUID=bdee0c71-50bf-4d72-9c86-1e678c175dc7 / ext4 users 0 1

The "users" option disables the ability to execute any binaries - even to root. Root is trying to execute a whole mess of stuff when it boots so this is not a good thing.

Change the line to look like this:

Code: Select all

UUID=bdee0c71-50bf-4d72-9c86-1e678c175dc7 / ext4 errors=remount-ro 0       1

That will get you back to the default setting for that partition.

From the looks of it you may get other errors but you should be given a chance to bypass them and boot anyway. If this works we can fix the ntfs partitions to have a better set of options than what mountmanger offered.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

aldrigmer
Level 1
Level 1
Posts: 5
Joined: Sun Jan 06, 2013 6:12 pm

Re: won't boot because of fstab changes

Postby aldrigmer » Thu Jan 10, 2013 7:34 am

thank you altair4!
worked just fine. so now my fstab looks like this:

UUID=8E2C05EC2C05D05F /media/user/Musik ntfs-3g users 0 0
UUID=001CE7BD1CE7AC3A /media/user/001CE7BD1CE7AC3A ntfs-3g defaults 0 0
UUID=6614a18c-b008-4daa-8fe1-006887d9df7e swap swap sw 0 0
UUID=8CB0AA73B0AA6404 /media/user/8CB0AA73B0AA6404 ntfs-3g users 0 0
UUID=bdee0c71-50bf-4d72-9c86-1e678c175dc7 / ext4 errors=remount-ro 0 1

and everything is working just fine. every disk/partition mounted succesfully on startup, just like i wanted. should i keep it that way or was this a temporary solution?

altair4
Level 17
Level 17
Posts: 7842
Joined: Tue Feb 03, 2009 10:27 am

Re: won't boot because of fstab changes

Postby altair4 » Thu Jan 10, 2013 7:46 am

aldrigmer wrote:thank you altair4!
worked just fine. so now my fstab looks like this:

UUID=8E2C05EC2C05D05F /media/user/Musik ntfs-3g users 0 0
UUID=001CE7BD1CE7AC3A /media/user/001CE7BD1CE7AC3A ntfs-3g defaults 0 0
UUID=6614a18c-b008-4daa-8fe1-006887d9df7e swap swap sw 0 0
UUID=8CB0AA73B0AA6404 /media/user/8CB0AA73B0AA6404 ntfs-3g users 0 0
UUID=bdee0c71-50bf-4d72-9c86-1e678c175dc7 / ext4 errors=remount-ro 0 1

and everything is working just fine. every disk/partition mounted succesfully on startup, just like i wanted. should i keep it that way or was this a temporary solution?

As an ordained minister in the "Church of If It Ain't Broke Don't Fix It", I would leave it alone. And this was permanent.

I personally don't care much for how those NTFS partitions are configured but as you found out they will work. Besides, if you are the only user of the PC I suppose it doesn't matter.

I would like to make one recommendation though: Do not use mountmanager, PySDM, ntfs-config, especially Disks, or any of the other fstab editors - each one of them has issues and produce unpredictable results.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

aldrigmer
Level 1
Level 1
Posts: 5
Joined: Sun Jan 06, 2013 6:12 pm

Re: won't boot because of fstab changes [SOLVED]

Postby aldrigmer » Thu Jan 10, 2013 7:58 am

thank you very much :)

LilAntny
Level 1
Level 1
Posts: 2
Joined: Tue Apr 19, 2016 12:37 am

Re: won't boot because of fstab changes [SOLVED]

Postby LilAntny » Sun Apr 24, 2016 12:56 am

I am having a similar problem (Mint 17.2). After setting up my ntfs drives to auto mount, my system won't boot. However my fstab appears to be correct (At least according to previous posts). I also do not have a backup fstab file.

UUID=86810c4a-912f-4ea8-9a1d-347a25c0df7e / ext4 errors=remount-ro 0 1
LABEL=Series\0406T-1000 /mnt/Series\0406T-1000 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Series\0404T-1000 /mnt/Series\0404T-1000 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Series\0408T-1000 /mnt/Series\0408T-1000 auto nosuid,nodev,nofail,x-gvfs-show 0 0

User avatar
austin.texas
Level 17
Level 17
Posts: 7527
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: won't boot because of fstab changes [SOLVED]

Postby austin.texas » Sun Apr 24, 2016 4:28 pm

LilAntny wrote:I am having a similar problem (Mint 17.2). After setting up my ntfs drives to auto mount, my system won't boot. However my fstab appears to be correct (At least according to previous posts). I also do not have a backup fstab file.

UUID=86810c4a-912f-4ea8-9a1d-347a25c0df7e / ext4 errors=remount-ro 0 1
LABEL=Series\0406T-1000 /mnt/Series\0406T-1000 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Series\0404T-1000 /mnt/Series\0404T-1000 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Series\0408T-1000 /mnt/Series\0408T-1000 auto nosuid,nodev,nofail,x-gvfs-show 0 0


Edit your /etc/fstab and get rid of the "x-gvfs-show" garbage.
Make it:
UUID=86810c4a-912f-4ea8-9a1d-347a25c0df7e / ext4 errors=remount-ro 0 1
LABEL=Series\0406T-1000 /mnt/Series\0406T-1000 auto nosuid,nodev,nofail 0 0
LABEL=Series\0404T-1000 /mnt/Series\0404T-1000 auto nosuid,nodev,nofail 0 0
LABEL=Series\0408T-1000 /mnt/Series\0408T-1000 auto nosuid,nodev,nofail 0 0
Mint 17.3 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

Linux Linx 2016


Return to “Installation & Boot”

Who is online

Users browsing this forum: Baidu [Spider], ventor and 6 guests