No sound at all in Mint 14 Nadia!

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Mon Jul 30, 2012 6:08 pm

No sound at all in Mint 14 Nadia!

Postby bamboorecruit » Mon Jan 14, 2013 12:55 am

I just updated from Mint 12 Lisa to Mint 14 Nadia and while I love the way everything is a touch more user-friendly, I'm very upset over not having sound at all. I've read that other people have had problems with this within the last few months, and some solved their problem but mine seems to be different. Mint does not seem to recognize my speakers at all, but it does recognize the mic on my webcam. I've tried installing Gnome ALSA Mixer by suggestion of a Mint user, but that just did not do anything. When I punch in a terminal with aplay -l I'm shown only with "**** List of PLAYBACK Hardware Devices ****" and nothing below that. I really do not want to downgrade because I do like this update but I am very upset. I mean, what's an OS without sound? :(
Please help.
Kernal 3.5.0-17-generic x32, Mint 14 w/ Cinnamon desktop environment.

Level 1
Level 1
Posts: 7
Joined: Tue Jan 15, 2013 9:04 pm

Re: No sound at all in Mint 14 Nadia!

Postby bobr » Tue Jan 15, 2013 9:15 pm

If you get your problem fixed please post I am having the same problem. I had no problem till I downloaded drivers for my nvidia video card after that I started having my problem with sound. I get sound when i login but after that it stops but like you my mic seems to be working just my speakers are not working.

Level 1
Level 1
Posts: 7
Joined: Tue Jan 15, 2013 9:04 pm

Re: No sound at all in Mint 14 Nadia!

Postby bobr » Wed Jan 16, 2013 1:11 pm

I uninstalled mint 14 then got rid of the partition and did a clean install again. Sound worked fine for 2 to 3 hours then sound stoped working again. I cant seem to get it back I saw post about alas being off but mine is on when i play youtube videos but still no sound. would love to find a fix. I am new to linux and so far it has crashed 3 times and sound problems twice. I hear everyone saying how good linux is but cant come on board with that idear, fixes seem to be slow and hard to get answers for but, any help would be appreciated.

Level 1
Level 1
Posts: 11
Joined: Mon Jan 28, 2013 6:25 am

Re: No sound at all in Mint 14 Nadia!

Postby Tit » Tue Jan 29, 2013 4:48 pm

Well, I had sound problems myself, but I'm a complete newbie. Since you said that ANY help would be appreciated I am posting my fixes.

1. Install and activate pulseaudio (from

Warning /!\ This section only applies to old, unsupported versions of Ubuntu. Ubuntu 8.04 and higher installs PulseAudio by default and no extra configuration is needed.

Here's how to install it, as of Dec-08-2007, on Ubuntu Gutsy Gibbon 7.10, with PulseAudio 0.9.6

Installing PulseAudio
Open a Terminal window.
Type the following:
sudo apt-get install libasound2-plugins "pulseaudio-*" paman paprefs pavucontrol pavumeter

ALSA Configuration
Now, type the following:
gksudo gedit /etc/asound.conf
This will open /etc/asound.conf in a Text Editor as the root user.

Normally on Ubuntu 7.10, this file will not exist, so we're creating it.
Paste in the following:

pcm.pulse {
type pulse
ctl.pulse {
type pulse
pcm.!default {
type pulse
ctl.!default {
type pulse

The top two will create new output and input definitions for PulseAudio, and the bottom two will set PulseAudio as the default audio device for programs using the ALSA interface.

2. Tweak pulseaudio (from ... gnu-linux/)
Fix problems with Glitches, voice skips and crackling In file /etc/pulse/ its necessery to substitute the line;

load-module module-udev-detect


load-module module-udev-detect tsched=0

2. Resolve Choppy sound in (Pulseaudio) -> Skype

In /etc/pulse/daemon.conf two lines has to be also substituted:

; default-sample-rate = 44100

Should become;

default-sample-rate = 48000

3. Change /etc/default/pulseaudio to allow dynamic module loading

It is a good idea to the default settings from DISALLOW_MODULE_LOADING=1 to DISALLOW_MODULE_LOADING=0 .This step is not required and I'm not sure if it has some influence on solving sound in / out problems with Skype but I believe it can be helpful in some cases..

So in /etc/default/pulseaudio Substitute:




Restart computer

3. Install missing python libraries(?)
Install these



That pretty much worked for me, see if any of this helps...

Level 1
Level 1
Posts: 1
Joined: Sat Mar 09, 2013 10:41 am

Re: No sound at all in Mint 14 Nadia!

Postby jamathis » Sat Mar 09, 2013 10:43 am

Installing the gnome-alsamixer package fixed it for me.

Code: Select all

sudo apt-get install gnome-alsamixer

User avatar
Level 5
Level 5
Posts: 948
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: No sound at all in Mint 14 Nadia!

Postby anandrkris » Sat Mar 09, 2013 2:02 pm

Hi Guys, - Just to share with you all that I have posted an idea on having a Troubleshooting / Diagnostics wizard in Mint for audio related issues. Request you have a look at idea and provide your views and if it makes sense - cast your vote on it. :) Thanks.

Am rallying the user forums who have sound issues to get consensus on the idea. Let us join our hands together in building a user-friendly Linux Mint. Need your support.
If there is a drive, there will be a path

Level 1
Level 1
Posts: 45
Joined: Wed Feb 27, 2013 8:32 am

Re: No sound at all in Mint 14 Nadia!

Postby jmt95 » Fri Jul 26, 2013 5:00 pm

I'm running same LM 14 Nadia Cinnamon, same problem! Intalled Pulse Audion Control from Software Manager. Problem solved!



Return to “Sound, Multimedia, & Codecs”