Debian stable to LMDE COVERSION

Archived topics about LMDE 1
Forum rules
joemartin
Level 2
Level 2
Posts: 83
Joined: Fri Apr 10, 2009 7:37 am

Debian stable to LMDE COVERSION

Postby joemartin » Wed Jan 16, 2013 9:42 am

Can someone point me in the direction of a current tutorial on how to do this?

Thanks.

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Debian stable to LMDE COVERSION

Postby bigj231 » Wed Jan 16, 2013 11:50 am

I'm pretty sure that LMDE is somewhat based on testing, so it should be similar to converting stable to testing. If you are doing this because you want LMDE, it's honestly easier to just download the ISO and reinstall. Instead of constant updates like testing has, LMDE gets update packs every so often. Stuff will most likely break if you just switch repositories and start updating and installing stuff. Really, you just need to install the codecs and Cinnamon/MATE, and you are already half way to LMDE. The ISO is only about 1GB if I recall correctly.
If you're doing this as an exercise, then I wish you luck.
Running on a 4-slot toaster @ 60Hz

CptMidnight
Level 1
Level 1
Posts: 15
Joined: Tue Apr 24, 2012 11:55 pm

Re: Debian stable to LMDE COVERSION

Postby CptMidnight » Wed Jan 16, 2013 2:48 pm

I tried is as an exercise. Grabbed the netinst image of Debian Sid to ensure package compatibility with Mint's repositories. Installed the image and added the MATE environment + lightdm to login + xorg for basic graphical support. You may have an extra step for proprietary GPU drivers. At that point, you can switch all repos in sources.list from Debian to Mint, then update, upgrade, and reboot.

It still won't be clean, because the Mint devs provide a customized version of MATE that properly dresses up the desktop with a unified look and feel. It's difficult to approximate if you're gluing Debian and LMDE together. And you still need to install apps like a web browser, word processor, maybe a spreadsheet, GIMP, media player, email client, synaptic, etc.

This won't work with standard Debian images, because none of them come with MATE pre-installed. But if you don't care about MATE, then never mind.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 5 guests