virtualbox 4.2 problem on mint 14 XFCE

Questions about applications and software
Forum rules
Before you post please read how to get help
bcm4lm
Level 1
Level 1
Posts: 1
Joined: Wed Jan 16, 2013 5:25 pm

virtualbox 4.2 problem on mint 14 XFCE

Postby bcm4lm » Wed Jan 16, 2013 5:28 pm

I have used Vbox 4.2 for a few months without problem.
But today, I get this error message: (tried reinstallw ithout sucess)
=============================================================
Failed to create the VirtualBox COM object.
The application will now terminate

Start tag expected, '<' not found.
Location: '/home/bcm/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.
/home/vbox/vbox-4.2.6/src/VBox/Main/src-server/VirtualBoxImpl.cpp[525] (nsresult VirtualBox::init()).
Result Code: NS_ERROR_FAILURE (0x80004005)
Component: VirtualBox
Interface: IVirtualBox {3b2f08eb-b810-4715-bee0-bb06b9880ad2}
============================================

thanks in advance !

User avatar
xenopeek
Level 23
Level 23
Posts: 19685
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: virtualbox 4.2 problem on mint 14 XFCE

Postby xenopeek » Wed Jan 16, 2013 6:05 pm

Reinstalling only installs the software anew, but would never touch your personal files. The error is clear, something is wrong with your personal file (it's in your home directory, and the package manager doesn't touch files there): /home/bcm/.VirtualBox/VirtualBox.xml. You may check that folder (press Ctrl+H in your file browser to show hidden folders like this), there will be a VirtualBox.xml-prev file. You could rename the current VirtualBox.xml file to something else, and then rename the VirtualBox.xml-prev file to VirtualBox.xml. This file has a list of all your virtual machines, amongst other settings, so you might have to add one of your virtual machines again if it doesn't show up in the list (if VirtualBox will start again).

If that doesn't work, you could delete the file and VirtualBox will create a new (blank) file for you. You'll have to add all your virtual machines again though.

Before you try any of that, have you tried editing the file and fixing it? I don't have VirtualBox 4.2 but 4.1.18, but here are the first lines of my file. As the error says, it borks on the first line, first column. So it should hopefully be a bit obvious what is wrong. You can edit the file with the text editor.

Code: Select all

<?xml version="1.0"?>
<!--
** DO NOT EDIT THIS FILE.
** If you make changes to this file while any VirtualBox related application
** is running, your changes will be overwritten later, without taking effect.
** Use VBoxManage or the VirtualBox Manager GUI to make changes.
-->
<VirtualBox xmlns="http://www.innotek.de/VirtualBox-settings" version="1.12-linux">
  <Global>
    <ExtraData>
Image


Return to “Software & Applications”

Who is online

Users browsing this forum: inkoalawetrust, Yahoo [Bot] and 12 guests