Unable to connect Linux Mint to Windows Active Directory

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Wed Jan 16, 2013 2:00 pm

Unable to connect Linux Mint to Windows Active Directory

Postby Parasite » Wed Jan 16, 2013 5:40 pm


I was trying to connect my Linux Mint box to our Windows Server 2003 domain. I seem to be running into the same error over and over and I don't know what I am doing wrong. I'm not really a pro, so I am assuming I am typing in something wrong when setting up my network settings. I am using Likewise Open 5 to get on the domain.

At the desktop I go to Control Center>Network. This is the information I have filled on each tab.

Host Name: gps-pc
Domain Name: thorncollc.local

DNS Servers:
Search Domain: <none>

IP Address: Alias: gps-pc.thorncollc.local gps-pc localhost

Every time I try to join the domain using Likewise it gives me the following error.

Lsass Error
Network name not found.. Failure to lookup a domain name ending in ".local" may be the result of configuring the local system's hostname resolution (or equivalent) to use Multi-cast DNS. Please refer to the Likewise manual at http://www.likewise.com/resources/docum ... igNsswitch for more information.

Error code: ERROR_BAD_NET_NAME (0x00000043)


I have a feeling it may have something to do with that last tab on control settings>network>hosts

I'm not quite sure what I need to put in there for the IP and the Alias. If anyone could help me set this up, I would greatly appreciate it. I know it is something super simple with the settings that I am missing.

User avatar
Level 4
Level 4
Posts: 286
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: Unable to connect Linux Mint to Windows Active Directory

Postby dcihon » Wed Jan 16, 2013 5:50 pm

First question I would ask is what are you trying to get from the domain.
I connect to my file servers and shares to get to files.
I connect to my exchange email with Thunderbird.
I use Remmina to remote into my servers.
I don't log into the domain like you would on a windows computer but I get to everything I need.
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing

Level 1
Level 1
Posts: 2
Joined: Wed Jan 16, 2013 2:00 pm

Re: Unable to connect Linux Mint to Windows Active Directory

Postby Parasite » Wed Jan 16, 2013 6:05 pm

Well, this is a computer we have in the copy room and is hooked up to a monitor and displays a website for fleet tracking. I also have a USB plan printer that is hooked up to it and shared so that everyone can print to it. I guess I can probably get around without needing to get on the domain but the windows machine before this one was on the domain, so I figured I should have this replacement box take its' place and be on the domain as well. The tutorials I saw online made it out to be so easy but didn't really give me exact instructions on what to fill in for the different fields.

Level 1
Level 1
Posts: 13
Joined: Mon Nov 26, 2012 6:06 am

Re: Unable to connect Linux Mint to Windows Active Directory

Postby lsc9x » Thu Feb 27, 2014 9:35 pm

OK, so before anyone flames me for posting a potentially damaging fix for this issue I sould preface this by saying that:

1) I am a Linux noob, with a ton of computer experience and\
2) I do NOT know the overall impact of this fix, but it worked perfectly for me so it's worth posting AND I had to really dig and experiment to find the right answer.

Sorry to resurrect this thread, but I found a decent fix to both the bad packet error AND the Llass error (spelling?)

I had to do 3 things:

1) Edit the network connection IPv4 settings in gnome. This is so your machine can see the domain host. Add the IP of your domain host to the DNS server list (IF your server manages both the domain AND DNS) in the additional DNS section. NOTE: If you have multiple NICs in the machine, make sure you are editing the settings for the correct adapter, the interface managing the host/DNS, or this won't work!

1a) Add your domain name to the host setting directly below the additional DNS setting. This may be redundant, but this is how I set it. For example, mydomain.something.local

Doing these two things should enable your machine to see the host on the network and get rid of the "bad packet, could not locate server" error.

2) Edit the /etc/hosts file and just add the IP address of the DNS server at the top of the file, or directly BEFORE the " localhost" line. This will force the system to look to your domain host BEFORE it looks at the the localhost, which will fix the ".localhost" problem. localhost

3) Edit the /etc/nsswitch file and make these two lines read as follows:

hosts: files dns
networks: files

I THINK what this does is drops back the hosts/DNS setting to use a very basic DNS setting for searching for the domain host. The one that comes standard with linux uses something like m4dns blah blah etc. etc. For whatever reason Likewise doesn't like that line!

Reboot the machine and try connecting with Likewise again. It should work.

(Remember to back up your original files in case you need to roll it back!!!!)

Hope this helps,


Return to “Other networking topics”