Minor irritation with Numlock

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
russellz
Level 2
Level 2
Posts: 90
Joined: Sat Nov 24, 2012 7:02 am
Location: Millas, France

Minor irritation with Numlock

Postby russellz » Wed Jan 16, 2013 11:13 am

When I boot my machine the BIOS switches Numlock on however as soon as the login screen appears the Numlock goes off. As I have a French keyboard requiring shift for the numbers I habitually use the number pad. My usual passwords contain numbers and letters so, being a forgetfull old fart, I have to try two or three times to login.

Is there any way to set numlock for the login screen? I have added "numlockx on" to the startup programs but that doesn't get actioned until login.

Russell.
Laptop: Toshiba Satellite C870 13V . Mint Cinnamon 17.1
Desktop: Gigabyte GA-MA770T-UD3 motherboard, NVIDIA GeForce 210, AMD Phenom II Quad Core Processor 3GHz, 4GB ram, 120GB SSD, 500GB HDD. Mint Cinnamon 17.3

RavenLX
Level 2
Level 2
Posts: 74
Joined: Tue Jan 15, 2013 4:00 am

Re: Minor irritation with Numlock

Postby RavenLX » Thu Jan 17, 2013 12:32 am

I'm using KDE so I went into Applications - Settings - System Settings and then in the Hardware section, go to Input Devices. On the left, select Keyboard. In the Hardware tab you'll see some options for NumLock on KDE Startup. Be sure to click in "Turn on". Click Apply, Exit the dialog and reboot. You should now get the NumLock on by default. There's also an option to Turn Off for those who rather have the NumLock off as default.

User avatar
russellz
Level 2
Level 2
Posts: 90
Joined: Sat Nov 24, 2012 7:02 am
Location: Millas, France

Re: Minor irritation with Numlock

Postby russellz » Thu Jan 17, 2013 6:20 am

RavenLX wrote:I'm using KDE so I went into Applications - Settings - System Settings and then in the Hardware section, go to Input Devices. On the left, select Keyboard. In the Hardware tab you'll see some options for NumLock on KDE Startup. Be sure to click in "Turn on". Click Apply, Exit the dialog and reboot. You should now get the NumLock on by default. There's also an option to Turn Off for those who rather have the NumLock off as default.
Thanks for the suggestion.

Sorry, forgot to mention I'm using Linux Mint Mate rather than KDE. There doesn't seem to be that setting in Mate - or at least I can't find it.

Russell.
Laptop: Toshiba Satellite C870 13V . Mint Cinnamon 17.1
Desktop: Gigabyte GA-MA770T-UD3 motherboard, NVIDIA GeForce 210, AMD Phenom II Quad Core Processor 3GHz, 4GB ram, 120GB SSD, 500GB HDD. Mint Cinnamon 17.3

User avatar
russellz
Level 2
Level 2
Posts: 90
Joined: Sat Nov 24, 2012 7:02 am
Location: Millas, France

Re: Minor irritation with Numlock

Postby russellz » Thu Jan 17, 2013 7:09 am

Tried a few things;

1. I put "setleds -D +num" at the end of the rc.local file. That turned the numlock LED on but not the keyboard action.

2. I tried numlockx on in the rc.local file - no effect. I gues it only works after X has started?

Any other suggestions?

Russell
Laptop: Toshiba Satellite C870 13V . Mint Cinnamon 17.1
Desktop: Gigabyte GA-MA770T-UD3 motherboard, NVIDIA GeForce 210, AMD Phenom II Quad Core Processor 3GHz, 4GB ram, 120GB SSD, 500GB HDD. Mint Cinnamon 17.3

RavenLX
Level 2
Level 2
Posts: 74
Joined: Tue Jan 15, 2013 4:00 am

Re: Minor irritation with Numlock

Postby RavenLX » Thu Jan 17, 2013 2:06 pm

rc.local is for the terminal bootup. I would try looking for the mate login screen configuration either in the GUI or the file that it looks at when it runs. I think that is where it is either getting turned off or not present. Might want to try looking for a file: ~/.config/mate and see if it's in there somewhere.

Also your command is not turning on any numlock, just the LEDs. You need a command to turn the numlock feature on itself.

Here's another idea to try: http://forum.linuxmint.com/viewtopic.ph ... 8&start=20

User avatar
DrHu
Level 17
Level 17
Posts: 7563
Joined: Wed Jun 17, 2009 8:20 pm

Re: Minor irritation with Numlock

Postby DrHu » Thu Jan 17, 2013 5:59 pm

http://it.toolbox.com/blogs/locutus/wha ... inux-35692
    System -> Preferences -> Keyboard -> Layout -> Layout Options -> Miscellaneous compatibility options -> turn on "Default numeric keypad keys"
Does that work, from the complaint/blog link above

It is likely from the desktop/OS viewpoint to be related to some keyboard device selection setting

User avatar
thomZz
Level 1
Level 1
Posts: 4
Joined: Wed Jan 16, 2013 8:33 pm

Re: Minor irritation with Numlock

Postby thomZz » Thu Jan 17, 2013 6:58 pm

DrHu wrote:http://it.toolbox.com/blogs/locutus/what-is-it-with-numlock-and-linux-35692
    System -> Preferences -> Keyboard -> Layout -> Layout Options -> Miscellaneous compatibility options -> turn on "Default numeric keypad keys"
Does that work, from the complaint/blog link above

It is likely from the desktop/OS viewpoint to be related to some keyboard device selection setting


It works for me !

Thanks, that's what i was looking for.

User avatar
russellz
Level 2
Level 2
Posts: 90
Joined: Sat Nov 24, 2012 7:02 am
Location: Millas, France

Re: Minor irritation with Numlock

Postby russellz » Fri Jan 18, 2013 9:11 am

DrHu wrote:http://it.toolbox.com/blogs/locutus/what-is-it-with-numlock-and-linux-35692
    System -> Preferences -> Keyboard -> Layout -> Layout Options -> Miscellaneous compatibility options -> turn on "Default numeric keypad keys"
Does that work, from the complaint/blog link above

It is likely from the desktop/OS viewpoint to be related to some keyboard device selection setting

That's an interesting blog. Unfortunately the solution doesn't work for me.

Russell.
Laptop: Toshiba Satellite C870 13V . Mint Cinnamon 17.1
Desktop: Gigabyte GA-MA770T-UD3 motherboard, NVIDIA GeForce 210, AMD Phenom II Quad Core Processor 3GHz, 4GB ram, 120GB SSD, 500GB HDD. Mint Cinnamon 17.3

RavenLX
Level 2
Level 2
Posts: 74
Joined: Tue Jan 15, 2013 4:00 am

Re: Minor irritation with Numlock

Postby RavenLX » Fri Jan 18, 2013 11:58 am

I think what would be nice is a tutorial on how to turn on the numlock in each of the DEs.

User avatar
russellz
Level 2
Level 2
Posts: 90
Joined: Sat Nov 24, 2012 7:02 am
Location: Millas, France

Re: Minor irritation with Numlock

Postby russellz » Sat Jan 19, 2013 6:34 am

The problem with setleds (btw with -D it sets the flags as well as the leds) is that it only seems to work from a Console and only works for that console. It doesn't work from a Terminal.

I thought it might be the Login theme so I tried a different one but no change.

The numlock light is on when BIOS does it's thing but goes off as Linux Mint starts to load so there must be something in one of the startup scripts but I can't find it :(

Russell.
Laptop: Toshiba Satellite C870 13V . Mint Cinnamon 17.1
Desktop: Gigabyte GA-MA770T-UD3 motherboard, NVIDIA GeForce 210, AMD Phenom II Quad Core Processor 3GHz, 4GB ram, 120GB SSD, 500GB HDD. Mint Cinnamon 17.3


Return to “Newbie Questions”

Who is online

Users browsing this forum: Baidu [Spider], morcar, Punchy71 and 37 guests