Problem setting up Wacom intuos4 in Mint 14 [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
destro777
Level 1
Level 1
Posts: 7
Joined: Sun Dec 30, 2012 4:44 pm

Problem setting up Wacom intuos4 in Mint 14 [SOLVED]

Postby destro777 » Sat Jan 19, 2013 6:36 pm

I am trying to set up my tablet so I don't have to re-enter my settings using xsetwacom every time I restart my Laptop.
I have copied the 50-wacom.conf to /ect/X11/xorg.conf.d and renamed the file to "52-wacom.conf". I then edited it to add some Options.
Section "InputClass"
Identifier "Wacom class"
MatchProduct "Wacom|WACOM|Hanwang|PTK-540WL|ISD-V4"
MatchDevicePath "/dev/input/event*"
Driver "wacom"
Option "cursor" "rotate"
#Option
As you can see I have added Option "cursor" "rotate" (I entered this because I am left handed) after reboot with the tablet plugged into the laptop via usb nothing has changed and its as if its not reading the Options, I have tried other things such as setting it to Option "cursor" "rotate" "half" but then when I reboot X doesn't start and throws this at me "(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 19 16:50:10 2013
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Parse error on line 6 of section InputClass in file /etc/X11/xorg.conf.d/52-wacom.conf
"half" is not a valid keyword in this section."
Its telling me half isn't a "valid keyword" when it obviously is because that's the keyword that man wacom specifies and it also works if I enter it into xsetwacom.
Does anyone have a fix for this or know what i'm doing wrong?
Last edited by destro777 on Mon Jan 21, 2013 5:11 pm, edited 1 time in total.

Favux
Level 3
Level 3
Posts: 199
Joined: Fri Jul 01, 2011 1:20 am

Re: Problem setting up Wacom intuos4 in Mint 14

Postby Favux » Sat Jan 19, 2013 6:56 pm

Hi destro777,

The parameter you want to use is Rotate and the value is half. As in:

Code: Select all

Option "Rotate" "half"

By the way the cursor is linux wacom speak for the Wacom tablet mouse or puck.

destro777
Level 1
Level 1
Posts: 7
Joined: Sun Dec 30, 2012 4:44 pm

Re: Problem setting up Wacom intuos4 in Mint 14

Postby destro777 » Sat Jan 19, 2013 8:07 pm

Hey thanks for the fast reply, I have tried the code you posted and while it doesn't cause any errors it also does not affect anything. I tried it again just to double check and it still does not "rotate" the device. Have any other suggestions?

Favux
Level 3
Level 3
Posts: 199
Joined: Fri Jul 01, 2011 1:20 am

Re: Problem setting up Wacom intuos4 in Mint 14

Postby Favux » Sat Jan 19, 2013 8:40 pm

Hmm. I don't think the Wacom configuration applet is in System Settings. But the Wacom plug-in might be active in the gnome-settings-daemon and that could be set to normal rotation and blocking the .conf file. So try it as a xsetwacom command.

Code: Select all

xsetwacom set "device name" Rotate half

Where <device name> is the name of the stylus you see in the xinput list output. "Wacom Bamboo Pen stylus" or whatever.

destro777
Level 1
Level 1
Posts: 7
Joined: Sun Dec 30, 2012 4:44 pm

Re: Problem setting up Wacom intuos4 in Mint 14

Postby destro777 » Sun Jan 20, 2013 12:30 am

Favux wrote:Hmm. I don't think the Wacom configuration applet is in System Settings. But the Wacom plug-in might be active in the gnome-settings-daemon and that could be set to normal rotation and blocking the .conf file. So try it as a xsetwacom command.

Code: Select all

xsetwacom set "device name" Rotate half

Where <device name> is the name of the stylus you see in the xinput list output. "Wacom Bamboo Pen stylus" or whatever.


The xsetwacom command works perfectly as it should.

Code: Select all

xsetwacom set "Wacom Intuos4 6x9 pad" rotate half
makes my stylus and mouse rotate half way so I can use them, this is more of a convenience issue though as I was simply wondering if there is a way to make it so I don't have to input these settings each time I restart.

Favux
Level 3
Level 3
Posts: 199
Joined: Fri Jul 01, 2011 1:20 am

Re: Problem setting up Wacom intuos4 in Mint 14

Postby Favux » Sun Jan 20, 2013 12:55 am

Sure you just set up a xsetwacom script to autostart. I show how to do that on the BambooPT HOW TO in part IV.: viewtopic.php?f=42&t=110408 There is a sample/example xsetwacom script attached to post #2.

You can also check out my immortal prose on the MediaWiki: http://sourceforge.net/apps/mediawiki/l ... figuration :) Which is from the HOWTO page: http://sourceforge.net/apps/mediawiki/l ... gory:HOWTO

Plus you should be able to use the Gnome Wacom tablet applet. We figured out the Mint dev.s are hiding it for some reason but it is easy to get it back: viewtopic.php?f=208&t=117690

destro777
Level 1
Level 1
Posts: 7
Joined: Sun Dec 30, 2012 4:44 pm

Re: Problem setting up Wacom intuos4 in Mint 14

Postby destro777 » Mon Jan 21, 2013 5:11 pm

Thank you so much Favux your test script worked after I added the rotate option!


Return to “Hardware Support”

Who is online

Users browsing this forum: Seffis and 3 guests