Video Screen Capture problems - Kazam

Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 5
Joined: Sun Jan 20, 2013 12:57 pm

Video Screen Capture problems - Kazam

Post by pjdyns01 » Sun Jan 20, 2013 1:13 pm

I've been trying to install Kazam Screencaster into Mint13 KDE. Software Manager said it was installed but when I ran it failed to execute. I tried running from a terminal with a similar result, but with this message:
ERROR:root:Could not find any typelib for Gtk
Traceback (most recent call last):
File "/usr/bin/kazam", line 29, in <module>
from gi.repository import Gtk
I then removed the package via Software Manager and tried to install using the terminal and the kazam stable repository, copying and pasting commands found here ... ation.html but this seemed to install the same version with the same result and (when tried in the terminal) the same error message.

I have other gtk programs working fine, e.g. Grsynch, so am at a loss - and out of my depth - with this one.

Any ideas appreciated as the program seems generally to attract favourable reviews and I have a current need for it or something similar.

Level 1
Level 1
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: Video Screen Capture problems - Kazam

Post by grepnix » Sun Jan 20, 2013 8:54 pm

I managed to get it running by installing gir1.2-wnck-3.0 and its dependencies but it seems a bit flaky.

1) Could only get VP8/WebM working (Countdown doesnt work. Click little red dot in panel to stop)

2) Clicking 'record region' did nothing and neither did encoding as h264/mp4

Trying to encode as h264/mp4 I had to kill the process to get out of it... I installed h264enc which brought in a lot of dependencies but it didnt help. I was able to encode as webM and record my desktop in fullscreen.

There must be some other missing dependencies that I'm missing to be fully functional.


Post Reply

Return to “KDE”