Auto mount a partition not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Sat Jan 26, 2013 8:45 am

Auto mount a partition not working

Postby LloydAtkinson » Sat Jan 26, 2013 9:33 am


I have Windows and Linux Mint 14 installed on my machine. Because I will eventually have at least a couple more distros on my machine, I have created a 200 GB partition (That I wish to mount at /mnt/data that I will use to store my files (eg, photos, text files, etc). I did not create a seperate /home partition as I did not want problems to arise from different versions of programs in each distro changing the same settings files and messing things up.

I do not wish to have it mounted at /media/lloyd/data because I am not always the only user logged into my machine (sometimes I log into my machine via SSH under a different acount, for example), and from what I understand, once it is mounted at /media/lloyd, then another user would not be able to use it (unless it was unmounted and then mounted somewhere else)?

Initially it was mounting correctly but I did not have any permissions to it and could not create files, after changing the fstab to include "rw" or "users" (I can't remember which) Mint now says that it had problems mounting the partition while it is booting and I have to press S to skip mounting it.

Here is my fstab:

Code: Select all

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=cf937006-580f-4606-8fd9-8d93f6df3d5e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=3d45841a-0fc7-439e-b81c-5e4143987bc8 none            swap    sw              0       0
/dev/sda6 /mnt/data ext4 rw,defaults,users,noatime,x-gvfs-show 0 2

Level 18
Level 18
Posts: 8835
Joined: Tue Feb 03, 2009 10:27 am

Re: Auto mount a partition not working

Postby altair4 » Sat Jan 26, 2013 9:58 am

[1] Unmount the partition if you have mounted it manually.

[2] Change the line from this:
/dev/sda6 /mnt/data ext4 rw,defaults,users,noatime,x-gvfs-show 0 2

to this:
/dev/sda6 /mnt/data ext4 defaults,noatime 0 2

[3] Remount using this command which will also test for any syntax errors:

Code: Select all

sudo mount -a

[4] You will need to decide who you want to grant access to this partition.

*** If it's only you:

Code: Select all

sudo chown your-user-name /mnt/data

*** If it's a group of users - and let's say the group is plugdev ( you will need to add your users to the plugdev group ):

Code: Select all

sudo chown :plugdev /mnt/data

Code: Select all

sudo chmod 0770 /mnt/data

*** If it's all users:

Code: Select all

sudo chmod 0777 /mnt/data

Or, a hundred different variations of the above.

[5] Finally, never use the "Disk" utility again for the rest of your life :)
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Return to “Hardware Support”