icedtea - installing latest version

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 3
Level 3
Posts: 192
Joined: Thu Dec 15, 2011 11:53 pm

icedtea - installing latest version

Postby jamvaru » Thu Jan 17, 2013 6:26 pm

ok, so this is kind of a shout for help and partly a sort of how-to or how i did it (im actually in the middle of doing it, lol; it has become an adventure, so i thought i would put it down for posterity)

i needed to update icedtea for my online classes and firefox decided to be a bear and practically hung up on me, so i tried chromium, and it passed all the browser checks except for java... ah, there is an update java link...

so, eventually i found the icedtea page and decided, after not getting the other versions to work, to do the 2.3.4 version, updated 1/15/13 or 15 jan 13

ok, i downloaded, opened in archive manager, dragged to folder, opened in terminal, and you type:


it then goes through a VERY long list of stuff, then it hits an error; I am a bit on through the process, but basically, whatever error you find you then open SYNAPTIC and install whatever it says is missing; type it in the search box, then find it in the list, right click, or double click, and select install, or mark for installation... then click apply and so on
. for a couple of things, one being nss, i sorted by 'new' i think, the gold sort of star or sunburst, the 2nd column, then select all witht he sunburst, right click, mark for install, apply and so on.
... then you go back to your terminal, hit up arrow, which gives you ./configure, and hit enter... it should make it past your previous stopping point; at this point, i am at 'rhino', which i have just installed with synaptic, so... i am re-configuring...
:: now i have an error for jpeg:

configure: error: Could not find JPEG library; install JPEG or build with --disable-system-jpeg to use the in-tree copy.

so, lemme try to fix this and i will continue if/when i get it working... (i found libjpeg and gem, decided to install it all, wth)
now libpng ... trying libpng-12 dev... it is getting longer to ./configure, so i would almost rather just install everything *png, but...
ok, now libgif ... it looks like installing the dev packages for each lib works... libgif is already installed, but not libgif dev
yep, now LCMS2 ... well, that is not in synaptic, and i am tired of this, so it says i can do this, er... ok:: --disable-system-lcms to use the in-tree copy.
i presume they mean ./configure --disable-system-lcms to use the in-tree copy.
let's see
ah, it freaked out... maybe i can install lcms2 in terminal; lol, whew... this worked: sudo apt-get install liblcms2-dev
ok, ./configure again ; it seems to have several problems, yesses when there should be no's and vice-versa, but it trundles on, till
gtk+ ... ok... here we go again... im guessing this one: libswt-gtk-3-java ... using synaptic; i think i'll do this one too: libjavascriptcoregtk-3.0-dev
nope... ok, going bonkers, installing everything gtk, or mostly everything... wth (i typed gtk in the search box and selected everything that starts with gtk, it went fairly nuts)
ok, im gonna go make some tea while this thing runs, lol (./configure again)
wow, still no gtk+ support ... im going to try to install everything in the stupid list... probably break the system, lol
maybe not, taking a long time just to mark everything... ok, mabye ubuntu has a simple install for icedtea
yeah, synaptic craashed, i am going to have to try something else, i guess

what do you think? is there a way to install icedtea (latest) without all this mess?


Level 3
Level 3
Posts: 192
Joined: Thu Dec 15, 2011 11:53 pm

Re: icedtea - installing latest version

Postby jamvaru » Thu Jan 17, 2013 7:05 pm

well, this worked


at any rate, i'm definitely going to be deleting this installation; im not really happy with lm 14, but i'm game to trying out the new cinnamon iso and the ide iso and goofing around with it...

there is only so much you can take before you get pissed

lol, i'm more tired of the 'vibe' than anything else... hey, it is ok... maybe i will really like cinnamon... meh

i guess i can keep this install for now, since i got chrome working for my school, so; a plus

alrighty then, on to the next thing

hey, man... don't settle for 'if it ain't broken don't fix it' ... keep on making it better

i have had some odd issues with this install (LM 14 MATE) so it is not just this one thing that is breaking it for me

but, ultimately, there is a sort of 'so-what' attitude about everything, imo

i am turned off

but i will be back to check you guys out... turns out I am definitely NOT one of you, though

happy '13

User avatar
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: icedtea - installing latest version

Postby mockturtl » Thu Jan 17, 2013 8:09 pm

You'd want icedtea-7-plugin, but Debian and Ubuntu have not deployed a security update for the exploit announced earlier this week. You've got a real problem if your coursework requires the Java plugin.

(edit: if the webupd8team oracle-java ppa works for you, great)

you type:


it then goes through a VERY long list of stuff, then it hits an error
The whole infrastructure of a distribution exists to facilitate this -- as against grabbing raw source and battling the compiler, like you're doing.

If you need to build it yourself, try:

Code: Select all

apt source icedtea-7-plugin
apt build-dep !$

Level 3
Level 3
Posts: 192
Joined: Thu Dec 15, 2011 11:53 pm

Re: icedtea - installing latest version

Postby jamvaru » Sun Jan 27, 2013 11:53 am

fascinating, lol; i am skeptical that it is so easy as you describe, but...

the proprietary java worked, for now; however, i got pissed at chrome for being chrome (google) so I removed it

relying on sunjava for now in firefox, seems to be working ok

i need to read a book, lol

Return to “Software & Applications”