Installing gMate ?

Forum rules
Before you post please read how to get help
ndyakov
Level 1
Level 1
Posts: 2
Joined: Mon Jan 28, 2013 7:40 pm

Installing gMate ?

Postby ndyakov » Mon Jan 28, 2013 7:58 pm

Hello guys,
Firstly I want to apologize for my bad English.
Secondly i need a help with gedit-gmate.
My situation is simple... I have compiled and instaled gedit 3.2.6 :

Code: Select all

ndyakov@moon ~/Desktop $ gedit --version
gedit - Version 3.2.6

But when I run

Code: Select all

ndyakov@moon ~/Desktop $ sudo apt-get install gedit-gmate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gedit-gmate : Depends: gedit (>= 3) but 2.30.4-2ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.


Any suggestions ? What should I do ?
Oh yes, by the way I'm currently running

Code: Select all

ndyakov@moon ~/Desktop $ lsb_release -a
No LSB modules are available.
Distributor ID:   LinuxMint
Description:   Linux Mint 14 Nadia
Release:   14
Codename:   nadia

with XFCE on top.... So please help me, you are my last resort.




Edit:
By the way, gedit-plugins from the repo doesn't work either:

Code: Select all

ndyakov@moon ~/Desktop $ sudo apt-get install gedit-plugins
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  gedit

They want to install gedit from the repo... i'm badly surprised ....
Last edited by ndyakov on Mon Jan 28, 2013 8:11 pm, edited 1 time in total.

zerozero
Level 16
Level 16
Posts: 6517
Joined: Tue Jul 07, 2009 2:29 pm

Re: Installing gMate ?

Postby zerozero » Mon Jan 28, 2013 8:03 pm

Image

[ bliss of ignorance ]

ndyakov
Level 1
Level 1
Posts: 2
Joined: Mon Jan 28, 2013 7:40 pm

Re: Installing gMate ?

Postby ndyakov » Tue Jan 29, 2013 5:15 am

Thank you, I was able to install

Code: Select all

ndyakov@moon ~ $ /usr/bin/gedit --version
gedit - Version 3.6.1


But there is another error now. When i try to open a file, from the gui or from the command line, i get "GLib-GIO-ERROR" :

Code: Select all

ndyakov@moon ~ $ /usr/bin/gedit ~/Desktop/test.pl

(gedit:6141): GLib-GIO-ERROR **: Settings schema 'org.gnome.gedit.preferences.editor' does not contain a key named 'ensure-trailing-newline'
Trace/breakpoint trap


Any ideas how can i fix this ? I have tried to disable all plugins, but the error stays the same.


Return to “XFCE”

Who is online

Users browsing this forum: No registered users and 0 guests