Persistent ext4 Journal corruption on fresh install Mint14

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Tue Jan 29, 2013 5:55 am

Persistent ext4 Journal corruption on fresh install Mint14

Postby Dtohjam » Tue Jan 29, 2013 6:31 am

I have installed a number of versions of Mint (14 Mate 32 bit, 13 KDE, and 14 Mate 64bit) and have consistent ext4 fs corruption following the initial powerdown and reboot from a fresh install.

This initially shows has being unable to access /var, /usr or /bin. Checking "cat /proc/mounts" shows the root mount / has been set to read only "ro". Sometimes I get a kernel panic. Powering down and checking with a recovery disk, using fsck shows that the "recovery journal contains a file with errors... "

I've check and double checked and done the following;
    Down loaded the Mint14 Mate 64bit version direct from the Linux-Mint website, checking the MD5Sum hash on download and following burning to a DVD.
    The system is (and has been for ages) a dual boot to Win7, so the first 3 Fat and NTFS partitions remain untouched.
    With gpared, deleted and realigned the 4 extended partion. Reestablished the virtual partitions sda5, sda6 for / (35GB) (one for mint and one for ubuntu) and 1000 GB for /home and 8GB for swap. All have about 1MB free space between.
    Created ext4 fs and surface checked for bad blocks with the fsck -cc option.
    And have tried installing Mint14Mate 64Bit in sda6 and sda5 with same results.

Googling - the symptoms seem similar to the kernel bug reported about Oct 24, 2012 where the journal system in ext4 and maybe in ext3 would not unload (clean) when there were USB drives or loop fs mounted and in use. I assume this has got to be addressed and patches rolled through...

Any guidance much appreciated!. Thanks.

Dtohjam, Perth Aust.

User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Re: Persistent ext4 Journal corruption on fresh install Mint

Postby viking777 » Tue Jan 29, 2013 9:09 am

Do you think this is the same error:
If you think it is then add your experience to that topic and we will close this one down, if you don't think it's the same I'll leave this topic open.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

Return to “Installation & Boot”

Who is online

Users browsing this forum: No registered users and 5 guests