Symlink to an NTFS volume in triple boot system

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 19
Joined: Sun May 02, 2010 8:24 pm

Symlink to an NTFS volume in triple boot system

Postby markosjal » Wed Jan 30, 2013 10:39 pm

I have finaly set up my dream multi Boot Win7/OSX/Mint system with one exception. The mint part which I thought would be the easiest is turning out problmatic.

You see I have 5 partitions as follows
Mint ext4
Files NTFS (for commn documents folders from all OSs)
Linux Swap

In windows I can define locations for user documents, and set to Files

In Mac OSX I can mount NTFS with read/write and FUSE then made a symlink to Files

In Mint however I made a symlink much like OSX, and at boot Mint complains because other users have write privlidges to the "user" directory apparently as defind by the symlink. I can not even seem to change the permissions on the symlink. I was finally able to recreate it in the userspace without "sudo" so the owner shows correctly. When I previously tried to chown it woud not work. I also tried to chmod 755 on the symlink and can not change the permissions. Is there somthing I am missing ir a better way to define the user file locatons?

Level 18
Level 18
Posts: 8831
Joined: Tue Feb 03, 2009 10:27 am

Re: Symlink to an NTFS volume in triple boot system

Postby altair4 » Thu Jan 31, 2013 7:30 am

You can't chmod a symlink. And you can't chmod an NTFS filesystem.

It's not clear what you are trying to do but if you want to mount an ntfs partition and "link" it to say your home directory then mount it that way in /etc/fstab. Something like this:

Code: Select all

UUID=DA9056C19056A3B3 /home/altair/CommonData ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0

Run the following command to get the correct UUID number:

Code: Select all

sudo blkid -c /dev/null

And make the new mount point:

Code: Select all

mkdir /home/altair/CommonData
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Return to “Other topics”