gparted not finding external hard drive

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 3
Level 3
Posts: 110
Joined: Wed Jun 22, 2011 7:11 pm

gparted not finding external hard drive

Postby jonass » Fri Jan 25, 2013 4:35 pm

So I have an external hard drive I made from and old broken laptop. It worked when I put it together a few months ago, however today I plugged it in and mint never found it, so I opened gparted and it also never found it. I can feel that the drive is on and running when plugged in. One other thing, if I plug it into the front port of my comp, which sometimes seems to revert to usb 1 rather than the 2.0 they should be, it starts up but makes a clicking sound as it is spinning. I read that can be an issue of not getting enough power. If I plug it into the back port it does not do this. Still whichever port I try it still doesn't get found. How can I tell if this drive is broken for sure?

Level 6
Level 6
Posts: 1498
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: gparted not finding external hard drive

Postby Orbmiser » Fri Jan 25, 2013 5:28 pm

Clicking sound is not good and an indicator that drive maybe going bad.
Would boot up to another windows machine to verify indeed it's a problem.

And yes some older desktops have underpowered front usb ports and can be resolve usb device issues plugging into back ports.

One trick I use to use when I did Hardrive data recovery for customers on a failing drive is to put in freezer for an hour.
Pull out and hooked up to computer and then had anywhere from 15-45 mins to recover data before the drive warmed up and started to fail again. Not 100% but if works then fails will verify bad drive. Just google freezing hardrive to see the successful results from others that have used the technique.

Level 3
Level 3
Posts: 159
Joined: Tue Jan 08, 2013 11:35 am

Re: gparted not finding external hard drive

Postby srq2625 » Thu Jan 31, 2013 8:47 am

Clicking sound .... I've heard that as well.

I have a old WD Passport drive that used to work on my desktop. In hind-sight, I realize it stopped being recognized when I upgraded the MBO. From that time on - worked only on occassion. So, I bought a new external HDD.

In the last couple of days, I read somewhere that this sort of thing can be caused by not enough power on the USB port, thus not enough to properly drive the HDD.

So, I pulled out an old USB 2.0 powered hub, plugged that into the same port on my MBO, plugged the WD into the hub and ..... magic! It works again!

I have to wonder if the power on the MBO ports is, maybe by design, just enough for things like thumb drives, but not enough for "real" drives?

Return to “Hardware Support”