USB Drive automounts after login

Forum rules
Before you post please read how to get help
gmakka
Level 1
Level 1
Posts: 5
Joined: Thu Jan 31, 2013 6:17 am

USB Drive automounts after login

Postby gmakka » Thu Jan 31, 2013 6:23 am

Hi Guys,

Installed linux mint 14 with mate the other day. Every time that i login, the connected USB drives automatically mount and a file browser pops up.

Whilist this is convient sometimes, 99% of the time, it's REALLY annoying :) Oh, and then when i logout and back in again, it then tells me that it can't mount the drive, because it's previously mounted else where

Is there a way to turn this off?

Thanks
Grant

User avatar
jungle_boy
Level 7
Level 7
Posts: 1662
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest Land

Re: USB Drive automounts after login

Postby jungle_boy » Thu Jan 31, 2013 6:16 pm

Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot
LM17.1 Cinnamon (PC) and 17.3 Cinnamon (Laptop) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)

Trapper
Level 4
Level 4
Posts: 305
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: USB Drive automounts after login

Postby Trapper » Sun Feb 03, 2013 9:05 am

jungle_boy wrote:Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot


I think the OP may be more interested in preventing the auto mount of USB connected drives at login rather than the prevention of the file browser opening when the drive's mounted.
MSI 880GME35-455 MB, Athlon AM3-A2-455R 3x CPU, 4GB DDR3 RAM, WD 320 GB SATA3 HD
Single FDE container holding LMDE 2, LM 17.2, LM 18, swap and shared data LV's.

User avatar
jungle_boy
Level 7
Level 7
Posts: 1662
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest Land

Re: USB Drive automounts after login

Postby jungle_boy » Sun Feb 03, 2013 11:15 am

Trapper wrote:I think the OP may be more interested in preventing the auto mount of USB connected drives at login rather than the prevention of the file browser opening when the drive's mounted.


I tested and it works fine...
LM17.1 Cinnamon (PC) and 17.3 Cinnamon (Laptop) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)

mikkelbreiler
Level 1
Level 1
Posts: 1
Joined: Thu Mar 28, 2013 1:30 pm

Re: USB Drive automounts after login

Postby mikkelbreiler » Thu Mar 28, 2013 1:48 pm

jungle_boy wrote:Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot


I want to turn this feature off too My USB hard drive tower is reactivated from power off rather often, without anything doe by me and every time this happens a window appears on top of what I am oing so I can click it away.

I have Linux Mint Cinnamon installed and if I select "Menu", at the bottom left I do not see anything labelled "Control Center". Where do I find "Control Center", "File Mangement" and the "Media" tab ?

-Mikkel

User avatar
DrHu
Level 17
Level 17
Posts: 7563
Joined: Wed Jun 17, 2009 8:20 pm

Re: USB Drive automounts after login

Postby DrHu » Thu Mar 28, 2013 2:29 pm

Apart that it (a line entry ref: usb device) may be in /etc/fstab, the static mounts for devices: the usual location for inserted media is /media, hence you are allowed to alter its operation per device in that location
The media TAB mentioned, or you can use a file manager, whichever one you have, Cairo, nautilus, thunar (should be in menu(s) or as an ICON on your desktop)), and then a right-click-->properties will get data you can manage/change..
http://www.linuxlinks.com/article/20081 ... agers.html
http://www.maketecheasier.com/linux-fil ... 2010/04/29


Return to “MATE”

Who is online

Users browsing this forum: No registered users and 2 guests