Libreoffice - Thesaurus problems... Solved for GB language

Write tutorials here
There are more tutorials here
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Level 1
Level 1
Posts: 16
Joined: Wed Sep 29, 2010 1:44 pm

Libreoffice - Thesaurus problems... Solved for GB language

Postby daozen » Fri Feb 01, 2013 7:40 am

I know what you're thinking - "Not another one of these threads".

Well I have read all the threads on here about the thesaurus issues, I know you need to install the following packages:


because they aren't installed with Libreoffice.

However once installed this did not do anything for me, still no thesaurus. I tried a lot of the fixes on the internet to no avail. I think my problem was my environmental settings which are British. For some reason Libreoffice wouldn't use the US thesaurus (apparently GB and US are subsumed into the same package). And as you know British isn't an English option for Libreoffice, despite English being from Britain... :?

Anyway the solution I found is this:

Open up a terminal and type and go to mythes directory:

Code: Select all

cd /usr/share/mythes

Create symbolic links to the US thesaurus:

Code: Select all

sudo ln -s th_en_US_v2.dat th_en_GB_v2.dat && sudo ln -s th_en_US_v2.idx th_en_GB_v2.idx

Now it works. This isn't my solution I found it on the web HERE.

Obviously if you want an actual British thesaurus and not one that just points to the US thesaurus then this may be an option for you: though the package hasn't been updated in a while.

Its not perfect buts its better than what I had.

Hope this helps some people.


User avatar
Level 5
Level 5
Posts: 976
Joined: Tue Dec 28, 2010 10:37 am

Re: Libreoffice - Thesaurus problems... Solved for GB langua

Postby usbtux » Sat Feb 02, 2013 8:54 am

Nice easy fix, thank you. :D

Code: Select all

sudo apt install mythes-en-us
to install the required.
Then right click under synonyms.

Another possible answer that seems to be still current LinuxMint tutorials.
Running LinuxMint 17.3 Mate. Pepermint 6 & Manjaro 15.12 Capella XFCE Installing Mint - the screen cast videos.
linuxcounter #368850

Return to “Tutorials”