Please help...can't access wifi on Gateway NV77H20u

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sat Feb 02, 2013 3:23 am

Please help...can't access wifi on Gateway NV77H20u

Postby justiceanthony » Sat Feb 02, 2013 3:42 am

Hello everyone, Im very new to linux. I installed it on my Gateway NV77H20u laptop as the sole operating system (fully migrating from windows). My laptop is a core i5 4gig ram laptop and i installed the 64bit version of linux mint 14. It's quite smooth and I'm really enjoying it. My only problem, however, is the fact that i can't connect my wifi or any wireless network unless through a cable. I've tried reading some threads on the linux forum...but i'm always lost because I don't understand anything (about terminals and so'm really new to linux and I really need help. Pls help me as to what to do. I want to make linux mint my permanent OS.

this is the result after running this comand: sudo /usr/lib/linuxmint/mintWifi/

justice@justice-NV77H ~ $ sudo /usr/lib/linuxmint/mintWifi/
[sudo] password for justice:
* I. scanning WIFI PCI devices...
-- Broadcom Corporation BCM43227 802.11b/g/n
==> PCI ID = 14e4:4358
* II. querying ndiswrapper...
* III. querying iwconfig...
eth0 no wireless extensions.

lo no wireless extensions.

* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr dc:0e:a1:0c:0f:9e
inet addr: Bcast: Mask:
inet6 addr: fe80::de0e:a1ff:fe0c:f9e/64 Scope:Link
RX packets:5368 errors:0 dropped:0 overruns:0 frame:0
TX packets:4811 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:2246239 (2.2 MB) TX bytes:803182 (803.1 KB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:904 errors:0 dropped:0 overruns:0 frame:0
TX packets:904 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:158456 (158.4 KB) TX bytes:158456 (158.4 KB)

* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
* VI. querying nslookup

Non-authoritative answer:

justice@justice-NV77H ~ $

User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Re: Please help...can't access wifi on Gateway NV77H20u

Postby viking777 » Sat Feb 02, 2013 11:39 am

First of all welcome to the forum.
Second of all, you must know a little about terminals etc because you managed to run the command mintwifi, which is just the right thing to do.
Thirdly, I am not a wifi expert by any stretch of the imagination, but when I look at the output of mintwifi I can see that you have no wireless connection.

Let's start with the simple stuff (the simple stuff is all I know with regard to wifi :? ).

In your panel you will have an icon for the network manager. Left click this. Is wireless enabled?

Does this laptop have a wireless hotkey (most do, mine is Fn+F5 for example). Press whatever key combination yours is and wait for a few seconds - if it works you should get a pop up saying your connection is established.

If that doesn't work at all (ie no pop up notification) has this machine ever run windows in the past? If so was wireless switched off when windows was installed. There have been occasions in the past when this has prevented Linux from reversing the setting. A difficult question to answer because you probably don't remember - neither would I. So in this case we have to have a look in the terminal again, so open it and type:

Code: Select all

rfkill list

After pressing enter what you would hope to see is something like this:

Code: Select all

phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

If it is soft blocked try the following command:

Code: Select all

sudo rfkill unblock phy0

NB the type - phy0 - is read from the output of the first command - yours may be different so check and amend that if necessary before using the command.

Hard blocks are caused by hardware switches (ie the key combinations we tried earlier) and cannot be undone by this command.

My last shot is for you to have a look at the connection itself (they should happen automatically but maybe yours hasn't). So left click on the network manager again and click Network Settings. In the settings dialog highlight 'wireless' then click on 'options'. In there you need the ssid of your wireless network and the mode (infrastructure if you have a router) on the wireless tab, and on the wireless security tab you need the security set to the correct type (usually wpa2 personal) and your correct network password entered. I also suggest ticking the 'available to all users' box as well. If you happen to know the mac address of your wireless card you can enter it in the 'device mac address' on the first tab but this is not usually necessary.

That is about all I know on the subject, hope it helps.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

Return to “Wireless”