Mint 14: No Sound (Suddenly) / Sound Stops working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 8
Joined: Sun Aug 12, 2012 5:11 pm

Mint 14: No Sound (Suddenly) / Sound Stops working

Postby Hoffman462 » Mon Feb 04, 2013 7:02 pm

I've been using Mint 14 for some time, and have had sound working for a while. I've noticed with both 13 and 14 that on my laptop sound works, but will periodically stop working (just simply cut out).

Can someone please help me fix it, I'm pretty novice at internals like this. I really appreciate your patience and help.
I've done a bit of reading on other forums, here are some details:

I saw that this command is supposed to be good for debugging:

Code: Select all

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Likewise, I found that the codec is:

Code: Select all

cat /proc/asound/card0/codec#* | grep Codec
Codec: Creative CA0132

My modprobe.d/alsa-base.conf file (Which I believe is completely auto generated) is listed below.

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Thank you for any help, tips, suggestion or advice.
I'm completely stumped and really don't want to re-install again :(

User avatar
Level 7
Level 7
Posts: 1701
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Mint 14: No Sound (Suddenly) / Sound Stops working

Postby bimsebasse » Mon Feb 04, 2013 7:13 pm

If you're "lucky", it's the common mint/ubuntu issue of your system on its own initiative suddenly choosing another hardware device. Open Sound Settings, open the Hardware tab, and choose the hardware device not selected (if there is one).

The issue is that sometimes, for no reason, the system suddenly chooses e.g. Hi Def Audio device instead of Built-In Audio device, resulting in no sound.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!

Level 1
Level 1
Posts: 8
Joined: Sun Aug 12, 2012 5:11 pm

Re: Mint 14: No Sound (Suddenly) / Sound Stops working

Postby Hoffman462 » Mon Feb 04, 2013 7:27 pm

thank you so much!
I'll add some more details in case someone else stumbles upon this crazy feature.
Firstly, all my sound stopped working - which was kind of curious.

Hardware Tab:
in my sound dialogue or display, I noticed that my sound had not actually changed, but I did restart a few times in alternate modes. For example, I restarted in the HD mode (and got no sound) and the restarted in the Built in mode (and then the sound worked!).

Output Tab:
Then, I tried to use mplayer, but the sound failed again.
I went back to the sound dialogue, and moved around the radio button on the output tab. Trying a few different times. It seems kind of buggy, but after moving this around a few times, it seems that the output got re-initalized.

thanks alot.

Return to “Hardware Support”

Who is online

Users browsing this forum: erzis, JeremyB and 4 guests