[SOLVED] Default Game Controller Settings

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
User avatar
Level 2
Level 2
Posts: 59
Joined: Mon Feb 04, 2013 9:51 pm

[SOLVED] Default Game Controller Settings

Postby CupOfCoffee » Mon Feb 04, 2013 10:39 pm

Hello Everyone,
I need help with game controller settings. When I try playing the Java test version of Perfect 11 Soccer (p11s.net) and I have it load, I end up with the message "No default controller found. If on a UNIX system, try this command: sudo chmod a+rwx /dev/input/*". And when I enter the command in the terminal, I get this response: chmod: missing operand after 'a+rwx/dev/input/*',Try 'chmod --help' for more information.
Is there some program/command that I can use to set game controller settings?

Thanks for the help!

EDIT: Oh, and when I entered it in with the spaces, it asked me to type my password, and nothing happened after that. :?

2nd EDIT: Oh, the game loaded once I entered in the command with the spaces, so I guess my problem's fixed! :)

Thanks again!
Last edited by CupOfCoffee on Tue Feb 04, 2014 10:07 pm, edited 6 times in total.
New PC (using): Lenovo G505s - 6GB RAM, 1TB HHD, AMD A10-5750M Crossfire Graphics.

My Rusty and Trusty Old PC(not in use): Compaq Presario C500 (widescreen) - 2.5GB RAM, 1TB Solid State Hybrid, 1.86 GHz Intel Celeron M 440.

User avatar
Level 24
Level 24
Posts: 21382
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Default Game Controller Settings

Postby xenopeek » Tue Feb 05, 2013 6:07 am

I'm not sure that is something you should be doing; I don't fully understand why you would need to do this so broadly (for all files and folders in /dev/input) or what possible consequences this may have for other programs. Sounds like you don't either, but if you accept it as your risk to do something you do not know the consequences of, then you should add a whitespace between arguments in your command. I.e.:

Code: Select all

sudo chmod a+rwx /dev/input/*

Doing an Internet search, you are the only person in the world getting this error :shock: Perhaps nobody is playing the game, or something else is wrong. Are there any preferences you can set somehow?

Return to “Gaming on Linux Mint”