trying to connect Orange 3G key

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sat Jan 12, 2013 9:40 am

trying to connect Orange 3G key

Postby kannibal » Tue Feb 05, 2013 6:35 am

hi everybody

I'm trying to connect a 3G key ( Huawei E5331) From Orange to my Linux Mint 14 Nadia

I have installed usb_modeswitch but it doesn't work

At first, i tried with interface=3 but it can't send inquiry message

-------------------------------- my test ------------------------------------------------
maison pelipe # usb_modeswitch -c /etc/usb_modeswitch.conf -i 3 -m 32
Looking for target devices ...
Found devices in target mode or class (1)
Looking for default devices ...
found matching product ID
adding device
Found device in default mode, class or configuration (1)
Accessing device 005 on bus 001 ...
Getting the current device configuration ...
OK, got current device configuration (1)
Using interface number 3
Using endpoints 0x32 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
No driver found. Either detached before or never attached
Could not send INQUIRY message (error -22)

USB description data (for identification)
Manufacturer: HUAWEI
Product: HUAWEI Mobile
Serial No.: not provided
Looking for active driver ...
No driver found. Either detached before or never attached
Setting up communication with interface 3
Using endpoint 0x32 for message sending ...
Trying to send message 1 to endpoint 0x32 ...
Sending the message returned error -22. Trying to continue
Resetting response endpoint 0x81
Could not reset endpoint (probably harmless): -16
Resetting message endpoint 0x32
Could not reset endpoint (probably harmless): -22

Checking for mode switch (max. 2 times, once per second) ...
Searching for target devices ...
Searching for target devices ...
No new devices in target mode or class found

Mode switch has failed. Bye.


I have tried usbsniff on windows xp and tried all the messages and endpoint i saw but nothing works

i have also tried with a dummy message like
MessageContent = "0000000000000000111111111111111111111111111"
i could reach with interface=0, could send inquiry message, but again Mode switch has failed.

please help me !!!!! i don't know what to do


User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Re: trying to connect Orange 3G key

Postby viking777 » Tue Feb 05, 2013 9:12 am

I don't know if this post will help you:


It is very old now (though still relevant) but to me it looks as if you have tried quite a lot of the usb_modeswitch manual configuration already.

Looking at the modeswitch site: ... erence.txt

Your device is not listed as supported.

I was a heavy user of this type of device years ago and must have written thousands of words about them. They have always been a pain, particularly before modeswitch came along.

If it is of any interest to you I stopped using these modems a couple of years back and now only use 'mifi' type devices which are miles better and connect to anything, anytime, anywhere. Not much use to you right now though sadly.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
Level 9
Level 9
Posts: 2614
Joined: Sat Jul 18, 2009 3:54 am
Location: South Africa

Re: trying to connect Orange 3G key

Postby jesica » Tue Feb 05, 2013 10:27 am

modeswitch is installed in the new Mint versions,
Like viking777 said, it is the dongle itself

My Linux Counter number # 566377
IT Ninja
Happy apt-get-ing!
Linux Mint Donar # 2159

Security is the separation of an asset from a threat.

Return to “Other networking topics”

Who is online

Users browsing this forum: No registered users and 2 guests