Can't Connect to WiFi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Fri Aug 17, 2012 10:11 am

Can't Connect to WiFi

Postby rwgraves » Thu Aug 23, 2012 9:54 pm

I have recently installed Linux Mint 13 to my ASUS U56E laptop and everything works great except WiFi. I have researched this forum and tried about everything I could find on the subject, but no joy. I have removed Network Manager and installed a fresh copy of Wicd. It didn't help. My computer sees the network in my house, but, when it tries to connect, it continually fails during the password authentication phase. I have tried disabling encryption. Then it failed trying to get an IP address. I have included the listing from sudo /usr/lib/linuxmint/mintWifi/

I hope somebody is able to help. This is very discouraging.

Rick Graves

rwgraves@rwgraves-U56E ~ $ sudo /usr/lib/linuxmint/mintWifi/
* I. scanning WIFI PCI devices...
-- Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)
==> PCI ID = 8086:0885 (rev 67)
* II. querying ndiswrapper...
* III. querying iwconfig...
lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

eth0 no wireless extensions.

* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr c8:60:00:2c:c1:fc
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

* V. querying DHCP...
* VI. querying nslookup
;; connection timed out; no servers could be reached

User avatar
Level 2
Level 2
Posts: 95
Joined: Mon Jul 11, 2011 4:38 pm

Re: Can't Connect to WiFi

Postby Miami592 » Mon Aug 27, 2012 7:30 am


Welcome to the forum. I just spotted your post.

While I do not have a definite answer I may be able to steer you in the right direction.

I have experienced the same exact thing on several different machines. Nearly every time it was because a wireless adapter would not play well with the linux 3.x kernel.

To verify you may want to live-usb a copy of mint 9 isadora (linux 2.6 kernel). If your wifi works than that is your issue.

From there you could see if your particular wireless adapter has updated drivers available or go with a distro that uses the 2.6 linux kernel (mint9, crunchbang"#!"Statler, etc)

Hope this helps,

HP a6619f, 4GB ram, 500 GB HDD, Nvidia GeForce 930 GS
Mint 13 Cinnamon 64

Level 1
Level 1
Posts: 2
Joined: Fri Aug 17, 2012 10:11 am

Re: Can't Connect to WiFi (solved)

Postby rwgraves » Mon Aug 27, 2012 10:13 am


Thanks for your assistance, however, I was able to solve my problem last night with some help from the Ubuntu forum.


Level 2
Level 2
Posts: 97
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Re: Can't Connect to WiFi

Postby jaderiver » Tue Aug 28, 2012 5:52 pm


Recently read your post with interest as I also have an ASUS U56E. I eventually solved my wireless issue with terminal commands:

rmmod iwlwifi
modprobe iwlwifi bt_coex_active=0

(Needed to add sudo before every command.)

I made permanent by going into or creating this file:

sudo pluma /etc/modprobe.d/iwlwifi.conf

Then added line:
options iwlwifi bt_coex_active=0

1) Wondering if this was your solution as well?

2) Also, have you done all updates and run into wireless issues again, like me? For example, Network Manager has to be forced to service and start, and even then, wireless accounts not listed on panel bar. Have you dealt with this issue on your ASUS U56E, and found a workable solution?

ASUS U56E 64-bit Mint 18.2 MATE Sonya dualboot WIN 7
Zoom #3095 dialup USB modem

Level 1
Level 1
Posts: 2
Joined: Fri Mar 04, 2011 9:46 am

Re: Can't Connect to WiFi -- password fails

Postby scottcarson » Wed Feb 06, 2013 1:04 pm

Problem... wireless card / USB dongle drivers and firmware appear to be correctly installed but the wireless password is not accepted.

My setup: Dell Inspiron 5100 + TL-WN721N wireless USB adapter + Maya XFCE

Here's at least a possible partial work around solution that established a wireless connection for me...

Go into your wireless network connections, edit your wireless network, deselect 'connect automatically', and select 'Available to all users'. Save and close. Then left click on the network icon (bottom right) and select your wireless network. You should get the popup window requesting your network password. Enter your password and hopefully you'll connect.

The above steps established a connection for my setup. I then did some additional testing to discover that the problem is not really solved. I rebooted and the USB dongle was not automatically recognized, so again no wireless connection. If I remove and re-insert the USB dongle the dongle is recognized and I can re-establish the connection. I also deleted my wireless network listing from Network Manager and rebooted with the same results. Except this time when I re-inserted the dongle I was prompted for a password and my wireless network entry in Network Manager was automatically created including 'connect automatically'. When I now reboot my laptop with the USB dongle inserted, still do not get a wireless connection. When I remove and re-insert the dongle the wireless connection is made automatically including my password login. So something within my setup is still not correct.

Before I discovered the above partial solution, I spent several hours trying to get Maya 13 XFCE running on my older Dell Inspiron 5100 using the internal Broadcom BCM4306 (legacy) mini-pci wireless card. Once I got this same point where the password wasn't accepted, I opted to try my TP-Link TL-WN721N USB dongle (listed as Linux compatible). I re-installed Linux Mint with the USB dongle installed, but the USB dongle with the fresh install had the same problem, ie, the wireless dongle was being identified (seems the firmware and drivers were loaded), but my wireless network in the Network Manager panel was not listed and would not connect. After manually entering my wireless info and password, the connection could not be made and the request for password kept re-appearing.

Finally today I read a post that suggested the above solution which partially worked for me. Suspect this would also have worked with my Broadcom card after I had discovered all of the hardware tidbits... finding and loading the BCM legacy drivers required for the BCM4306, commenting out BCM 'blacklist' in the config file, etc.

Given several of the posts I read today suggested that an older version of linux mint (2.x kernel) might not have this problem and/or a Linux Mint version other than the XFCE desktop may work. So I may try that next. In the mean time I can get connected wirelessly and my wired connection has worked flawlessly.

Thanks again to the Linux Mint team.

Hope the above helps anyone else having this problem.

Level 1
Level 1
Posts: 2
Joined: Fri Mar 04, 2011 9:46 am

Re: Can't Connect to WiFi

Postby scottcarson » Wed Feb 06, 2013 2:46 pm

Here's an update to my previous post...

Have replaced LM XFCE with Linux Mint 13 MATE and everything is working correctly including the wireless USB dongle. Installed the iso with the dongle connected and no wired network connection. Mint recognized the wireless on startup and made the connection after I entered the password. This wireless connection supported the install process. After the install was completed, they system was re-started, wireless disabled and a wired connection established with no problems. So I believe this Mint version has installed without any problems and was much faster and easier to install than Windows. Unfortunately I don't have the Linux expertise to diagnose the problem with LM 13 XFCE.

On a side note, performance also seems to be good for this older laptop... Pentium 4, 2.4 ghz with only 640mb available RAM.

Thanks again to the LM Team.

Level 1
Level 1
Posts: 1
Joined: Fri Feb 08, 2013 2:28 pm

Re: Can't Connect to WiFi

Postby stockloanbancorp » Fri Feb 08, 2013 2:36 pm

It will help me i think thanks for helpful post

Return to “Wireless”