64 bit Mint 14 and Netgear WNDA3100 USB NIC [SOLVED]

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Tue Nov 22, 2011 6:00 pm

64 bit Mint 14 and Netgear WNDA3100 USB NIC [SOLVED]

Postby ski98033 » Fri Jan 04, 2013 1:50 am


Took me a bit to figure this all out, but since I did I thought I would post my solution for others. Steps to getting this to work with LinuxMint 14 are:

First get and install the windows drivers.
1. Download the ndiswrapper drivers (attached). Make sure you download the correct version (32 or 64 bit)
2. Enter unzip Broadcom_bcm43xx_USB_64bit_v2.zip
3. Enter cd Broadcom_bcm43xx_USB_64bit_v2
3. Enter sudo ndiswrapper -i bcmn43xx64.inf
4. Enter ndiswrapper -l to verify it worked. You should see something like:

bcmn43xx64 : driver installed
device (0846:9011) present

Now we have to get the kernel module working as the version in linux mint 14 does not have the kernel module and its source fails with I try to compile it.
5. First use synaptic and search on ndiswrapper. Make sure that ndiswrapper-dkms and ndiswrapper-source are NOT installed.
6. Download the latest version of ndiswrapper (attached)
7. Enter tar -zxvf ndiswrapper-1.58rc1.tar.gz
8. Enter cd ndiswrapper-1.58rc1
9. Enter make uninstall
10. Enter make
11. Enter sudo make install
12. Enter sudo modprobe ndiswrapper

Plug in the Netgear and enter iwconfig to see it.


(194.85 KiB) Downloaded 1179 times
(454.39 KiB) Downloaded 1197 times
(410.67 KiB) Downloaded 577 times

Level 1
Level 1
Posts: 1
Joined: Fri Mar 01, 2013 9:22 pm

Re: 64 bit Mint 14 and Netgear WNDA3100 USB NIC [SOLVED]

Postby geogeogeo » Fri Mar 01, 2013 9:28 pm


The instructions above do work for 2.4GHz with the following security options : None, WEP, WPA-PSK

I could not connect to a 5GHz nor could I with WPA2, which means that you would be limited to a 54Mbps speeds.

I suppose the problem has to do with the driver itself. Could there be a more specific updated drivers for WNDA3100V2?

User avatar
Level 1
Level 1
Posts: 28
Joined: Wed Dec 07, 2011 6:29 pm
Location: Ogden Utah USA

Re: 64 bit Mint 14 and Netgear WNDA3100 USB NIC [SOLVED]

Postby mhbell » Sun Mar 31, 2013 3:56 pm

excellent post. I followed the instructions and it worked for me after trying other posts and forums I stumbled on this one downloaded the attachments and it worked. Thank you very much

Level 1
Level 1
Posts: 7
Joined: Tue Sep 02, 2014 10:39 am

Re: 64 bit Mint 14 and Netgear WNDA3100 USB NIC [SOLVED]

Postby positonic » Wed Feb 18, 2015 4:34 pm

At step 9, I get an error about permissions, which I solved by typing

Code: Select all

, that let me run it.

But then I get an error againat step 10:

Code: Select all

positonic@positonic-System-Product-Name ~/Downloads/ndiswrapper-1.58rc1 $ makemake -C utils
make[1]: Entering directory `/home/positonic/Downloads/ndiswrapper-1.58rc1/utils'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/positonic/Downloads/ndiswrapper-1.58rc1/utils'
make -C driver
make[1]: Entering directory `/home/positonic/Downloads/ndiswrapper-1.58rc1/driver'

Cannot find kernel build files in /usr/src/linux-headers-3.13.0-37-generic
Please give the path to kernel build directory with
the KBUILD=<path> argument to make

make[1]: *** [config_check] Error 1
make[1]: Leaving directory `/home/positonic/Downloads/ndiswrapper-1.58rc1/driver'
make: *** [driver] Error 2

Return to “Wireless”