[SOLVED] wireless recognized but can't complete connection

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 7
Joined: Sun Mar 03, 2013 9:08 am

[SOLVED] wireless recognized but can't complete connection

Postby terano » Sun Mar 03, 2013 12:27 pm

2013-03-09 SOLVED: I reinstalled the system (fresh install), this helped to connect properly also to Router 2. See my reply below for a summary of the problems encountered and the solutions for them.

2013-03-08 UPDATE: Router 1 had the security configured as "WPA-PSK (TKIP)", I changed it to "WPA2-PSK (AES)" and that worked for both the Zydas and the WNA1100. Now connection works with Router 1 and 3, but still not with Router 2.

Router 2 is set now to AES as well, with the result that with both Zydas and WNA1100 I can connect to the local address of the router (, but I cannot connect to the internet. Syslog ends with this error message:

Code: Select all

Mar  7 23:19:29 kmp201 NetworkManager[758]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Mar  7 23:19:29 kmp201 NetworkManager[758]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Mar  7 23:19:29 kmp201 NetworkManager[758]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Mar  7 23:20:11 kmp201 ntpdate[3454]: Can't find host ntp.ubuntu.com: Name or service not known (-2)
Mar  7 23:20:11 kmp201 ntpdate[3454]: no servers can be used, exiting

Extra note: with the same USB Wireless device (Netgear WNA1100) on the 32bit laptop and connection to the same router I don't get this error and can connect to the internet directly. However on this 64bit laptop (with also Mint Maya installed) I can now only connect to the router and not to the internet.

Anyone an idea what I should look for?


2013-03-05 EDIT: I'm testing now with a third router and now both the internal and the WNA1100 work.

What does this mean?

With Router 1: the internal Zydas works normally, the external WNA1100 is recognized but can't make connection.
With Router 2: Zydas and WNA1100 are recognized by NetworkManager, but both can't complete connection with Router (after sending the wifi-password)
With Router 3: Zydas and WNA1100 both work directly (without additional drivers etc.)


initial post:

I've searched for hours and I know that almost identical problems already have been posted in this and other forums, however I can't solve my situation. I'd like to ask your help:

- 2 laptops both with internal wireless usb device (Zydas and Atheros AR5212)
- 2 external usb devices (Netgear WNA1100 (ar...) and a Realtek rtl8192cu)
- 2 routers

1 laptop 32bit Mint Maya MATE on the other one 64bit Mint Maya MATE.

The internal device of the 32bit (AR5212) works flawlessly with both routers and without configuring/installing extra drivers.

It's the 64bit laptop that I want to get working. The 64bit internal Zydas works fine with Router 1 but it can not bring up a complete connection with Router 2 (not with NetworkManager neither with wicd). Therefore I bought the Netgear WNA1100, because according to several hardware lists it should work properly with Maya. Well, it is recognized by NetworkManager (and detects available networks) and can be seen in lsusb etc, but it can't complete the connection-procedure neither with Router 1, nor with Router 2. I even tested with a Realtek-device with the same problem as a result (recognized and connects with the Router but can't complete the connection).

What should I do next to make the WNA1100 work? (I focus on the Netgear WNA1100, because it seems to me the best usb-adapter I have (supporting b/g/n, Maya etc)

here are some details of the system and devices:

In this case the WNA1100 is wlan1. Here are all the log entries containing wlan1 from syslog (NetworkManager-log)

This is the dmesg concerning wlan1:

Thanks in advance.

(topic title also used: "can connect to router but not to internet (usb wireless)")
Last edited by terano on Sat Mar 09, 2013 2:41 pm, edited 2 times in total.

Level 1
Level 1
Posts: 7
Joined: Sun Mar 03, 2013 9:08 am

Re: [solved] wireless recognized but can't complete connecti

Postby terano » Sat Mar 09, 2013 2:18 pm

Okay, finally I solved. For those interested I place here a summary of the problems that I encountered with Mint Maya and usb-wireless:

Problem 1: NetworkManager shows option "Enable Wireless", but it doesn't enable wireless connections after clicking it. Neighbour wireless networks were not visible in NetworkManager.

Solution: for my laptop the solution was to blacklist the acer_wmi module. To do that go to /etc/modprobe.d/ and add to blacklist.conf:

Code: Select all

# add this to /etc/modprobe.d/blacklist.conf
blacklist acer_wmi

Probably this is necesary only for some laptops in combination with Mint Maya (in my case: a Medion WAM2030, AMD 64 Dual core).
Problem 2: the internal usb wireless device (Zydas) as well as an external Netgear WNA1100 are now recognized by NetworkManager and also nearby wireless networks are shown. Password for the wireless network can be entered but after that no connection can be established.

Solution: In the router configuration change WPA (TKIP) to WPA2 (AES).
Problem 3: Now with some routers everything works fine, but I had still one router with which connection was possible, but only with the local network ( and not with the internet.

Solution: reinstall Maya (fresh install, adding the acer_wmi again to blacklist.conf). (in the past days, trying to solve the wireless problem, I've tried many different solutions, probably I changed a configuration or module that now was interfering with the wireless drivers; with a fresh reinstall this was solved).


Although I solved my problem by myself, nevertheless thanks everyone for reading my post. I hope this post will be helpfull to someone.

Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 2 guests